nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   2.6.2 (http://www.nvnews.net/vbulletin/showthread.php?t=24956)

JoeJaz2 02-16-04 05:34 PM

I am migrating to the 2.6 kernel and am happy to see that NVIDIA
supports 2.6 now. I however have had a few problems. On my Debian
partition on my Inspiron 8000, the drivers went in flawlessly. In RH 9,
however, the drivers build, install, and run correctly, but after a reboot,
the drivers fail to load. I am then required to reinstall the drivers at every reboot. I can see the kernel module in /lib/modules/2.6.2/kernel/drivers/video/nvidia.ko and the modprobe.conf contains the line:
alias char-major-195* nvidia
(I did install module-init-tools, by the way)
I am just not sure why this module is not being loaded at bootup. Has anyone encountered this problem before? I have heard of someone who encountered this problem a few years ago and worked around it by having the nvidia drivers build every boot in the init scripts, but this shouldn't be necessary. I would be very greatful if anyone had any ideas as to how to solve this problem. Thanks for taking the time to read this. Have a good day,

whig 02-17-04 05:21 PM

Same (Mandrake 9.2 64 bit, kernel 2.6.) I just put nvidia in /etc/modprobe.preload. I haven't had to do this in Debian 3.0 (kernel 2.4).

twinpower 02-19-04 07:39 PM

Thank $deity that you guys are having this issue!
The screen redraw is *very* slow now that I've upgraded this PC here at work to an nvidia card. Moving between any window / browser tab etc. is almost unbearable.
(upgraded from an ancient 3dfx voodoo 3 3000, boy was that process fun!!)
24bit color is sweet, but slow refresh... can't stand it

Here are my specs :

Currently using the 4620 drivers; however I've tried *EVERY* driver out there from minion.de and nvidia.com for the 2.6 kernel (my own custom compile... no frame buffers, no AGPGART at all, all device drivers compiled into the kernel, not as modules) and they all exhibit this headache inducing behaviour.

Geforce 4 420mx (yoinked it out of a new Dell we got for an office admin here, like she'll ever need it)
glx loads, and I can run glxgears (downloading ut2003 right now to check out preformance)

[colexa@pc44 bin]$ uname -a
Linux pc44 2.6.1 #3 Thu Feb 19 17:46:42 CST 2004 i686 athlon i386 GNU/Linux

[colexa@pc44 bin]$ lspci
00:00.0 Host bridge: Advanced Micro Devices [AMD] AMD-751 [Irongate] System Controller (rev 23)
00:01.0 PCI bridge: Advanced Micro Devices [AMD] AMD-751 [Irongate] AGP Bridge (rev 01)
00:04.0 SCSI storage controller: Adaptec AHA-2940U/UW/D / AIC-7881U
00:06.0 Ethernet controller: 3Com Corporation 3c905B 100BaseTX [Cyclone] (rev 30)
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 14)
00:07.1 IDE interface: VIA Technologies, Inc. VT82C586/B/686A/B PIPC Bus Master IDE (rev 06)
00:07.2 USB Controller: VIA Technologies, Inc. USB (rev 06)
00:07.3 USB Controller: VIA Technologies, Inc. USB (rev 06)
00:07.4 SMBus: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 10)
01:05.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX 420] (rev a3)

[colexa@pc44 bin]$ cat /proc/driver/nvidia/agp/status
Status: Enabled
Driver: NVIDIA
AGP Rate: 1x
Fast Writes: Disabled
SBA: Disabled

(kernel AGPGART has not been compiled, as a module nor into the kernel)

XF86Config snippets : (I do not use XF86Config-4)
Section "Module"
Load "glx"
Load "dbe"
Load "extmod"
Load "fbdevhw"
Load "record"
Load "freetype"
Load "type1"
Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "Videocard vendor"
BoardName "Geforce 4 mx"
Option "NvAGP" "1"
Option "NoLogo" "true"
# Option "RenderAccel" "true"
Option "HWCursor" "true"
Section "Monitor"
Identifier "Monitor0"
VendorName "Monitor Vendor"
ModelName "KLEER K7 V1A"
DisplaySize 300 220
HorizSync 30.0 - 70.0
VertRefresh 50.0 - 120.0
Option "dpms"

(yeah, I've never heard of a KLEER monitor either... we have them at work...)

All libs in /usr/lib/tls have been made to be symlinks to their corresponding /usr/lib counterparts...

I can't think of anything else right now that could be the cause of this issue... maybe I don't have an IRQ assigned to my geforce in the bios, but when I do this :

[root@pc44 lib]# cat /proc/driver/nvidia/cards/0
Model: GeForce4 MX 420
IRQ: 11
Video BIOS:
Card Type: AGP

I see IRQ 11... so I probably do have it set thusly.

Anyone find anything yet? This is totally irritating...

twinpower 02-19-04 07:41 PM

What the hell? My last post went into the TOTALLY wrong thread... way to go vbulletin. phpbb forever!

All times are GMT -5. The time now is 07:11 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.