nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Looking for a fix :( (http://www.nvnews.net/vbulletin/showthread.php?t=25006)

MNKyDeth 02-17-04 06:34 PM

Looking for a fix :(
 
Well, I just DL'ed UT2004Demo and I really wanted to do the benchmark that is posted over here http://forums.gentoo.org/viewtopic.php?t=137730 to see what I would get for performance in this game.

Unfortunately I get this error: Xlib: extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0"

Over on icculus.org it says this:
Q: I'm getting this message in UT2003 about Xlib: extension "XiG-SUNDRY-NONSTANDARD" and something about a hull!
A: Don't panic, both of these messages are harmless.

There is no exact answer on how to fix it from what I see. I am using Archlinux with the 2.6.2 kernel and 5336 nvidia driver. I do not know if this is a problem with the driver or code in the game, but if anyone knows how to fix this or get around it so I can atleast get the score for my system using the benchmark please let me know.

I am happy though that the game does atleast work and seems to perform very well.

Hmmm, guess I should post my system specs just incase.
A64 3400+
Chaintech ZNF3-150
GFFX 5900se
Corsair Pc3200LL XMS
SB Audigy2zs

whig 02-17-04 09:49 PM

ut2004demo ons-torlan?spectatoronly=true?numbots=12?quickstart=tr ue?attractcam=true -benchmark -seconds=60 -nosound

whig 02-17-04 09:50 PM

Oh yeah, then look in ~/.ut2004demo/Benchmark/Results.

MNKyDeth 02-18-04 12:10 AM

When I run those lines whig I still get the same error during the benchmark. It runs for a bit then erros with it. No results are in the folder prolly cause of it crappy out on me.

whig 02-18-04 02:22 AM

If the error message you refer to is

Xlib: extension "XiG-SUNDRY-NONSTANDARD" missing on display ":0.0".

I wouldn't worry - I get that and the game still runs great. To come to think of it I have seen it before on other game(s).

energyman76b 02-19-04 05:56 PM

Hi,

that is not an error.

And if you had read the README, you would knew it!

The gams is testing for a XiG extension, which is used, to change the resolution of the X of XiG. If have not XiG's X installed, you have not the extension.
This is not an error, XFree86 does not have and does not need this extension. This is only important, if you try to play the game on XiG, and then you are in the wrong forum.

borgzilla 02-19-04 07:24 PM

While we're at benchmarks what should be average score for my system?
I got this
ons-torlan
5.409130 / 40.373356 / 104.548996 fps
Score = 40.346645

1024x768 max quality settings
Barton 2500@2000MHz/GF4 Ti4200 128MB/1GB DDRam dual channel/Abit NF7-S
Slackware current and kernel 263 built against my system
5336 nvidia drivers
I've also had 66 processes in background


All times are GMT -5. The time now is 10:32 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.