nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Suse 9.0 nVidia driver problem (http://www.nvnews.net/vbulletin/showthread.php?t=25111)

szlevente 02-20-04 02:14 AM

Suse 9.0 nVidia driver problem
 
Hello,

I am a Linux newbie and I have a problem with the nVidia driver on my Suse Linux. After installing the distribution, and the nVidia driver v. 1.0-4496 everything worked fine for some time, but about a week ago I was no longer able to start X with my 'regular' (non-root) account. I was still able to start it by logging in as root and then typing 'startx'. I could only fix this problem by setting up a new user on my machine. But two days ago, I had the same problem again...typing 'startx' just brings up the nvidia logo, and then reverts to the command-line. I wouldn't really want to create a new user again, and transferring all my settings there, and the idea of running X as root isn't appealing either...what can be done?
I have also tried the newest nVidia driver, 5336, same result...X only runs as root.
Here is my configuration:
AMD Athlon 950 Mhz processor
K7VAZ(S)-B2 motherboard
Suse Linux 9.0, kernel version 2.4.21-166-athlon
XFree86 version 4.3.0.1
XProtocol version 11, whatever that is
nVidia Riva TNT2 M64 video card

I have attached my XF86Config file and the log file. Any help would be greatly appreciated...Thanks.

szlevente 02-20-04 02:17 AM

1 Attachment(s)
It seems I can't attach zip files....I am attaching the log/config files now.

szlevente 02-20-04 02:18 AM

1 Attachment(s)
And this is the log file...

whig 02-20-04 02:32 AM

There was one time I had that - only root could use X. Turned out the filesystem had no space free.

szlevente 02-20-04 02:44 AM

Well, thanks, I didn't think of that, it might be a good idea. I'll check as soon as I get home. However, if I create a new user, I can start X for that user...I just hate the idea of creating a new user every two weeks or so, whenever X decides it's time not to start up anymore...

p0g0 02-21-04 03:18 PM

i've had the same problem. this happened to me twice. u can solve it by replacing all the files (not the dirs) in your home dir, with the equivalent files of another user. that will get your window manager running again. let me know if it works.

szlevente 02-23-04 02:19 AM

Thanks p0g0, I'll remember that. But having all the week-end at my disposal, I just took the time and reinstalled SuSE. Of course, not before trying to install KDE 3.2 from rpm-s and messing up everything ;)

However, it all works ok now and I'm still in love with Suse Linux. :)

p0g0 02-23-04 08:05 AM

that's good - me2 :). the best part is that i even got counter-strike, wolfenstein and ut04 running.


All times are GMT -5. The time now is 02:17 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.