nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Xlib error when running glxgears (http://www.nvnews.net/vbulletin/showthread.php?t=25162)

Virtex 02-21-04 07:33 AM

Xlib error when running glxgears
 
I just install Mandrake because I couldn't get Fedora to run the new nvidia drivers under x windows. Got the drivers installed and I can get into windows, but this is the error I'm getting while trying to run glxgears:

$ glxgears
Xlib: extension "GLX" missing on display ":0.0".
Error: couldn't get an RGB, Double-buffered visual
$

anyone have an idea what the problem could be and how I could fix it?

coroner 02-21-04 08:07 AM

if you have successfully installed the nvidia-drivers edit your /etc/X11/XF86Config then and put "Load glx" into the modules-section... be sure to comment out lines containing dri and GLcore

Virtex 02-21-04 08:17 AM

1 Attachment(s)
Done that.

coroner 02-21-04 08:21 AM

and is it working? could you post the file /var/log/XFree86.0.log here too if its not?

Virtex 02-21-04 08:42 AM

1 Attachment(s)
Nope it is still not working same error. Here are the files you asked for there are 3 different ones so I'm posting them all.

Virtex 02-21-04 08:44 AM

1 Attachment(s)
2

Virtex 02-21-04 08:45 AM

1 Attachment(s)
3

coroner 02-21-04 08:50 AM

i dont know for which reason, but instead of the nvidia-supplied driver the standard nv-driver of X11 is used... could you look into /etc/X11 and tell, if there are more than one file starting with XF86Config? if this is true then copy the one config file you first sent here to /etc/X11/XF86Config and try again...


All times are GMT -5. The time now is 03:17 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.