nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   SuSE 9.0 A7N8X nForce (http://www.nvnews.net/vbulletin/showthread.php?t=25202)

Mammut 02-22-04 10:05 AM

SuSE 9.0 A7N8X nForce
 
I using SuSE 9.0 on a A7N8X mobo and had until the last kernel update no problem with installing nforce drivers. but my new kernel (from SuSE update) gives some error when using make install so does modprobe after wards. Can someone give me some guidelines. (I have same kernel and souce installed).

.................................................. .................................................. ................
linux:/home/Christian/GAMES/Driver/nforce # make install
make -C nvnet install
make[1]: Entering directory `/home/Christian/GAMES/Driver/nforce/nvnet'
mkdir -p //lib/modules/2.4.21-192-athlon/kernel/drivers/net
install -b -m 644 -o root nvnet.o //lib/modules/2.4.21-192-athlon/kernel/drivers/net
/sbin/depmod -a
depmod: *** Unresolved symbols in /lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o
depmod: *** Unresolved symbols in /lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o~
depmod: *** Unresolved symbols in /lib/modules/2.4.21-192-athlon/kernel/drivers/sound/nvaudio.o~
make[1]: Leaving directory `/home/Christian/GAMES/Driver/nforce/nvnet'
make -C nvaudio install
make[1]: Entering directory `/home/Christian/GAMES/Driver/nforce/nvaudio'
mkdir -p //lib/modules/2.4.21-192-athlon/kernel/drivers/sound
install -b -m 644 -o root nvaudio.o //lib/modules/2.4.21-192-athlon/kernel/drivers/sound
/sbin/depmod -a
depmod: *** Unresolved symbols in /lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o
depmod: *** Unresolved symbols in /lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o~
depmod: *** Unresolved symbols in /lib/modules/2.4.21-192-athlon/kernel/drivers/sound/nvaudio.o
depmod: *** Unresolved symbols in /lib/modules/2.4.21-192-athlon/kernel/drivers/sound/nvaudio.o~
make[1]: Leaving directory `/home/Christian/GAMES/Driver/nforce/nvaudio'
make -C nvgart install
make[1]: Entering directory `/home/Christian/GAMES/Driver/nforce/nvgart'
mkdir -p //usr/src/nvidia/nvgart
install -b -m 644 -o root linux-2.4.20-agpgart.diff //usr/src/nvidia/nvgart
install -b -m 644 -o root README //usr/src/nvidia/nvgart
make[1]: Leaving directory `/home/Christian/GAMES/Driver/nforce/nvgart'
linux:/home/Christian/GAMES/Driver/nforce # modprobe nvnet
/lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o: unresolved symbol alloc_skb_R2c46407b
/lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o: unresolved symbol __kfree_skb_R904b9d68
/lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o: unresolved symbol eth_type_trans_R83bf4dc2
/lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o: unresolved symbol __netdev_watchdog_up_Rfd478dac
/lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o: unresolved symbol skb_over_panic_R39fc9221
/lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o: unresolved symbol softnet_data_Re00958f6
/lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o: unresolved symbol netif_rx_R0f439c9f
/lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o:
Hint: You are trying to load a module without a GPL compatible license
and it has unresolved symbols. Contact the module supplier for
assistance, only they can help you.

/lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o: insmod /lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o failed
/lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o: insmod nvnet failed
linux:/home/Christian/GAMES/Driver/nforce # modprobe nvaudio
/lib/modules/2.4.21-192-athlon/kernel/drivers/sound/nvaudio.o: unresolved symbol remove_wait_queue_R17c614fa
/lib/modules/2.4.21-192-athlon/kernel/drivers/sound/nvaudio.o: unresolved symbol no_llseek_R01b17f7b
/lib/modules/2.4.21-192-athlon/kernel/drivers/sound/nvaudio.o: unresolved symbol register_sound_dsp_Re61d974a
/lib/modules/2.4.21-192-athlon/kernel/drivers/sound/nvaudio.o: unresolved symbol mem_map_Ra2dbbaa3
/lib/modules/2.4.21-192-athlon/kernel/drivers/sound/nvaudio.o: unresolved symbol register_sound_mixer_Rdc78d95d
/lib/modules/2.4.21-192-athlon/kernel/drivers/sound/nvaudio.o: unresolved symbol add_wait_queue_R794cb9c3
/lib/modules/2.4.21-192-athlon/kernel/drivers/sound/nvaudio.o: insmod /lib/modules/2.4.21-192-athlon/kernel/drivers/sound/nvaudio.o failed
/lib/modules/2.4.21-192-athlon/kernel/drivers/sound/nvaudio.o: insmod nvaudio failed
linux:/home/Christian/GAMES/Driver/nforce # modprobe nvnet
/lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o: unresolved symbol alloc_skb_R2c46407b
/lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o: unresolved symbol __kfree_skb_R904b9d68
/lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o: unresolved symbol eth_type_trans_R83bf4dc2
/lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o: unresolved symbol __netdev_watchdog_up_Rfd478dac
/lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o: unresolved symbol skb_over_panic_R39fc9221
/lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o: unresolved symbol softnet_data_Re00958f6
/lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o: unresolved symbol netif_rx_R0f439c9f
/lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o:
Hint: You are trying to load a module without a GPL compatible license
and it has unresolved symbols. Contact the module supplier for
assistance, only they can help you.

/lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o: insmod /lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o failed
/lib/modules/2.4.21-192-athlon/kernel/drivers/net/nvnet.o: insmod nvnet failed
.................................................. .................................................. .............

Kind regards

buche 02-26-04 05:26 AM

Ok, I have a similar problem, and recieved from the Suse support the following:

After installing and updating the kernel-source, do
download NVIDIA_nforce-1.0-0261.tar.gz
tar xvzf NVIDIA_nforce-1.0-0261.tar.gz
cd nforce
make
make install
install -m 644 nvnet/nvnet.o
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/ install
-m 644 nvaudio/nvaudio.o /lib/modules/2.4.21-override-athlon/kernel/drivers/ depmod -a

The last four lines should be one command. But, just to warn you, it didn't work for me. Install reports, that --a is an unknown option, and I couldn't figure out why.
So, try it, when you're successful tell me, otherwise, do so 2. Maybe we can both get our network-adapter to work after this malign kernel-update.

c-ya
Buche

Mammut 02-26-04 06:50 AM

I got it working now - just now :)

But thanks for you answer

And to make a long story short I had not delete my nforce folder (created by the previous nforce install) and just when right ahead with make , make install etc.

I got it working by deleting the nforce folder and untar the NVIDIA_nforce...tar.gz file again and then using Nvidia's guide.

I had also tried:
Recompiled my kernel several times (but not deleting the nforce folder) - that did not work so I went back to the original kernel (using cloneconfig).
Next move would have been a 2.6.3 kernel....

Yesssss.

buche 02-26-04 07:04 AM

Now that's funny. Installing it the way i describes it without the depmod -a command worked for me as well, but I hat to edit
/etc/modules.conf

There the alias entry in the nvidia section was commented out (?? ... there was an # at the beginning of the line). Deleted that charcter and I was fine.
But you way sounds interesting, too.

c-ya
Buche


All times are GMT -5. The time now is 12:25 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.