nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   No Screens Found...tried almost everything (http://www.nvnews.net/vbulletin/showthread.php?t=25206)

solrules 02-22-04 12:31 PM

No Screens Found...tried almost everything
 
1 Attachment(s)
Well, Im having a problem with the Nvidia drivers. Whenever I boot up, I get three screen flashes, and Mandrake 9.2 dumps me into a "command prompt". When I try startx, i get an error: no screens found. I have installed the latest drivers from this website, as well as configgured my config fieles to match. The only problem I see is in the modules.conf file, which says

alias /dev/nvidia* nvidia

, and I do not seem to have that directory/file. Im a linux n00b, and I need help with these drivers!

solrules 02-22-04 12:33 PM

1 Attachment(s)
Heres the XF86Config

solrules 02-22-04 12:34 PM

1 Attachment(s)
And the XF86Config-4

solrules 02-22-04 12:35 PM

1 Attachment(s)
And the verbose log

btw, I have a Nvidia GeForce 2 GTS, with latest drivers, Mandrake 9.2, and a Thunderbird 1.2Ghz

llindir 02-22-04 03:13 PM

Hey,

I ran into the exact same problem after I updated the drivers.

A quick fix I found was to change back the line in the Xfree4 config file from
Driver "nvidia"
to
Driver "nv".

I have no idea why this works, especially in the README file where it says you should change this to nvidia...

Hopefully someone can come up with a solution so we can use the correct driver.

solrules 02-22-04 03:23 PM

No dice...same error message after changing back to "nv" instead of "nvidia".

prplxd 02-22-04 04:28 PM

it might be ...?
 
What this sounds like to me is that in the:
device section, screen section and server layout section of the XF86Config file,
they are not matching up with the same identifier or screen.

Antonio P. 02-22-04 05:00 PM

In the Xfree log you have :
...
(!!) More than one primary device found
(--) PCI: (0:9:0) unknown vendor (0x1102) unknown chipset (0x0002) rev 8, I/O @ 0xdc00/5
(--) PCI: (1:0:0) nVidia Corporation NV15 [GeForce2 GTS/Pro] rev 164, Mem @ 0xd8000000/24, 0xd0000000/27
...

Do you have several graphic cards ? anyway, I guess xfree things you have 2.

You should try editing /etc/X11/XF86Config-4 and add a BusId line in the device section,
as

Section "Device"
Identifier "device1"
Driver "nvidia"
# add only the line below !!
BusID "PCI:1:0:0"
EndSection

By the way, your "monitor section" is bizarre, you have :

Section "Monitor"
Identifier "monitor1"
HorizSync 30-95
VertRefresh 50-180

as I have :
Section "Monitor"
Identifier "monitor1"
VendorName "Belinea"
ModelName "10 17 40"
HorizSync 30-80
VertRefresh 50-75

Your vertical refresh and horizsync seems too high. Try lowering it, it will not harm and maybe prevent some damage on your screen.

good luck !!

solrules 02-22-04 05:12 PM

Wow! That did it! Thank you, Antonio P., you just saved me from many more hours of headaches!! Again, thank you.


All times are GMT -5. The time now is 09:26 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.