nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   how do i install the nvidia drivers on suse 9.0?? (http://www.nvnews.net/vbulletin/showthread.php?t=25209)

tecate428766 02-22-04 01:45 PM

how do i install the nvidia drivers on suse 9.0??
 
please someone HELP. i've only been using linux for about 2 weeks now. the only reason i am trying to install nvidia drivers is because i want to play unrealtournament on it. where am i supposed to save the drivers at? and how do i do everything els? im so lost. will someone please tell me what to do so i can have some fun on this machine??!?!:confused:

prplxd 02-22-04 04:35 PM

??
 
You can pretty much save the download anywhere you want.

I downloaded mine to: /usr/local/src
from there, I ran sh <nvidia file name.run>, and it installed the drivers.

It will also create an ~/Nvidia directory with all its stuff.
I recommend you read the Nvidia README first.

andyrock 02-22-04 04:53 PM

boot with "linux 3" command at lilo prompt (this will take you to command line, with no X)

login as root

run your downloaded file with sh NVIDIA-XYZ.run

run sax2 with: sax2 -m 0=nvidia (0 is a number)

init 5

enjoy :-)

tecate428766 02-22-04 07:16 PM

thanks, but somehow i managed to completely avoid all of that by accident. i have no idea how, but this is waht i did.
i downloaded the drivers on a windows machine(it has a cdrw drive) put it on a cdrw disk. mounted that drive. then, it started to install. (wouldnt work while on the HDD. so then it came up with a message saying that the "file ALREADY exists on the system:continue and overwrite" so, i tabbed over to yes and, started to install, then came the error of not having kernel source installed. so i had to exit. out of frustration, i rebooted so i could start from a freash system load. and, oddly enough, the nvidia logo popped up on screen?? crazy..so i played the gear screen saver, and it was playing around 95fps in fullscreen mode. please dont ask me what i did lol.
Anyway, before i "tried" to install the nvidia drivers, i ran sax2 before anything els i did(before i even read about needing drivers and whatever) looked up the cross refference of the board 0x0322 is my model(geforce fx 5200 agp with 128MB ddr ram. its crazy how its working, im not sure if its fully 100% sure that its working correctly, but im assuming that it is. i'll install ut2003 and see if it runs fine. if i it does, i guess its safe to say that it works correctly. anyway, uhm..if anyone els reads this, i guess try doing what i did. not that i planned any of it, or know what im doing.

andyrock 02-23-04 04:41 AM

maybe you've installed it using yast online update :confused:

tecate428766 02-23-04 03:09 PM

install error??!?! AHHH
 
well, i tried YaST to install it from YOU. but, and error occured download. i think it says ftp site not responding or soemthing. anyway, i finally got the installer to run(put it on cdrw and went from there). the installer came up and worked fine, untill it said this;"ERROR: Unable to determine the NVIDIA kernel module filename" Then below that it reads "ake: *** [select_makefile] Error 1. that is after it tried to compile its own kernal interface. im not sure what to do about this. i couldnt find any help on README files or anything els that i've found. HELP AGAIN PLEASE!!! is it because im running it from the cdrom drive?



-
IBM xSeries eServer, 2.0 Celeron. 128MB DDR2100 CL2.5 RAM. not sure what chipset, but it is INTEL i beleive. PNY GeForceFX 5200 AGP 128. Samsung CDdrive(40x i think).40GB IBM HDD, Boadcom NetExtreme GigaNet interface. Samsung 955DF monitor. Also has integrated ATI RageXL(works, but not configured for multiple monitor support). SuSE 9.0 PRO(i586)- kernel 2.4.21-192-Default.

andyrock 02-23-04 04:02 PM

Install kernel source, update it with YOU, and as root do:

cd /usr/src/linux
make cloneconfig
make dep

log of

crtl alt F1

log in as root
init 3
now you can run the installer
after you finished run:
sax2 -m 0=nvidia
init 5

tecate428766 02-23-04 04:25 PM

..
 
well, i just did that last step, it came up with a question. "plug In CPU Schedulers (CONFIG_PLUGIN_SCHED) [N/y/?] (NEW)
So,....im lost from this point...shuold i type Y, N? thanks
PS, thanks alot people for helping me out.


All times are GMT -5. The time now is 10:01 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.