nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   "Unresolved symbols" message when trying to install a driver with rpm (http://www.nvnews.net/vbulletin/showthread.php?t=25217)

lautip 02-22-04 05:53 PM

"Unresolved symbols" message when trying to install a driver with rpm
 
Hello everyone,

I tryed to install this package :
NVIDIA_nforce-1.0-0261.rh90up_2.4.20_6.athlon.rpm

this is the command I used :
# rpm -i Driver_lynux_NVIDIA_nforce_1_2004Feb21.rpm

and the returned message :
depmod: *** Unresolved symbols in /lib/modules/2.4.20-6/kernel/drivers/net/nvnet.o

then when I tryed to load the nvnet module :
# modprobe nvnet
/lib/modules/2.4.20-6/kernel/drivers/net/nvnet.o: unresolved symbol skb_over_panic_R712a47ec
/lib/modules/2.4.20-6/kernel/drivers/net/nvnet.o: unresolved symbol softnet_data_Rf8a98481
/lib/modules/2.4.20-6/kernel/drivers/net/nvnet.o: unresolved symbol netif_rx_Radae146a
/lib/modules/2.4.20-6/kernel/drivers/net/nvnet.o: unresolved symbol eth_type_trans_Rbe3f1075
/lib/modules/2.4.20-6/kernel/drivers/net/nvnet.o: unresolved symbol __kfree_skb_Rdaba6be9
/lib/modules/2.4.20-6/kernel/drivers/net/nvnet.o: unresolved symbol alloc_skb_Re1ba4853
/lib/modules/2.4.20-6/kernel/drivers/net/nvnet.o: unresolved symbol __netdev_watchdog_up_R9fabb2e3
/lib/modules/2.4.20-6/kernel/drivers/net/nvnet.o:
Hint: You are trying to load a module without a GPL compatible license
and it has unresolved symbols. The module may be trying to access
GPLONLY symbols but the problem is more likely to be a coding or
user error. Contact the module supplier for assistance, only they
can help you.

/lib/modules/2.4.20-6/kernel/drivers/net/nvnet.o: insmod /lib/modules/2.4.20-6/kernel/drivers/net/nvnet.o failed
/lib/modules/2.4.20-6/kernel/drivers/net/nvnet.o: insmod nvnet failed

I use a RedHat 9.0
and "uname -r" return 2.4.20-6


I looked a little bite around this forum but I did not find this problem anywhere

So as in the installation guide of nvidia, I downloaded the souce "NVIDIA_nforce-1.0-0261.src.rpm"
and executed this command :
rpmbuild --rebuild NVIDIA_nforce-1.0-0261.src.rpm (by using "rpm --rebuild NVIDIA_nforce-1.0-0261.src.rpm", like in the guide, rpm tell me that the option "rebuild" does not exist)

I had one hundred of lines displayed in the terminal with 10% of error

and when I try to compile the driver with the "make" command and the source files from nvidia .... same things, a lot of lines and errors

:(
so unfortunately I can't use my network interface
:cry:

it's the first time I install and manage Linux by myself
so may be I made some thing wrong

I will be grateful if someone can help me :D

bjlockie 02-22-04 08:16 PM

Did you upgrade you compiler?
You could recompile without module versioning.

Do a search on goolge for "skb_over_panic".
There are tons of results, maybe something is appropriate.


All times are GMT -5. The time now is 02:02 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.