nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   Getting nForce to work with kernel 2.6.3 (http://www.nvnews.net/vbulletin/showthread.php?t=25244)

NeoXP 02-23-04 02:26 PM

Getting nForce to work with kernel 2.6.3
 
I have succesfully upgraded to kernel 2.6.3 on my ABIT NF7-s MoBo running Mandrake 9.2, but I can't get my onboard NIC to work.

I have heard of a patch to get NVIDIA_nforce-1.0-0261 to work with kernel 2.6 (nvnet-patch).

Has anyone of you succeeded and if so how did you do it? What are the steps I have to follow, which commands etc.

Thxs,
NeoXP

blueworm 02-24-04 07:21 AM

You dont need anything contained in the nvidia nforce drivers package...
Everything is allready in the kernel, as of 2.6.2.
Use forcedeth for NIC.
Use snd-intel8x0 for audio.

NeoXP 02-24-04 07:42 AM

Then please help me, how do I install them. Are they modules, should I use modprobe?

I'm a newbee but wanting to improve.

Thxs

blueworm 02-24-04 11:37 AM

Compile forcedeth as a module.
Then to load add to your /etc/modules
Code:

# echo forcedeth >> /etc/modules
What this instruction does is add the text forcedth to the bottom of your /etc/modules.
This will load forcedth every time you boot.
You can also load it manually using modprobe.
Code:

# modprobe forcedeth
Another option is to actually build into the kernel.
Then you must try and configure the eth device.
Once the module has loaded devfs will create an eth device, /dev/eth0, /dev/eth1 etc...
depending on how many lan cards you have.
Try using the mandrake GUI config tool.
I have not used Mandrake since 9.1 and to get nvnet to work I had to configure it manually.
This may not be the case with forcedeth but I am not sure.
Anyhow I you search this forum you willl find an explanation of how to configure manually for mandrake. I wrote it a year ago.
Goodluck.
http://www.nvnews.net/vbulletin/show...threadid=16954

NeoXP 02-24-04 02:35 PM

Thxs sofar Blueworm,

But please help me some more, because I'm a complete newbee to compiling and stuff!

I found in /lib/modules/2.6.3-1mdk/kernel/drivers/net the following file forcedeth.ko.gz

I presume this is the one I have to compile, but how do I do that?

When I have compiled it, I will follow the instructions in your last post and I think I can manage within Mandrake Control Center to get it up and running.

Hope to see your reply soon

Thxs:angel:

blueworm 02-24-04 02:52 PM

I took for granted that you had allready compilled the kernel.
please type this and post the result.
Code:

$ uname -r
All this does is print to stdout(terminal) kernel version actually running.
If it prints something like this...
Code:

2.6.3-1mdk
Then I think you should be good to go allready.
Just change directory to /lib/modules/2.6.3-1mdk/kernel/drivers/net.
Code:

# cd /lib/modules/2.6.3-1mdk/kernel/drivers/net
and unpack the forcedeth.ko.gz.
Code:

# gunzip forcedeth.ko.gz
Now you will have the module installed.
You can now try to load it.
Code:

# modprobe forcedeth
Now you can follow my previous post.

NeoXP 02-24-04 03:35 PM

Thxs Blueworm,

I got it working! But I didn't have to unzip it! First I unzipped it as you wrote, but when I tried modprobe I got a message saying couldn't find /lib/modules/2.6.3-1mdk/kernel/drivers/net/forcedeth.ko.gz.

So I figured what the h*ll is going on! So I did:

gzip forcedeth.ko

and then:

modprobe forcedeth

no errrors or something.

Then I went into drakconf and brought up my connection.

This proves the statement: Once you have done it, it is extremely simple

Thxs again M8!

Cigarman 02-26-04 03:00 PM

nforce anger
 
I also had some problems getting the damn thing to work under linux 2.6.3 with mandrake cooker but here's a new twist. The module nvaudio is not found when booting. If this stuff is suipposed to be included in the kernel then ???? The intel driver seemed to be just a sloppy patch even in the 2.4.xx kernel and didnt work worth diddly then either. Must we recompile the driver for 2.6 or something? I'm trying to use S/PDIF on my board as I do in winXP but no deal so far. I can see NVIDIA's reluctance to embrace the OSS model but sheesh this has been months and no leeway since 2.6.1 of the nforce drivers on their site.

blueworm 02-27-04 02:55 PM

nvaudio does not work in 2.6 Nobody has bothered to patch it since the alsa driver is better.
The problem with the alsa driver is that getting the SPDIF to work is a nightmare.

Cigarman 02-27-04 03:33 PM

well then perhaps its time to go for that M-audio 7.1 card with the spdif and see if linux of any sort supports it. This driver/hardware madness is just silly.

kenjiro 02-27-04 04:06 PM

Well... I won't go as far as talking about SPDIF.

OK, I got my nforce2 to work on my 2.6.3 kernel (Slackware Linux). I used the forcedeth and 3Com modules, OK!

For the Audio, I followed the tips I read here and I am already listening to music with XMMS and watching movies with MPlayer.

However, I am stuck with 2 speakers only. Has anyone put the Linux box to work with 6 speakers? On Windows it works.

OK, I was trying XMMS and probably the other 4 speakers were not working because the mp3 file was created to use only the 2 front speakers. However, on Windows the driver/software does that for me, splitting the music along the 6 speakers (or faking that *LOL*).

I tried an DivX movie I have on my HD, which supposedly has an AC3 5.1 sound. Even then I could only hear the sound coming from the 2 front speakers.

Ok... that's it! Anyone put the 6 speakers to work? How?

Thanks

blueworm 02-27-04 04:26 PM

check out the comments at the bottom.
http://www.alsa-project.org/alsa-doc...odule=intel8x0


All times are GMT -5. The time now is 10:30 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.