nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Latest NV Linux Driver on Alienware Laptop (http://www.nvnews.net/vbulletin/showthread.php?t=25366)

masaver 02-26-04 01:43 AM

Latest NV Linux Driver on Alienware Laptop
 
I have an Alienware Area51m Laptop dual booted with Xp and Redhat Linux Enterprise Workstation with kernel 2.4.21-4-EL... The system has the following:

P4 3.2GHz Hyperthread
1GB PC3200 Memory
AGP 8X
Nvidia GF 5600 Go
60 GB ATA 100 drive
CD/DVD-RW
Wireless a/b/g
56k Modem
Realtek 1000/100/10 Ethernet
Motherboard unknown.....

After the Redhat intall, I installed the latest Nvida Linux Drivers v-1.0-5336. I edited the XF86Config as per the readme..... When I did a startx, the system hung.... I rebuilt the drivers and kernel using make install, same result.... I modified the driver source to step down the AGP to 4x to see if that would help... Rebuilt, same result..... If I step back to the "nv" or "vesa" driver in XF86Config, I can get the X to come up, but without any graphics acceleration of course!!! I also stepped back to the previous drivers released in December.... Same result!!!! The XF86Config and XFree86.0.log files are attached in XF86Config.0.log.... Any help or suggestions would be appreciated.....

Best Regards,

Mike......

LordMorgul 02-27-04 12:04 AM

Files did not attach, if you still have problems please post them.
The FX 5600 GO is currently not listed as "supported", but it may work.

masaver 02-27-04 08:24 AM

Linux NV Drivers on Alienware
 
1 Attachment(s)
LordMorgul,

Thanks for your response.... I will try the attachments again in this post... TheXF86Config and XFree86.0.log should be in the attached alien.log file...

Best Regards,

Mike......

LordMorgul 02-29-04 07:37 PM

Your configuration looks correct and no significant errors are in the log, except for the AGP issue. I suggest you try this edit to your config, to use nVidia's AGP driver rather than AGPgart (from the kernel). Honestly, I don't know why this is no longer the default behavior.

Code:

Section "Device"

        Identifier          "Videocard0"

        Driver              "nvidia"

        VendorName "Videocard vendor"

        BoardName  "NVIDIA GeForce 4 (generic)"
        Option            "NvAGP" "1"

EndSection


masaver 03-01-04 10:13 PM

Alienware Problems
 
Lord,

Tried your last suggestion.... No luck.... Same lockup and error message.... Any other ideas????

Best Regards,

Mike.....

LordMorgul 03-01-04 11:00 PM

Motherboard?
 
Better determine what your motherboard is. :)

You can get some clues from investigating the /proc interface (fake directories). Try lspci -v
There are some tools that read the info there for you as well, such as kinfocenter.

Are there any errors when inserting the module manually? Try
modprobe nvidia
after booting into runlevel 3 (non-graphical). Also check the output of 'dmesg' for anything related to agp or AGP.

masaver 03-02-04 08:38 PM

Diagnostic output
 
1 Attachment(s)
Lord,

Please find output from lspci, dmesg, and modprobe nvidia in the attached file.... Only thing strange is that lspci calls out the nvidia card as an unknown device... I don't know if this is correct or not.....

Many Thanks,

Mike......

SparrowHawk 03-02-04 11:39 PM

Hi

I have the same laptop, and have it dual booting with XP and Redhat 9.0.

I had all kinds of strange problems in linux until I stopped using the smp kernel. Have you tried with the uniprocessor kernel ?

I get X running with their latest (5336) driver, but I have a problem where the screen will distort or flicker maybe every 2-3 minutes. I haven't been able to get that to go away, but other then that things seem to work OK.

masaver 03-03-04 07:52 AM

alien driver
 
Sparrowhawk,

Yes, I am using the uniprocessor kernel... I can't even get the SMP to boot all the way... I guess I could go back to RH9.... It had probs with the realtek ethernet driver when I tried 9 earlier, but I could download that separetely....

Mike.....

SparrowHawk 03-03-04 05:37 PM

Hi again,

Its funny you mention the ethernet driver b/c that's what I was having the most trouble with the SMP kernel under RH9. It was loading the driver, but it could never get an IP address. For some reason it would never respond to the DHCP server. The UP RH9 kernel runs smooth.

If you do move over to RH9, let me know if you experience the "flicker" every once in a while. I've seen other people complain of it with FX Go cards in other threads, but they were never the same laptop exactly. Yours is the new Area51m w/ the MSiS648FX + SiS963L AGP8X Chipset Mobo, right ?

masaver 03-03-04 06:41 PM

Area51
 
Sparrow,

I guess so.... Look back at one of the previous posts in this thread that has my output from dmesg and lspci..... My A51 was delivered 12/27/03... Not sure about backtracking to RH9 yet..... Fedora1 and Enterprise Workstation has no problems with the Realtek network interface, but the SMP problem still persists... The SMP issue is a known RedHat problem... We also experience it with our Dell Laptops here at work....

Mike....

bucketmouse 03-04-04 11:03 AM

The flicker is a hardware cursor problem, you can fix it by putting

"HWCursor" = "0"
"SWCursor" = "1"

in the devices section of XF86Config.


All times are GMT -5. The time now is 09:30 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.