nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   (EE) NVIDIA(0): Failed to load GLX (http://www.nvnews.net/vbulletin/showthread.php?t=25493)

siegelfriedel 02-29-04 06:39 AM

(EE) NVIDIA(0): Failed to load GLX
 
1 Attachment(s)
Hi from Neumünster/Germany,

I installed the new NVIDIA-driver on SuSE8.2 using an RIVA TNT2-Card.
It al worked, for I followed the README. When starting the X-Server, the NVIDIA-logo comes up

but

:~> glxinfo | grep "direct rendering"
direct rendering: No

And the log-file of XFREE gives:

(EE) NVIDIA(0): Failed to load GLX

What happend?

I have attached the XFREE86.0.log

Any help is wellcomed!

Thank´s

Siegfried

LordMorgul 02-29-04 06:16 PM

Code:

(II) LoadModule: "glx"
(WW) Warning, couldn't open module glx
(II) UnloadModule: "glx"
(EE) Failed to load module "glx" (module does not exist, 0)

Look for the module manually, it may not be installed as expected.

[16:13:13]-extensions$: ls -al /usr/X11R6/lib/modules/extensions/
drwxr-xr-x 2 root root 4096 Feb 25 11:44 .
drwxr-xr-x 9 root root 4096 Feb 25 11:44 ..
-r--r--r-- 1 root root 2141722 Feb 20 13:13 libGLcore.a
-r--r--r-- 1 root root 449362 Feb 20 13:13 libglx.a
lrwxrwxrwx 1 root root 18 Jan 14 02:18 libglx.so -> libglx.so.1.0.5328
-rwxr-xr-x 1 root root 647268 Jan 14 02:18 libglx.so.1.0.5328

How did you install the driver? Suse specific RPMs or using the installer and these instructions

siegelfriedel 03-01-04 02:14 PM

Hi, thank you for your answer.
I installed it as it is said in the README, using the installer and corrected a missing link like:

cd /usr/lib
rm libGL.so.1
ln -s libGL.so.1.0.5336 libGL.so.1

for the link was pointing at /usr/lib/libGL.so.1 -> GL/libGL.so.1.4.mesasoft

But this didn´t change a thing!

How can I get further?

The list of my extensions is:

# ls -al /usr/X11R6/lib/modules/extensions/
insgesamt 922
drwxr-xr-x 2 root root 232 2004-03-01 09:32 .
drwxr-xr-x 9 root root 1072 2004-01-31 17:50 ..
-r--r--r-- 1 root root 16684 2003-03-17 14:26 libdbe.a
-r--r--r-- 1 root root 31612 2003-03-17 14:26 libdri.a
-r--r--r-- 1 root root 168026 2003-03-17 14:26 libextmod.a
-rwxr-xr-x 1 root root 646808 2004-03-01 09:29 libglx.so.1.0.5336
-r--r--r-- 1 root root 26140 2003-03-17 14:26 librecord.a
-r--r--r-- 1 root root 39722 2003-03-17 14:26 libxtrap.a

Any ideas?

Thank´s

Siegfried

LordMorgul 03-01-04 04:08 PM

This link:
lrwxrwxrwx 1 root root 18 Jan 14 02:18 libglx.so -> libglx.so.1.0.5328

is missing from your listing, and I'm not quite sure if you said you replaced it or not. You should do this with:
Code:

cd /usr/X11R6/lib/modules/extensions/
ln -s libglx.so.1.0.5336 libglx.so

You also don't have the libglx.a, which might be a problem with your XFree86 install, I'm not sure whether it should be there on Suse or not (it is part of the main X package for RedHat / Fedora systems). First correct the link and give it a try.

siegelfriedel 03-02-04 06:30 AM

Hi,

I tried, but it is still the same.

As far as I learned till now, libglx.a is a part of mesa-rpm, which I had to uninstall, when I installed XFREE86-GLX-devel-rpm (I thought maybe they are necessary for the installation of the driver), for there was a conflict.

How can I go on?

Thank´s

Siegfried

LordMorgul 03-03-04 04:01 AM

I'm not certain whether the GLX devel package is in the way or not, but I'm pretty sure you don't need it installed for the nVidia driver. You should first reinstall any package that was there from your basic installation, and then install the driver again with them in place. No XFree86 devel packages should be necessary.

Once the libglx.so link was replaced do you still have the same error message or is there anything new in the log?

SuLinUX 03-03-04 06:38 AM

The 4620 driver should fix that, I help fix quite a few people "direct rendering: no" with this driver, it's HERE anyway.

siegelfriedel 03-03-04 11:51 AM

Hi,

after puting everything back in place as you told me, I reinstalled the driver.
This is what the log says:

(II) NVIDIA(0): AGP 2X successfully initialized
(II) NVIDIA(0): Setting mode "1024x768"
(II) Loading extension NV-GLX
(II) NVIDIA(0): NVIDIA 3D Acceleration Architecture Initialized
(II) NVIDIA(0): Using the NVIDIA 2D acceleration architecture
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(II) NVIDIA(0): v4l[/dev/video0]: using hw video scaling [YUY2].
(II) Loading extension NV-CONTROL
(WW) NVIDIA(0): Option "Rotate" is not used
(WW) NVIDIA(0): Option "CalcAlgorithm" is not used

So the GLX-module seams to be started, but still:

:~> glxinfo | grep "direct rendering"
direct rendering: No

So I´m gona give the "4620-driver" a try and will report here

Siegfried

siegelfriedel 03-03-04 01:33 PM

solved!
 
Thank you everybody!

The 4620-driver did it! So it is a driver-bug, because when I did all the recommended things (the missing link and so on) the GLX-Modul was started with the originall latest NVIDIA-driver, but didn´t work!
With the 4620 I have 1200fps on my old machine (AthlonXP1,6GH, Viper 770).

Thank´s and bye

Siegfried


All times are GMT -5. The time now is 07:23 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.