nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Mandrake 9.2 and Nvidia driver lockup (http://www.nvnews.net/vbulletin/showthread.php?t=25561)

jboschee 03-02-04 01:21 AM

Mandrake 9.2 and Nvidia driver lockup
 
I successfully installed the latest 5336 driver. When I type startx the screen goes black and the computer is hard locked. I have to hard reset. I have used Redhat 9 on the same machine with success with the same driver version. When I do a modprobe nvidia it tells me that it will taint the kernel if that helps any. I did install the kernel sources rpm. For some reason it doesn't create a log when I use the nvidia driver so I didn't include it here.

Geforce4 TI4600
Driver 5336
Mandrake 9.2 default install
Bios version 4.25.00.37
Intel Pentium 4 2.66
Asus P4S8X-X Motherboard

Here is the XF86CONFIG-4

# File generated by XFdrake.

# ************************************************** ********************
# Refer to the XF86Config man page for details about the format of
# this file.
# ************************************************** ********************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "en_US"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/usbmouse"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "1280x1024 @ 60 Hz"
HorizSync 31.5-64.3
VertRefresh 50-85

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "NVidia"
BoardName "NVIDIA GeForce4 (generic)"
Driver "nvidia"
Option "IgnoreDisplayDevices" "DFP, TV"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 15
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 16
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 24
Virtual 1280 1024
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
Screen "screen1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
EndSection

jboschee 03-03-04 11:20 AM

Just wanted to post my solution to my problem.

All I needed was this line in the device section

Option "NvAGP" "0"

Maybe that will help some.

Jeff


All times are GMT -5. The time now is 06:37 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.