nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Problems with FX 5200 and twinview (tv-out) under Mandrake 9.2 (http://www.nvnews.net/vbulletin/showthread.php?t=25609)

mcordero 03-02-04 10:01 PM

Problems with FX 5200 and twinview (tv-out) under Mandrake 9.2
 
I bought an ASUS V9520/TD card with a FX 5200 chip (lspcidrake tells me it's a 0x0322 => FX5200). I can't get it to work under Mandrake 9.2 (updated) with drivers ver5336 from mandrakeclub.com. I already tried with my old XF86Config-4 from a Geforce 4 MX440 as well as editing the twinview options myself.
The funny thing is I that I get perfect tv output from the very beginning until my login manager pops up (Mandrake uses Framebuffer during start-up), then the usual black screen...
Hardware? AthlonXP 2000, 512MB RAM, analogue 18'' flat screen.
Any help appreciated, thanks.
Marcio Cordero

My XF86Config:
# File generated by XFdrake.

# ************************************************** ********************
# Refer to the XF86Config man page for details about the format of
# this file.
# ************************************************** ********************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection

Section "ServerFlags"
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
#DontZap # disable <Crtl><Alt><BS> (server abort)
EndSection

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer
EndSection

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "de_CH"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
EndSection

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
HorizSync 30-80
VertRefresh 60-85

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "NVidia"
BoardName "NVIDIA GeForce FX (generic)"
Driver "nvidia"
Option "DPMS"
Option "TVStandard" "PAL-B"
Option "SecondMonitorHorizSync" "30-50"
Option "TwinViewOrientation" "Clone"
Option "NvAGP" "3"
Option "MetaModes" "1280x1024,800x600; 800x600,800x600; 640x480,640x480"
Option "SecondMonitorVertRefresh" "60"
Option "TwinView"
Option "TVOutFormat" "COMPOSITE"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 15
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 16
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 24
Virtual 1280 1024
EndSubsection
EndSection

Section "ServerLayout"
Identifier "layout1"
Screen "screen1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
EndSection

vencik 03-03-04 02:49 AM

did you try the Linux driver from nVIDIA (maybe it's the same, but I don't know)? I have a Soltek SL-5200-CD with FX5200, too and it's working just fine with the driver on Mandrake 9.2. It's closed source, though. :-(

mcordero 03-03-04 06:04 AM

No, I didn't yet, but the mandrakeclub rpm is supposed to be just the in-rpm-repackaged version of the 5336 official nvidia drivers. I will try them but I don't believe that's the reason. Thanks for the answer though... :-)

mcordero 03-03-04 06:31 AM

Maybe some more details:
- nvtv tells me there's "no supported card"
- yanc tells me sometimes "twinview options are disabled" but even when it doesn't I still can't change the twinview options
- I got ONCE everything OK and could get my desktop displayed on tv. One log out and nothing worked again
- I get the following rather interesting warnings in /var/log /Xfree86.0.log:

(WW) NVIDIA(0): 3 display devices connected, but only 2 supported;
(WW) NVIDIA(0): adjusting...
( I only have a flat panel and the tv thru a composite cabel and a scart connector. I googled around and all I found was the same warning with 2 display... 1 supported, so that seems to be rather unique!)

(II) NVIDIA(0): Connected display device(s): CRT-0, CRT-1, TV-0
(???)

(**) NVIDIA(0): TwinView enabled
(it seems to be enabled. Even a decoder is found:)

(--) NVIDIA(0): Detected TV Encoder: NVIDIA

Hope that helps a little...


All times are GMT -5. The time now is 12:37 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.