nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   RH 8 Problem when insmod'ing NVdriver (http://www.nvnews.net/vbulletin/showthread.php?t=2566)

dmp 10-05-02 07:59 AM

RH 8 Problem when insmod'ing NVdriver
 
I have compiled the kernel module src rpm on RH 8 ok, but when I try to insmod it I get the following error:

[root@localhost root]# insmod NVdriver
Using /lib/modules/2.4.18-14/kernel/drivers/video/NVdriver
/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver: The module you are trying to load (/lib/modules/2.4.18-14/kernel/drivers/video/NVdriver) is compiled with a gcc
version 2 compiler, while the kernel you are running is compiled with
a gcc version 3 compiler. This is known to not work.
[root@localhost root]#

The odd thing is that I DID compile the module on my RH8 system (which only has gcc3.2 on)!

Does anybody have any ideas about ways to get round this problem?

Many thanks,

David

bwkaz 10-05-02 09:09 AM

What does cc -v tell you, and what about echo $CC? If the $CC one prints something other than nothing and other than cc, then try <that executable> -v. For example, if it prints gcc-i868-pc-linux-gnu or something like that, then do a gcc-i686-pc-linux-gnu -v instead.

I know gcc 3.2 is the default on RH 8, but it might be that 2.96 was also installed, for some (strange) reason.

dmp 10-05-02 08:19 PM

Both those indicated 3.2, which surprised me slightly.

However, I remember that part of the NVidia kernel module is closed source (compiled) with an open source wrapper, so I was wondering if perhaps the closed source bit was gcc 2.9x compiled. :confused:

However, I tried again tonight with the newer kernel src rpm (3123) and had no problems at all. Before I had 2960, and I wonder if that was the cause, as I can't think of anything else..

Thanks for your suggestions though - much appreciated :)

bwkaz 10-05-02 09:14 PM

I don't know what Module-nvkernel is compiled with, but it worked for you with gcc 3.2, and it works here with the same, so I think it's OK.

Oh, actually, this might have been a problem a while ago (just before 3123) with RedHat's version of modutils. If that was the issue, then using the latest stable version of modutils (off ftp.kernel.org somewhere, I believe) fixed the problem. But if you got it working, then it wasn't that.


All times are GMT -5. The time now is 11:53 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.