nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   forcedeth issue(s) (http://www.nvnews.net/vbulletin/showthread.php?t=25697)

trevallion 03-05-04 12:24 AM

forcedeth issue(s)
 
Alright, so I already posted a bit on my ethernet problem, and I realize that this is a problem this forum sees tons of. But my card simply wont initlize. Now after trying things on my own for a day, then combing the net for two days, I have figured these things out.

1) the drivers are odd for onboard ethernet in nforce (for the sound to...)
2) there is both a 'tar' and an 'rpm' that contain drivers for these issues
3) forcedeth is the way to go to get your eth working, and it is included on some 2.6 kernels

here are my problems:

1) the network device manger sez "device does not seem to be present... delaying installation" this is also, by the way, what the fedora core returns when starting up
2) either I am doing something wrong (probably) or the files don't work, even after following evey set of instructions I found the same error occurs
3) I am still new enough not to know how to get those forcedeth drivers into, onto, whatever. I see this long text (?) files of code (?) how do I get these to work? My kernel is 2.4.22 i believe

NeoXP 03-05-04 02:14 AM

Please inform us with the following:

1. what distro do you use?

2. get into a terminal and type:

uname -r

this will tell you what kernel you are using.

/edit/ after reading your previous post on this forum, there 's another thing we like to know:

3. do you have a AMD64 processor with nForce3 chipset?

trevallion 03-05-04 02:10 PM

alrighty
 
No problem

I'm trying Fedora Core 1 distro

Its running 2.4.22 kernel

The specs on your signature match mine almost exactly
These are the differences
AMD 2800+
only 1 stick of 512 mb ram
and I 'm running the onboard NVIDIA GeForce 4 chipset

does this mean its nForce3?

isn't Athalon AMD's 64 bit architecture?
sorry for not seeing need for this earlier...

NeoXP 03-06-04 05:55 AM

no prob!

First of all, I can only describe how it works for Mandrake, I'm not sure if it will work with Fedora, maybe a Fedora-guru can be of some assistance here.

Second, if you have an AMD 2800+ you are running the nForce2 chipset, this means you'll have to install another driver.

You can get it by clicking here:

click me

after you have downloaded it get into a terminal and type:

su -

followed by your root-password, this will give you complete controll.

go to the dir where you downloaded the nForce driver and type:

rpm --rebuild NVIDIA_nforce1.0-0261.src.rpm

a lot of info will pass your screen, just look for a line like:

wrote /usr/.....

go to this dir where you will find your new compiled nForce-driver

type:

rpm -ivh NVIDIA_nforce......rpm

this will install the nForce-driver called nvnet

All that you have to do now is configure your network, don't know how to do this in Fedora.

Good Luck

NOTE For mandrake I had to install the kernel-source also, don't know if it is already installed in Fedora, maybe a Fedora-guru has the answer to this.

trevallion 03-09-04 01:47 AM

ok, sorry i missed for a few days. Now this file, is it only about 90kb? because i grabbed it, and tryed to take it off a 1.44 floppy (remember, my problem is with ethernet on this machine) and it does not seem to find the file. I'm still chewin on it though, hopefully the light will break soon!!

NeoXP 03-09-04 02:09 AM

It is indeed 91 kB, don't know why you can't find it though. I don't think it is because of the small size!

trevallion 03-12-04 10:30 AM

No, I just thought that I might not have gotten the whole file. It still doesn't seem to work with my DHCP. I tried ifconfig and it showed no packets sent on eth0 interface, though it should sent request packets out, shouldn't it?


All times are GMT -5. The time now is 11:10 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.