nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   5336 - startx gives black screen and XIO: fatal IO error 104 (http://www.nvnews.net/vbulletin/showthread.php?t=25740)

scottwaye 03-06-04 10:58 AM

5336 - startx gives black screen and XIO: fatal IO error 104
 
1 Attachment(s)
Hope someone at Nvidia has time to help with this as it would appear from the forum that I am not alone.

System: Gigabyte GA7DX-F7 Mobo with Athlon XP (2000+) GeForce2 MX 200 (32Mb RAM)

I used to run kernel 2.4.20 with the old Nvidia driver 3xxx (don't remember the exact numbers) and it was fine. I upgraded the kernel to 2.6.2 (without APM or framebuffer support, but with ACPI) and downloaded the 5336 Nvidia installer.

I ran the installer, it had no suitable driver, it tried the ftp site but couldn't find anything there so it continued to build a driver which succeeded. So far so good, the installer worked nicely and was easy to use. I then took the sample XF86Config file that came with the driver and modified it a bit for my keyboard/mouse and monitor settings. Then I tried to start X with:

startx -- -layout AGP -logverbose 5 -verbose 5

This gives a black screen. Switching consoles with ALt-F2, Alt-F1 shows the tail of the X log (attached) and the following message :

XIO: fatal IO error 104 (Connection reset by peer) on X server ":0.0"
after 0 requests (0 known processed) with 0 events remaining.

It appeared that the Nvidia driver was trying to probe for the APM module which I don't use (its useful for machines with batteries and I use ACPI) so I added

install char-major-10-134 /bin/true

to modprobe.conf

After that change there is nothing reported in /var/log/messages or debug but I get this in syslog:

Mar 6 16:52:34 bollox kernel: Unable to handle kernel NULL pointer dereference
at virtual address 00000080
Mar 6 16:52:34 bollox kernel: *pde = 00000000

lsmod gives:

Module Size Used by
nvidia 2074792 2
nls_iso8859_1 3968 5
nls_cp437 5632 2


which looks like the nvidia module loaded ok?

I guess one obvious question which should be easy to answer is: does the Nvidia driver require APM?

Thanks for any light shone on this problem.

scottwaye 03-06-04 11:14 AM

and heres the log
 
1 Attachment(s)
And the log


All times are GMT -5. The time now is 03:50 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.