nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   kernel 2.4.23-pre6 and nforce2 linux driver (http://www.nvnews.net/vbulletin/showthread.php?t=25741)

zdenko 03-06-04 11:19 AM

kernel 2.4.23-pre6 and nforce2 linux driver
 
Hello!
I tried to install NVIDIA-Linux-x86-1.0-5336 video driver from Nvidia on my Slackware 9.1 distro with kernel 2.6.3--bk8.
At compilig the driver I got error:
*****************************************
nvidia-installer log file '/var/log/nvidia-installer.log'
creation time: Sat Mar 6 13:05:21 2004

option status:
license pre-accepted : false
update : false
force update : false
expert : false
uninstall : false
driver info : false
no precompiled interface: false
no ncurses color : false
query latest driver ver : false
OpenGL header files : false
no questions : false
silent : false
XFree86 install prefix : /usr/X11R6
OpenGL install prefix : /usr
Installer install prefix: /usr
kernel source path : (not specified)
kernel install path : (not specified)
proc mount point : /proc
ui : (not specified)
tmpdir : /tmp
ftp site : ftp://download.nvidia.com

Using: nvidia-installer ncurses user interface
-> License accepted.
-> There appears to already be a driver installed on your system (version: 1.0-
5336). As part of installing this driver (version: 1.0-5336), the existing
driver will be uninstalled. Are you sure you want to continue? ('no' will a
bort installation) (Answer: Yes)
-> No precompiled kernel interface was found to match your kernel; would you li
ke the installer to attempt to download a kernel interface for your kernel f
rom the NVIDIA ftp site (ftp://download.nvidia.com)? (Answer: No)
-> No precompiled kernel interface was found to match your kernel; this means
that the installer will need to compile a new kernel interface.
-> Kernel source path: '/lib/modules/2.6.3-bk8/build'
-> Performing cc_version_check with CC="cc".
-> Cleaning kernel module build directory.
executing: 'cd ./usr/src/nv; make clean'...
rm -f -f nv.o os-agp.o os-interface.o os-registry.o nv.o os-agp.o os-interfa
ce.o os-registry.o nvidia.mod.o
rm -f -f build-in.o nv-linux.o *.d .*.{cmd,flags}
rm -f -f nvidia.{o,ko,mod.{o,c}} nv_compiler.h *~
-> Building kernel module:
executing: 'cd ./usr/src/nv; make module SYSSRC=/lib/modules/2.6.3-bk8/build
'...
*** Warning: Overriding SUBDIRS on the command line can cause
*** inconsistencies
make[3]: `arch/i386/kernel/asm-offsets.s' is up to date.
CHK include/asm-i386/asm_offsets.h
echo \#define NV_COMPILER \"`cc -v 2>&1 | tail -n 1`\" > /tmp/selfgz972/NVID
IA-Linux-x86-1.0-5336-pkg1/usr/src/nv/nv_compiler.h
CC [M] /tmp/selfgz972/NVIDIA-Linux-x86-1.0-5336-pkg1/usr/src/nv/nv.o
/tmp/selfgz972/NVIDIA-Linux-x86-1.0-5336-pkg1/usr/src/nv/nv.c:1185: warning:
initialization from incompatible pointer type
CC [M] /tmp/selfgz972/NVIDIA-Linux-x86-1.0-5336-pkg1/usr/src/nv/os-agp.o
CC [M] /tmp/selfgz972/NVIDIA-Linux-x86-1.0-5336-pkg1/usr/src/nv/os-interf
ace.o
CC [M] /tmp/selfgz972/NVIDIA-Linux-x86-1.0-5336-pkg1/usr/src/nv/os-regist
ry.o
LD [M] /tmp/selfgz972/NVIDIA-Linux-x86-1.0-5336-pkg1/usr/src/nv/nvidia.o
Building modules, stage 2.
arch/i386/kernel/.msr.mod.o.cmd:1: warning: NUL character seen; rest of line
ignored
arch/i386/kernel/.msr.mod.o.cmd:2: warning: NUL character seen; rest of line
ignored
arch/i386/kernel/.msr.mod.o.cmd:2: *** missing separator. Stop.
make[2]: *** [modules] Error 2
nvidia.ko failed to build!
make[1]: *** [module] Error 1
make: *** [module] Error 2
-> Error.
ERROR: Unable to build the NVIDIA kernel module.
ERROR: Installation has failed. Please see the file
'/var/log/nvidia-installer.log' for details. You may find suggestions
on fixing installation problems in the README available on the Linux
driver download page at www.nvidia.com.
*****************************************

What is wrong? Is there any chance to compile and instal the driver.

Please help.

The driver compiles and works on my current working kernel 2.4.23-pre6.

Zdenko from Slovenia

energyman76b 03-06-04 12:08 PM

Hi,

why this completly wrong thread title?

For your problem. Maybe you should rebuild your kernel with msr built in (why build it as modul? you have to use it anyway), instead of a modul, maybe this will solve your problem.

And if msr is built in, try a 'real' kernel like 2.6.3 or 2.6.4-rc. The bk-versions don't even have to build...
But maybe I am totally wrong.. but I am one of the many nvidia&2.6 users without problems.

zdenko 03-09-04 05:31 AM

Thank's, solved
 
Thank, you!

I solved the problem. I eliminated MSR from compiling (none: in or module).

for the kernel version:

I use Philips SAA7134 based TV card, for which the kernel patch for that particular subversion was available. (At the end I finished with that subversion with dead TV card - module returned i2c errors).

In the feature I'll stick with more reliable versions.
k 2.6.x was for curiosity, else I use 2.4.23 kernel.


Regards!

Zdenko

p.s.: Regarding Nvidia video driver compiling/installing: I had troubles with executable.
So I used -x and unpack it. After "make install" all was completed without a single error!


All times are GMT -5. The time now is 04:21 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.