nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Problem with Geeforce 4MX 440 and Mandrake (http://www.nvnews.net/vbulletin/showthread.php?t=25794)

salemvam 03-07-04 05:02 PM

Problem with Geeforce 4MX 440 and Mandrake
 
1 Attachment(s)
=================================================
Here is my problem
=================================================
Past year I bought some components and builded the PC now I'm using. Since that day I had discovered day by day new things to enjoy my Linux experience but something happens with Mandrake and nVidia drivers.
=================================================
Since I got my new PC running, I have tried some Linux distros like MEPIS (Debian based), Red Hat, Mandrake... I could use nVidia drivers with all them... but Mandrake. It's always the same problem (with whathever version of Mandrake):

I install the nVidia driver, I edit the "XFConfig-4" file, I start X server by typing "init 3" and I can see the nVidia logo and the KDM asking for my username and password. Once I type them and push enter the KDE loads without problem but a few seconds after the splashscreen dissapear, the PC hangs without remedy. The keyboard and mouse doesn't respond anymore and I must do a RESET to restart the computer. Sometimes the start sound of KDE sounds in a ring (once and once again till I do the dirty restart).
=================================================
Here goes the description of my PC:

- Video Card: NVIDIA GeForce 4 MX 440 (64Mb)
- Driver version: Whatever I try: the latest try was 5336
- Distro: Mandrake 9.1
- Video BIOS ver.: The info contained in "/proc/driver/nvidia/cards/0" (bold issues)
- Model: GeForce4 MX 440
- IRQ: 5
- VideoBios: 04.17.8e.61.00
- Cartype: AGP
- Processor: Genuine Intel Pentium IV 2533Mhz
- Mainboard: P4VXASD2+
=================================================
The "XFree86.0.log" and "XFConfig-4" files are zipped and attached to this message.
=================================================
Thanks for your support and for read this.

Flokater 03-09-04 03:25 PM

Hi

I got a similar Problem, but a bit different. In single Monitor use, all was working fine. In TwinView Mode, X crashed after a few Seconds. Most of the Time i can move the Mouse, but cant do anything else (CTRL+ALT+F1). So i have to hard reset the Computer.
I changed my XF86Config-4 in Section [Device] :
Option "NvAGP" "0"

After this change, everything works fine.
So im sure, it was a problem with the AGP.

So please put also your Bios Informations for AGP
like "Allocate IRQ to PCI-VGA" in this Thread.

Its not Mandrakes Fault if its not running on your System.
I use the NVIDIA Driver since Mandrake 9.1, and it always worked.

Best regards
Flokater


p.s.: Im using Mandrake 9.2

salemvam 03-11-04 10:53 AM

==============================================
Hello
==============================================
Hi everybody, here goes my BIOS information related with AGP I could find through it sections:

---> Advanced Setup
|-> AGP mode: x1 (*)
|-> AGP Comp. Driving: Auto
|-> AGP Aperture size: 64Mb
---> PCI / Plug and Play Setup
|-> Allocate IRQ to PCI VGA: Yes

(*) = I modificated this parameter several times to probe them all with Mandrake. All the possibilities are x1, x2 and x4... and no one works with MDK.
==============================================
My system BIOS is AMIBIOS (American Megatrends)
==============================================
I hope this ease the way to solve my problem. Thanks.

salemvam 04-22-04 02:49 PM

Re: Problem with Geeforce 4MX 440 and Mandrake
 
Hello Guys:
================================================== ============
No option added ("NvAGP" "2", "0"... ) worked for me... I think I have Gremlins in my PC. After all before the installation of a recently downloaded version of Mandrake 10.0. The same problem of always: my screen freezes and I only can move the cursor a few seconds after KDE or GNOME starts... sometimes freezes before the session is completely loaded. I only can see a "beautiful" screenshot of my desktop (and sometimes the sound in a ring at the background) and the only thing to do is a dirty restart.
================================================== ============
I don't know what's the problem: with Windows (98se or XP for example) my nVidia works fine. With Mepis (Debian) or Red Hat works too... but with MDK is a nightmare installing the nVidia drivers because after uninstalling them with the correct command line program, OpenGL doesn't work at all and I must reinstall Mandrake again if I want play again with Frozen Bubble for example.
================================================== ============
I read that the Commercial version of Mandrake 10.0 does support nVidia drivers and the Downloadable version (this is what I'm using now) doesn't... is this true?
================================================== ============
Salutations from Tenerife, and thanks for your time reading this.


All times are GMT -5. The time now is 08:06 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.