nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   NVIDIA NIC driver installation problems in Suse 9.0 (http://www.nvnews.net/vbulletin/showthread.php?t=25956)

mbekkail 03-11-04 10:57 PM

NVIDIA NIC driver installation problems in Suse 9.0
 
I have M7NCG mobo by Biostar with onboard NVIDIA nForce MCP Networking Adapter and just installed Suse 9.0 as a second OS (wxppro is 1st). Now, I downloaded the NIC driver of the NVIDIA website and followed installation instructions. Here is the log of the RPMBUILD command:

mbekkali@linux:~> su
Password:
linux:/home/mbekkali # cd Linux
linux:/home/mbekkali/Linux # dir
total 110652
drwxr-xr-x 2 mbekkali users 288 2004-02-24 15:19 .
drwxr-xr-x 24 mbekkali users 1360 2004-02-24 15:54 ..
-r-xr-xr-x 1 root root 92517 2004-02-24 10:45 NVIDIA_nforce-1.0-0261.src.rpm
-r-xr-xr-x 1 mbekkali users 57486 2004-02-06 08:19 NVIDIA_nforce-1.0-0261.suse90.i586.rpm
-r-xr-xr-x 1 root root 378880 2003-05-06 12:39 NVIDIA_nforce-1.0-0261.tar[1]
-r-xr-xr-x 1 root root 87301 2004-02-24 10:44 NVIDIA_nforce-1.0-0261.tar.gz
-r-xr-xr-x 1 root root 112567600 2004-02-07 11:57 Suse Linux Wine Rack.rar
linux:/home/mbekkali/Linux # rpmbuild --rebuild NVIDIA_nforce-1.0-0261.src.rpm
Installing NVIDIA_nforce-1.0-0261.src.rpm
warning: user buildmeister does not exist - using root
warning: group adm does not exist - using root
warning: user buildmeister does not exist - using root
warning: group adm does not exist - using root
warning: user buildmeister does not exist - using root
warning: group adm does not exist - using root
warning: user buildmeister does not exist - using root
warning: group adm does not exist - using root
warning: user buildmeister does not exist - using root
warning: group adm does not exist - using root
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.16528
+ umask 022
+ cd /usr/src/packages/BUILD
+ echo '---- Copying Sources ----'
---- Copying Sources ----
+ cd /usr/src/packages/BUILD
+ rm -rf nforce
+ /usr/bin/gzip -dc /usr/src/packages/SOURCES/nvnet.tgz
+ tar -xvvf -
drwxr-xr-x buildmeister/adm 0 2003-05-06 12:36:14 nforce/
drwxr-xr-x buildmeister/adm 0 2003-05-06 12:39:37 nforce/nvnet/
-r--r--r-- buildmeister/adm 16904 2003-05-06 12:39:37 nforce/nvnet/adapter.h
-r--r--r-- buildmeister/adm 794 2003-05-06 12:39:37 nforce/nvnet/basetype.h
-r--r--r-- buildmeister/adm 6752 2003-05-06 12:39:37 nforce/nvnet/nvnet.h
-r--r--r-- buildmeister/adm 4437 2003-05-06 12:39:37 nforce/nvnet/os.h
-r--r--r-- buildmeister/adm 4749 2003-05-06 12:39:37 nforce/nvnet/phy.h
-r--r--r-- buildmeister/adm 37870 2003-05-06 12:39:37 nforce/nvnet/nvnet.c
-rw-r--r-- buildmeister/adm 21504 2003-05-06 12:39:37 nforce/nvnet/nvnetlib.o
-r--r--r-- buildmeister/adm 3088 2003-05-06 12:39:37 nforce/nvnet/Makefile
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd nforce
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ cd /usr/src/packages/BUILD
+ /usr/bin/gzip -dc /usr/src/packages/SOURCES/nvaudio.tgz
+ tar -xvvf -
drwxr-xr-x buildmeister/adm 0 2003-05-06 12:39:38 nforce/
drwxr-xr-x buildmeister/adm 0 2003-05-06 12:39:38 nforce/nvaudio/
-r--r--r-- buildmeister/adm 2522 2003-05-06 12:39:38 nforce/nvaudio/Makefile
-r--r--r-- buildmeister/adm 58241 2003-05-06 12:39:38 nforce/nvaudio/nvcrush.c
-r--r--r-- buildmeister/adm 32174 2003-05-06 12:39:38 nforce/nvaudio/nvhw.c
-r--r--r-- buildmeister/adm 33857 2003-05-06 12:39:38 nforce/nvaudio/nvmain.c
-r--r--r-- buildmeister/adm 8314 2003-05-06 12:39:38 nforce/nvaudio/nvrec.c
-r--r--r-- buildmeister/adm 26382 2003-05-06 12:39:38 nforce/nvaudio/nvspdif.c
-r--r--r-- buildmeister/adm 14709 2003-05-06 12:39:38 nforce/nvaudio/nvwavout.c
-r--r--r-- buildmeister/adm 4546 2003-05-06 12:39:38 nforce/nvaudio/chaninfo.h
-r--r--r-- buildmeister/adm 5065 2003-05-06 12:39:38 nforce/nvaudio/nvhw.h
-r--r--r-- buildmeister/adm 1570 2003-05-06 12:39:38 nforce/nvaudio/nvioctl.h
-r--r--r-- buildmeister/adm 1392 2003-05-06 12:39:38 nforce/nvaudio/nvrec.h
-r--r--r-- buildmeister/adm 1618 2003-05-06 12:39:38 nforce/nvaudio/nvspdif.h
-r--r--r-- buildmeister/adm 1499 2003-05-06 12:39:38 nforce/nvaudio/nvwavout.h
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd nforce
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ cd /usr/src/packages/BUILD
+ /usr/bin/gzip -dc /usr/src/packages/SOURCES/nvmaster.tgz
+ tar -xvvf -
drwxr-xr-x buildmeister/adm 0 2003-05-06 12:39:36 nforce/
-r--r--r-- buildmeister/adm 1091 2003-05-06 12:39:36 nforce/Makefile
-r--r--r-- buildmeister/adm 5404 2003-05-06 12:39:36 nforce/NVLicense.txt
-r--r--r-- buildmeister/adm 18007 2003-05-06 12:39:36 nforce/GNULicense.txt
-r--r--r-- buildmeister/adm 23612 2003-05-06 12:39:36 nforce/ReleaseNotes.html
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd nforce
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ cd /usr/src/packages/BUILD
+ /usr/bin/gzip -dc /usr/src/packages/SOURCES/nvgart.tgz
+ tar -xvvf -
drwxr-xr-x buildmeister/adm 0 2003-05-06 12:39:38 nforce/
drwxr-xr-x buildmeister/adm 0 2003-05-06 12:39:38 nforce/nvgart/
-r--r--r-- buildmeister/adm 590 2003-05-06 12:39:38 nforce/nvgart/Makefile
-r--r--r-- buildmeister/adm 1231 2003-05-06 12:39:38 nforce/nvgart/README
-r--r--r-- buildmeister/adm 14033 2003-05-06 12:39:38 nforce/nvgart/linux-2.4.20-agpgart.diff
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd nforce
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.16528
+ umask 022
+ cd /usr/src/packages/BUILD
+ cd nforce
+ echo '---- Building Drivers ----'
---- Building Drivers ----
+ make
/var/tmp/rpm-tmp.16528: line 24: make: command not found
error: Bad exit status from /var/tmp/rpm-tmp.16528 (%build)


RPM build errors:
user buildmeister does not exist - using root
group adm does not exist - using root
user buildmeister does not exist - using root
group adm does not exist - using root
user buildmeister does not exist - using root
group adm does not exist - using root
user buildmeister does not exist - using root
group adm does not exist - using root
user buildmeister does not exist - using root
group adm does not exist - using root
Bad exit status from /var/tmp/rpm-tmp.16528 (%build)
linux:/home/mbekkali/Linux #

Apparently, the driver is not installed since the installation generates the error messages. The problem is that I cannot find how to handle such errors since troubleshooting section of readme accompanying the driver does not have such.

IFCONFIG gives me

linux:/home/mbekkali # ifconfig
lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0
inet6 addr: ::1/128 Scope:Host
UP LOOPBACK RUNNING MTU:16436 Metric:1
RX packets:115 errors:0 dropped:0 overruns:0 frame:0
TX packets:115 errors:0 dropped:0 overruns:0 carrier:0
collisions:0 txqueuelen:0
RX bytes:7683 (7.5 Kb) TX bytes:7683 (7.5 Kb)

linux:/home/mbekkali # ifconfig eth0 up
eth0: unknown interface: No such device
linux:/home/mbekkali # ifconfig eth0
eth0: error fetching interface information: Device not found
linux:/home/mbekkali #
linux:/home/mbekkali #

I emailed several times to NVIDIA support but have not got any replies. I tried to install tar.gz file and src.rpm but get a message that the rpm is already installed (?).

Please help me. I don't want the saying "Linux works 98% of the time, but it is 2% that kill" come true. I've been posting on various forums but have not got any solution yet. It's been over 2 month now.

NeoXP 03-12-04 01:48 AM

I'm not a Suse expert (I'm using Mandrake 10.0), but why are you trying to install the nforce...src.rpm when there is an appropiate driver for Suse 9.0?

Inferno 03-12-04 06:21 AM

The problem is if you updated the kernel, the ethernet driver wouldn't start, because for the nvidia rpm you need the release kernel.

I rebuild with the src.rpm the driver, but i get a failure a startup from the ethernet driver.

When i load the driver with insmod nvnet.o the driver started correctly.
How can i load this driver at startup ????

I pasted in the nvnet.net in the modules.conf and modprobe.conf


Sorry for my bad english

NeoXP 03-12-04 07:27 AM

If you're updating, then go for updating your kernel to version 2.6.2 or higher. As of kernel 2.6.2 you can go for the forcedeth-driver!

I've tried it myself with ML 9.2. After install I had to compile the src.rpm driver to get the onboard NIC working, but after updating to kernel 2.6.3 it worked perfectly with the forcedeth-driver.

I'm now on ML 10.0 CE with kernel 2.6.3 and my NIC works out of the box.

:D

@ inferno:

You have to pass a line into your modprobe.conf:

alias eth0 nvnet

Inferno 03-12-04 11:40 AM

@NeoXP

I've pass in this line, but it don't work

Inferno 03-28-04 06:04 AM

Re: NVIDIA NIC driver installation problems in Suse 9.0
 
nobody can help me?????

NeoXP 03-29-04 03:12 AM

Re: NVIDIA NIC driver installation problems in Suse 9.0
 
post your modprobe.conf, maybe we can see what's wrong

Loth 03-29-04 03:24 PM

Re: NVIDIA NIC driver installation problems in Suse 9.0
 
I had the same problem and now it works !! :) :)

1.) download from suse the NEW KERNEL source from here (or your preferred mirror)
http://ftp.unicamp.br/pub/suse/i386/...1-199.i586.rpm

2.) install it ( yast will prompt you to install the base kernel source if you haven't done before )

3.) do the following as root (as written in the nvidia readme )

pushd /usr/src/linuxex
make cloneconfig
make dep
popd

4.) rebuild the rpm, ( you have to use the rpmbuild command, nor just rpm)

rpmbuild --rebuild nvidia_nforce{package na****-1.0-1.src.rpm

5.) install the fresh new RPM ( that you find in in /usr/src/packages/i586/RPMS )

Enjoy :) :) :)

Wildcards 04-02-04 06:39 AM

Re: NVIDIA NIC driver installation problems in Suse 9.0
 
I think you don't have make installed. Since make is required to compile the driver you have to install it first.
you can do that with yast:

yast -i kernel-source (this will install the kernel-source [and other c compiling tools i.e. make and glibc] of your old kernel, you will need to update the kernel-source with YOU, before you can compile the src.rpm)

I hope that answers some question (I'm new to linux myself, so if a more experienced user finds some fault in my description he may changed it accordingly.)

-bye wildcards

Clockworthy 09-17-04 11:27 AM

Re: NVIDIA NIC driver installation problems in Suse 9.0
 
I was using Loth's solution and when I was rebuilding the rpm file I got errors so it did not compile.

I am running SuSE 9.0 Server, with a BioStar M7NCG mother board.
Make 3.80
kernel-source-2.4.21-243.i586.rpm


Here is the output from the rpmbuild --rebuild NVIDIA_nforce-1.0-0261.src.rpm:

Beast:/home/bennettt/Desktop # rpmbuild --rebuild NVIDIA_nforce-1.0-0261.src.rpm
Installing NVIDIA_nforce-1.0-0261.src.rpm
Executing(%prep): /bin/sh -e /var/tmp/rpm-tmp.13884
+ umask 022
+ cd /usr/src/packages/BUILD
+ echo '---- Copying Sources ----'
---- Copying Sources ----
+ cd /usr/src/packages/BUILD
+ rm -rf nforce
+ /usr/bin/gzip -dc /usr/src/packages/SOURCES/nvnet.tgz
+ tar -xvvf -
drwxr-xr-x buildmeister/adm 0 2003-05-06 14:36:14 nforce/
drwxr-xr-x buildmeister/adm 0 2003-05-06 14:39:37 nforce/nvnet/
-r--r--r-- buildmeister/adm 16904 2003-05-06 14:39:37 nforce/nvnet/adapter.h
-r--r--r-- buildmeister/adm 794 2003-05-06 14:39:37 nforce/nvnet/basetype.h
-r--r--r-- buildmeister/adm 6752 2003-05-06 14:39:37 nforce/nvnet/nvnet.h
-r--r--r-- buildmeister/adm 4437 2003-05-06 14:39:37 nforce/nvnet/os.h
-r--r--r-- buildmeister/adm 4749 2003-05-06 14:39:37 nforce/nvnet/phy.h
-r--r--r-- buildmeister/adm 37870 2003-05-06 14:39:37 nforce/nvnet/nvnet.c
-rw-r--r-- buildmeister/adm 21504 2003-05-06 14:39:37 nforce/nvnet/nvnetlib.o
-r--r--r-- buildmeister/adm 3088 2003-05-06 14:39:37 nforce/nvnet/Makefile
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd nforce
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ cd /usr/src/packages/BUILD
+ /usr/bin/gzip -dc /usr/src/packages/SOURCES/nvaudio.tgz
+ tar -xvvf -
drwxr-xr-x buildmeister/adm 0 2003-05-06 14:39:38 nforce/
drwxr-xr-x buildmeister/adm 0 2003-05-06 14:39:38 nforce/nvaudio/
-r--r--r-- buildmeister/adm 2522 2003-05-06 14:39:38 nforce/nvaudio/Makefile
-r--r--r-- buildmeister/adm 58241 2003-05-06 14:39:38 nforce/nvaudio/nvcrush.c
-r--r--r-- buildmeister/adm 32174 2003-05-06 14:39:38 nforce/nvaudio/nvhw.c
-r--r--r-- buildmeister/adm 33857 2003-05-06 14:39:38 nforce/nvaudio/nvmain.c
-r--r--r-- buildmeister/adm 8314 2003-05-06 14:39:38 nforce/nvaudio/nvrec.c
-r--r--r-- buildmeister/adm 26382 2003-05-06 14:39:38 nforce/nvaudio/nvspdif.c
-r--r--r-- buildmeister/adm 14709 2003-05-06 14:39:38 nforce/nvaudio/nvwavout.c
-r--r--r-- buildmeister/adm 4546 2003-05-06 14:39:38 nforce/nvaudio/chaninfo.h
-r--r--r-- buildmeister/adm 5065 2003-05-06 14:39:38 nforce/nvaudio/nvhw.h
-r--r--r-- buildmeister/adm 1570 2003-05-06 14:39:38 nforce/nvaudio/nvioctl.h
-r--r--r-- buildmeister/adm 1392 2003-05-06 14:39:38 nforce/nvaudio/nvrec.h
-r--r--r-- buildmeister/adm 1618 2003-05-06 14:39:38 nforce/nvaudio/nvspdif.h
-r--r--r-- buildmeister/adm 1499 2003-05-06 14:39:38 nforce/nvaudio/nvwavout.h
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd nforce
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ cd /usr/src/packages/BUILD
+ /usr/bin/gzip -dc /usr/src/packages/SOURCES/nvmaster.tgz
+ tar -xvvf -
drwxr-xr-x buildmeister/adm 0 2003-05-06 14:39:36 nforce/
-r--r--r-- buildmeister/adm 1091 2003-05-06 14:39:36 nforce/Makefile
-r--r--r-- buildmeister/adm 5404 2003-05-06 14:39:36 nforce/NVLicense.txt
-r--r--r-- buildmeister/adm 18007 2003-05-06 14:39:36 nforce/GNULicense.txt
-r--r--r-- buildmeister/adm 23612 2003-05-06 14:39:36 nforce/ReleaseNotes.html
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd nforce
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ cd /usr/src/packages/BUILD
+ /usr/bin/gzip -dc /usr/src/packages/SOURCES/nvgart.tgz
+ tar -xvvf -
drwxr-xr-x buildmeister/adm 0 2003-05-06 14:39:38 nforce/
drwxr-xr-x buildmeister/adm 0 2003-05-06 14:39:38 nforce/nvgart/
-r--r--r-- buildmeister/adm 590 2003-05-06 14:39:38 nforce/nvgart/Makefile
-r--r--r-- buildmeister/adm 1231 2003-05-06 14:39:38 nforce/nvgart/README
-r--r--r-- buildmeister/adm 14033 2003-05-06 14:39:38 nforce/nvgart/linux-2.4.20-agpgart.diff
+ STATUS=0
+ '[' 0 -ne 0 ']'
+ cd nforce
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chown -Rhf root .
++ /usr/bin/id -u
+ '[' 0 = 0 ']'
+ /bin/chgrp -Rhf root .
+ /bin/chmod -Rf a+rX,g-w,o-w .
+ exit 0
Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.13884
+ umask 022
+ cd /usr/src/packages/BUILD
+ cd nforce
+ echo '---- Building Drivers ----'
---- Building Drivers ----
+ make
make -C nvnet
make[1]: Entering directory `/usr/src/packages/BUILD/nforce/nvnet'
cc -c -Wall -DLINUX -DMODULE -DEXPORT_SYMTAB -D__KERNEL__ -O -Wstrict-prototypes -DCONFIG_PM -fno-strict-aliasing -mpreferred-stack-boundary=2 -march=i686 -falign-functions=4 -DMODULE -I/lib/modules/2.4.21-183-athlon/build/include nvnet.c
In file included from /usr/include/linux/module.h:20,
from nvnet.h:20,
from nvnet.c:21:
/usr/include/asm/module.h:54:2: #error unknown processor family
In file included from /usr/include/linux/irq.h:19,
from /usr/include/asm/hardirq.h:6,
from /usr/include/linux/interrupt.h:10,
from nvnet.h:30,
from nvnet.c:21:
/usr/include/asm/irq.h:16:25: irq_vectors.h: No such file or directory
In file included from /usr/include/asm/hardirq.h:6,
from /usr/include/linux/interrupt.h:10,
from nvnet.h:30,
from nvnet.c:21:
/usr/include/linux/irq.h:67: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/linux/irq.h:67: error: requested alignment is not a constant
/usr/include/linux/irq.h:69: error: `NR_IRQS' undeclared here (not in a function)
In file included from /usr/include/linux/irq.h:71,
from /usr/include/asm/hardirq.h:6,
from /usr/include/linux/interrupt.h:10,
from nvnet.h:30,
from nvnet.c:21:
/usr/include/asm/hw_irq.h:28: error: `NR_IRQS' undeclared here (not in a function)
/usr/include/asm/hw_irq.h:31: error: `NR_IRQS' undeclared here (not in a function)
In file included from /usr/include/linux/interrupt.h:10,
from nvnet.h:30,
from nvnet.c:21:
/usr/include/asm/hardirq.h:13: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/asm/hardirq.h:13: error: requested alignment is not a constant
In file included from nvnet.h:31,
from nvnet.c:21:
/usr/include/linux/version.h:2:2: #error "================================================= ======"
/usr/include/linux/version.h:3:2: #error "You should not include /usr/include/{linux,asm}/ header"
/usr/include/linux/version.h:4:2: #error "files directly for the compilation of kernel modules."
/usr/include/linux/version.h:5:2: #error ""
/usr/include/linux/version.h:6:2: #error "glibc now uses kernel header files from a well-defined"
/usr/include/linux/version.h:7:2: #error "working kernel version (as recommended by Linus Torvalds)"
/usr/include/linux/version.h:8:2: #error "These files are glibc internal and may not match the"
/usr/include/linux/version.h:9:2: #error "currently running kernel. They should only be"
/usr/include/linux/version.h:10:2: #error "included via other system header files - user space"
/usr/include/linux/version.h:11:2: #error "programs should not directly include <linux/*.h> or"
/usr/include/linux/version.h:12:2: #error "<asm/*.h> as well."
/usr/include/linux/version.h:13:2: #error ""
/usr/include/linux/version.h:14:2: #error "To build kernel modules please do the following:"
/usr/include/linux/version.h:15:2: #error ""
/usr/include/linux/version.h:16:2: #error " o Have the kernel sources installed"
/usr/include/linux/version.h:17:2: #error ""
/usr/include/linux/version.h:18:2: #error " o Make sure that the symbolic link"
/usr/include/linux/version.h:19:2: #error " /lib/modules/`uname -r`/build exists and points to"
/usr/include/linux/version.h:20:2: #error " the matching kernel source directory"
/usr/include/linux/version.h:21:2: #error ""
/usr/include/linux/version.h:22:2: #error " o Configure kernel sources:"
/usr/include/linux/version.h:23:2: #error " - cd /usr/src/linux"
/usr/include/linux/version.h:24:2: #error " - make mrproper"
/usr/include/linux/version.h:25:2: #error " - make cloneconfig"
/usr/include/linux/version.h:26:2: #error " - make dep"
/usr/include/linux/version.h:27:2: #error ""
/usr/include/linux/version.h:28:2: #error " o When compiling, make sure to use the following"
/usr/include/linux/version.h:29:2: #error " compiler option to use the correct include files:"
/usr/include/linux/version.h:30:2: #error ""
/usr/include/linux/version.h:31:2: #error " -I/lib/modules/`uname -r`/build/include"
/usr/include/linux/version.h:32:2: #error ""
/usr/include/linux/version.h:33:2: #error " instead of"
/usr/include/linux/version.h:34:2: #error ""
/usr/include/linux/version.h:35:2: #error " -I/usr/include/linux"
/usr/include/linux/version.h:36:2: #error ""
/usr/include/linux/version.h:37:2: #error " Please adjust the Makefile accordingly."
/usr/include/linux/version.h:38:2: #error "================================================= ======"
In file included from /usr/include/linux/mm.h:205,
from /usr/include/asm/pci.h:7,
from /usr/include/linux/pci.h:677,
from nvnet.h:32,
from nvnet.c:21:
/usr/include/linux/page-flags.h:119: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/linux/page-flags.h:119: error: requested alignment is not a constant
In file included from nvnet.h:35,
from nvnet.c:21:
/usr/include/linux/netdevice.h:165: error: `CONFIG_X86_L1_CACHE_SHIFT' undeclared here (not in a function)
/usr/include/linux/netdevice.h:165: error: requested alignment is not a constant
nvnet.c:40:41: missing binary operator before token "("
nvnet.c: In function `nvnet_open':
nvnet.c:735: warning: passing arg 2 of `request_irq' from incompatible pointer type
nvnet.c: In function `nvnet_remove':
nvnet.c:1248: error: structure has no member named `driver_data'
nvnet.c:1284:41: missing binary operator before token "("
make[1]: *** [nvnet.o] Error 1
make[1]: Leaving directory `/usr/src/packages/BUILD/nforce/nvnet'
make: *** [nvnet_make] Error 2
error: Bad exit status from /var/tmp/rpm-tmp.13884 (%build)


RPM build errors:
Bad exit status from /var/tmp/rpm-tmp.13884 (%build)
----------------------------

Also:
I tryed to use the "modprobe nvnet" command and got this output:
Beast:/lib # modprobe nvnet
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o: unresol
ved symbol __netdev_watchdog_up_Ra7000325
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o: unresol ved symbol eth_type_trans_Rd36c0dd3
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o: unresol ved symbol skb_over_panic_R9ee181c3
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o: unresol ved symbol softnet_data_R6d8f9943
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o: unresol ved symbol netif_rx_Rfadb88b1
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o: unresol ved symbol alloc_skb_Rdee41f6c
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o: unresol ved symbol __kfree_skb_Raebda71a
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o:
Hint: You are trying to load a module without a GPL compatible license
and it has unresolved symbols. Contact the module supplier for
assistance, only they can help you.

/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o: insmod /lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o failed
/lib/modules/2.4.21-override-athlon/kernel/drivers/net/nvnet.o: insmod
---------------------------------------
If anyone has anyideas on how I can get my NIC to work I would greatly appreciate it.

Thanks


All times are GMT -5. The time now is 06:04 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.