nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Some of us are not just gamers (1.0-3123 Driver still not 100% working) (http://www.nvnews.net/vbulletin/showthread.php?t=2634)

psilo 10-07-02 03:45 PM

Some of us are not just gamers (1.0-3123 Driver still not 100% working)
1 Attachment(s)
I have tested the latest version of the nvidia kernel driver and glx libraries and am still dissatisfied. I have contacted nvidia several times (via linux-bugs@nvidia.com) about the following problem, but have heard *no* reply, not even a "we are working on it" or "stop bothering us, we'll never add that."

I am not a gamer (we'll, not on this box at least). I am trying to use my nvidia GF3 siluro card to do molecular modelling using software run on a Silicon Graphics workstation and sending it over the network to my RH 7.2 linux box (Tripos' Sybyl on Irix). Tripos support was kind enough to send me the attached file which demonstrates the problem that nvidia cards have with displaying text labels in Sybyl.

Other than this, the graphics are very fast, the driver is stable, and I wish I could use it. However, the lack of labels and highlighting in my modelling program, while seemingly pretty minor, are very important to the functioning of the interface. I am very reluctant to return to the Mesa driver/libraries, but until this can be fixed, I am doomed to paying too much for a 2D card with software rendering.

If I had purchased a "workstation" class card instead of the GF3 Siluro based "gaming" card, Im sure nvidia would pay a little more attention to me. I guess they are more concerned with gamers. It would be nice to have some reply or requests for more information.

Mike Braden
Dept. Medicinal Chemistry and Molecular Pharmacology
Purdue University
AMD Athlon 1800
512MB Memory
Abit Siluro GF3 64MB DDR
RedHat 7.2 2.4.7-10 kernel 4.1.0 XF86

bwkaz 10-07-02 05:30 PM

What's this program's output supposed to look like? I got text on my GF4, I'm just not sure if your problem is that the text isn't in the right place, or what's going on...

A screenshot of what I can see is here, let me know what's wrong with it...

psilo 10-07-02 08:52 PM

Thats a very good question. Im not sure how it is *supposed* to look. :p However, I did run this on my RH 7.3 box with a Radeon 7500 (XF86 4.2.0 drivers/dri) and it looks like this with the ability to rotate it thusly. Note that I did not compile these on my machine but ran the SGI compiled binary that they (Tripos) provided me as well. This was run on an SGI and the display information sent to my Xserver at home via the network (simulating how I would do it with my NVidia box). I will try this tomorrow at work with the RH 7.2 NVidia box and will post those results. I do not think it is just a matter of the text being displayed, but the "ruler" as well. I will see tomorrow I guess...

Mike Braden

bwkaz 10-07-02 09:54 PM

Ah. You're right, there is no ruler here, and I noticed also that either it didn't rotate, or I was using the wrong input stuff to do the rotation (I tried both the middle and right mouse buttons, and neither one rotated anything, so unless the input was changed without anyone changing the printed "instructions", it wasn't working).


utiel 10-07-02 10:00 PM

syb_ruler works with 1.0-3123 in 24 bits, no 16
1 Attachment(s)
For me works ( I have rotated it(right button mouse), and zoom (+,-)

If there is any difference between your radeon-jpg and my png, say to me, I don't find differences, I see, -X, 4, -4.0 and +X, I see also red line

I have tried syb_ruler, in RedHat 8.0, Nvidia-3123 and TNT2-M64


$gcc -o syb_ruler syb_ruler.c -lGLw -lGL -lXm -lXt -lXext -lX11 -L/usr/X11R6/lib
syb_ruler.c: En la función `main':
syb_ruler.c:166: aviso: el tipo de devolución de `main' no es `int'
$ ./syb_ruler

q to quit
MouseBtn2 to reset rotate and scale
MouseBtn3 to rotate
+ to increase scale by 1.0
- to decrease scale by 1.0
c to toggle clipping

It do NOT run in 16 bits, but YES in 24 bits

XF86Config with few options


Section "Module"
        Load  "dbe"
        Load  "extmod"
        Load  "glx"

Section "Device"
        Identifier  "RIVA TNT2"
        Driver      "nvidia"
        VendorName  "RIVA TNT2"
        BoardName    "RIVA TNT2"
        Option "IgnoreEDID" "true"
        Option "NoLogo" "false"
        Option "NvAGP" "1"

Section "Screen"
        Identifier  "Screen0"
        Device      "RIVA TNT2"
        Monitor      "Monitor0"
        DefaultDepth 24

        Subsection "Display"
                Depth      24
                Modes      "1280x1024" "1024x768" "800x600" "640x480"


psilo 10-08-02 10:39 AM

Ok, back at work and tried running syb_ruler on the SGI and sent the display over the network to my RH 7.2 nvidia box. As you can see here and here I have a ruler drawn but do not see the text.

Im not sure the relevance for compiling the syb_ruler on a linux box is, as this is supposed to show how the display information from an SGI is sent to a linux box. I know few of you have access to an SGI box to try this out on. However, I thank those that are helping and will try the suggested XF86Config settings.

Mike Braden

psilo 10-08-02 01:33 PM

Ok, I tried the above XF86Config settings and I get a similar lack of text running syb_ruler on the SGI over the network to my RH 7.2 nvidia box.

So again, this seems like an inherent driver or GLX library issue. Anyone from NVidia want to comment?

Thanks again for everyones help.
Mike Braden

bwkaz 10-08-02 07:18 PM

I'm pretty sure you don't get direct rendering when your connection to the X server is over the network... is that the problem maybe?

I know that last school year, when we were working with GL and fog, with Mesa and Voodoo3 cards (the lab machines... they were outdated, what can I say), if we would turn direct rendering on, then the fog would go away, completely. If we turned it off, the fog would show up.

So maybe that has something to do with it... maybe.

utiel 10-08-02 07:37 PM

OK, I understand now the problem

Originally posted by psilo
Ok, back at work and tried running syb_ruler on the SGI and sent the display over the network to my RH 7.2 nvidia box.
I Never have tried running an OpenGL program in a machine, and display it in another machine ( export DISPLAY=ip.machine:0.0 )

I can't Help, sorry

psilo 10-08-02 08:46 PM


Originally posted by bwkaz
I'm pretty sure you don't get direct rendering when your connection to the X server is over the network... is that the problem maybe?

No, I am pretty sure rendering is working ok otherwise. Using the mesa nv driver (software rendering), is very slow when there are lots of heavy graphics on the screen, I have to pretty much stick to anti-aliased lines. However, using the nvidia driver (direct rendering), it is much, much faster and I can have complex molecular surfaces or rendered bonds with no slowdown in rotation/manipulation. Plus, I do this with SGIs connecting to other SGI machines. Then the only limitation is the network connection.

bwkaz 10-08-02 09:02 PM

Hmm, OK, then that isn't it.

I don't know what is, sorry. It could be screwy drivers, or it could just be something I don't know about. Bug 'em some more (nVidia, that is)! ;)

psilo 10-08-02 09:15 PM

Sigh, thanks for your help. I now have some more crap to throw at them to look at, and hopefully they'll give me some reply. There is a very profitable market for relatively cheap workstations running linux that can connect to one very expensive server running one copy of a modelling software with an appropriate number of licenses. I wish NVidia would realize this. I could be a vehement supporter or naysayer either way depending on how this turns out. ;)

Mike Braden

All times are GMT -5. The time now is 08:22 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.