nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Plz Help!!! (http://www.nvnews.net/vbulletin/showthread.php?t=2653)

Rll 10-08-02 10:20 AM

Plz Help!!!
 
ok, i've compiled NVIDIA KERNEL & GFX tar 's on my Mandrake 9.0 , installed em, edited my XF86Config. Then did a reboot
It booted like allways then my screen flickered then NvLogo apeared then
the "Clock/wait" Cursor apeared, then it turned black Then NvLogo apeared again, and Wait Cursor apeared the it got black again , it repeated 3-4 times and X didn't load ??? WTF??? it loaded as usualy ... another thing, my system thinks its on/running !!!!!!!!!

PLZ Help !!!
My mails are
romanlenskij@hotmail.com (don't ask y hotmail)
&
romanlenskij@yahoo.com


PLZ send me built rpm or suggestions

:confused: :confused: :confused: :confused: :mad:

bwkaz 10-08-02 07:29 PM

Sounds like the NVIDIA_kernel installed, but the module that it uses isn't being loaded at boot.

Mandrake uses devfs, so make sure your /etc/modules.conf file has a line in it reading alias /dev/nvidia* NVdriver

When you see the flickering back and forth, hit Ctrl-Alt-F1 and log in (as root) in text mode. Then do a cat /etc/modules.conf to check what's in that file. If the correct alias line doesn't appear anywhere (others may be there, that's not a big deal), then do a vim /etc/modules.conf, arrow-key down to somewhere where you can add another line, hit the 'i' key (to enter insert mode), type out the alias line above, hit enter a couple times (for spacing purposes, no other real reason to do that), and then hit Esc (to exit from insert mode). Type in colon, then w, then q, and hit enter to save and exit. Then do, still as root, /sbin/depmod -a

Then, reboot (Ctrl-Alt-Del should shut down properly, otherwise init 6 works) and see if it works. It should.

Rll 10-09-02 01:32 AM

DIDN't Woik
 
alias net-pf-4 ipx
alias autofs autofs4
probeall scsi_hostadapter ide-scsi
alias sound-slot-1 es1371
alias eth0 ne2k-pci
alias sound-slot-0 via82cxxx_audio
probeall usb-interface usb-uhci
alias char-major-195 NVdriver

i don't know y, but i inserted even ur /dev/nvidia* NVdriver


try posting here XF86Config-4 plz.

ANY ONE !!!!! WHAT'S MY PROBLEM??????????????
somebody!!!! try e-mailing me some cfgs
or some rpms (on yahoo)

Rll 10-09-02 01:52 AM

A PIECE OF MY SYSTEM
 
################################################## ########################
# Sample XF86Config file for NVIDIA XFree86 drivers.
#
# Refer to the XF86Config(4/5) man page for details about the format of
# this file.
#
# Be sure to replace the monitor values with correct values for your
# monitor!
################################################## ########################


Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"
EndSection


################################################## ########################
# Server flags section.
################################################## ########################

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
EndSection



################################################## ########################
# Input devices
################################################## ########################

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "pc105"
Option "XkbLayout" "us_intl"
Option "XkbOptions" ""
EndSection

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "IMPS/2"
Option "Device" "/dev/psaux"
Option "ZAxisMapping" "4 5"
EndSection


################################################## ########################
# Module section
################################################## ########################

Section "Module"

Load "dbe"

# Load the glx module.
# Load "glx"

Load "extmod"

Load "type1"
Load "freetype"
EndSection


################################################## ########################
# Monitor section
################################################## ########################

Section "Monitor"
Identifier "monitor1"
VendorName "Plug'n Play"
ModelName "MAG 786FD"
HorizSync 30-86
VertRefresh 50-160

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
# ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
# ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
# ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

################################################## ########################
# Graphics device section(s)
################################################## ########################

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "NVIDIA GeForce2 DDR (generic)"
Driver "nvidia"
Option "DPMS"
BusID "PCI:1:0:0"
EndSection


################################################## ########################
# Screen sections
################################################## ########################
Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 15
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 16
Modes "1024x768" "800x600" "640x480"
EndSubsection

Subsection "Display"
Depth 24
Modes "1024x768" "800x600" "640x480"
EndSubsection
EndSection

################################################## #######################
# ServerLayout sections
# (invoke using the '-layout' option of 'startx'.
################################################## ########################

#
# just one agp card
#
Section "ServerLayout"
Identifier "layout1"
Screen "screen1"
InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"
EndSection



# PLZ HELP !!!

bwkaz 10-09-02 06:51 AM

What does /sbin/modprobe NVdriver (as root) tell you? Anything?

My XF86Config is here, but I'm not sure that will help (I don't run Mandrake, so a lot of things will be different from your config file).

When you do an ls /dev are most of the files in there symlinks (colored light blue)? Or are they actual devices (colored yellow)? Not all of them will be either (and there will be some files that are other colors as well), but you should see a predominance of either light blue or yellow. Post which.

Rll 10-10-02 12:53 AM

Thanx but no thnx
 
I've done it!!! i'm now typing this msg from Mozilla in Lnx :) had to fix some of the Makefile and uolia :) :D


All times are GMT -5. The time now is 06:54 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.