nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   My SuSE 8.0 just totally BROKE. Help please!!! (http://www.nvnews.net/vbulletin/showthread.php?t=2664)

sephiroth762 10-08-02 03:24 PM

My SuSE 8.0 just totally BROKE. Help please!!!
Ok... for starters, here's the system I'm running:

(Built by me :-))
AMD Athlon XP 2100+
WD 40MB 7200RPM HD (x2: one windows, one linux)
VisionTek GeForce4 Ti4400 (AGP)
Yamaha 20x10x40 CD-RW
1.44MB Floppy
SoundBlaster Audigy Gamer
Cheap ass 10/100 card
SuSE Linux 8.0 Professional (Drive 2)
Windows XP Professional (Drive 1)
---NOTE: I have it set up to use LILO as boot manager and boot linux by default. I have 8 seconds to decide Windows or Linux and if I don't make a decision, linux boots.

-ALSO- I don't know ANYTHING about linux. I just got it. I know NO "shell commands," directories, setup files or whatever, so try to explain as clearly as possible for a total beginner please :-D (if you could tell me exactly what to type that would be GREAT).

Alright, so here's the problem... I couldn't get my 3D card to work (I had installed Q3A and it ran like crap, plus the 3D games that came with SuSE won't run; says there's no 3D card) SOOOO, I downloaded and installed the two drivers on the NVIDIA site: the GLX and the Kernel files. SuSE then tested the setup, (it worked) and told me I didn't need to reboot. Well, my mouse turned into these two little pink slits somehow, so I decided to log out and log back in to see if it would go away.

Then the problem occured. When it should have gone back into the logon screen, the screen "clicked" and flashed 4-6 times, then it took me back into the green screen that comes up when you boot up (and it lists all the procedures its going through on startup). It then asks for my user name and password. I enter it and it just says "Have fun..." and gives me that Konsole or AShell or whatever its called on the green screen where the procedures are listed. I hit CTRL+ALT+DEL (being the windows user I am) and it rebooted. Now at the beginning, it moves along until where the logon screen should be. Then it says "NVIDIA" really big on the screen, clicks and flickers 4-6 times, and goes back to that "have fun..." crap. I can't figure out what to do. I tried to boot in "FailSafe" mode, but to no avail. The same thing happens again. I don't know what to do to get it to boot right again or get the thing to work. Did I totally screw up my Linux???? I hope not, cuz it took forever to get it this far. :-(

Any help at all would be greatly appreciated!!!

Thanks in advance.

sephiroth762 10-08-02 03:29 PM

P.S. - I downloaded and installed these two files...

GLX RPM for SuSE 8.0 NVIDIA_GLX-1.0-3123.suse80.i386.rpm


SuSE 8.0 NVIDIA_kernel-1.0-3123.suse80.i386.rpm

thereaper 10-08-02 04:24 PM

Installing the NVIDIA drivers with Suse 8.0 proved to be a pain in the neck for me too. I can offer you some tips.
Log into the console (i.e. the DOS type screen) as root and enter your root password.
Type "3Ddiag" which should give you some output as to the problem (you can hold down the ALT key and use the PAGEUP and PAGE DOWN keys to scrool up and down the screen).
You can type "3Ddiag -h" for more options.
If none the wiser type "init 3" and then type "sax2" you should be able to use the configuration tool to make sure that the correct drivers are loaded.
Type "lsmod" and see if "NVdriver" is in the list of modules loaded by the kernel.
If not type "switch2nv" this should reload the original drivers (i.e. without 3D support).
Type "init 5" and hold down the CTRL ALT and F7 keys this should take you back to the graphical login if not reboot!
Try to reinstall the NVIDIA drivers and remember to run the script "switch2nvidia_glx" as root after (i.e. open a terminal type "su" when prompted for a password type your root password and simply type switch2nvidia_glx).
That's about it .
Best of luck!

bwkaz 10-08-02 07:02 PM

And if none of that works, try posting the contents of /etc/modules.conf (type cat /etc/modules.conf to see it, and either attach it here, or post its contents, exactly).

Also, post what [ -c /dev/.devfsd ] ; echo $? prints out -- it should be either a 1 or a 0.

sephiroth762 10-08-02 11:46 PM


OK... thanks very much to TheReaper and Bwkaz for their great help here... with your instructions, I am now back on Linux WITH my 3D card running! YAAAAAY! Basically, I accomplished this by:

-Using 3Ddiag to determine where in the sequence the error was located (twice).

-Using the command "switch2nv" to go back to my old graphics setting.

-Once there (back in Linux with no 3D support again), I used the YaST online update to obtain the NVIDIA driver again (to make sure I had the correct matched pair).

-I then downloaded and installed the patches.

-Rebooted the system, only to find (using 3Ddiag again) that everything but the specific DRIVER was loading properly now.

-I then used the script "switch2nvidia_glx", rebooted, and all has worked.

-Of course, I then reset my screen to 1024x768 resolution and all that.

NOW, however, after doing all that, my QuakeIII CD will not "mount" (the software has already been installed, but I need the CD to run it cuz I don't know where the "launch"-type files are. It gives me the following error:

Could not mount device.
The reported error was:
/dev/cdrom: Input/output error
mount: I could not determine the filesystem type, and none was specified

Soooooooo... yeah. If you have any info again resulting in the fix of this, could you please assist me once again? I would once again appreciate it very much. I also help this thread helps anyone else with the same problem.

I know, I know.... I'm a damn newbie. It makes me sick as well ;-)

bwkaz 10-09-02 06:56 AM

Does mount -t iso9660 /dev/cdrom /mnt/cdrom work? It might, or it might just tell you "no superblock found" or something like that.

I/O error... <dumb question> you're sure there's a CD in the drive, right? </dumb question> OK, I though there was, just making sure.

What does ls -l /dev/cdrom tell you? Also do an ls -l on whatever the link target (the stuff on the right of the -> symbol) is.

thereaper 10-09-02 02:30 PM

Try opening the file "/etc/fstab" in an editor (gedit is fine) and see if there is an entry for /dev/cdrom. In Suse 8.0 it is mounted as /media/cdrom or /media/dvd. If the line is corrupted or missing try inserting something like this:

/dev/cdrom /media/cdrom auto ro,noauto,user,exec 0 0

You will have to be root to make any changes and make sure you save the file.
At the command line you could try:

"mount /media/cdrom " or "mount /media/dvd".

Best Wishes

All times are GMT -5. The time now is 08:28 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.