nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   No usable screens found - Mandrake 10.0 (http://www.nvnews.net/vbulletin/showthread.php?t=26709)

jpetsche 03-30-04 08:03 PM

No usable screens found - Mandrake 10.0
2 Attachment(s)
I am trying to get my NVidia driver setup under my new install of Linux Mandrake 10.0.

I've got my system configured usign the NV driver. I downloaed and installed 5336 driver version. It went through compiling the kernel module and everything. I changed my XFree config to use nvidia instead of nv and now I get "No screens found" or unusable configuration. I'm using respectable screen resolutions (800x600) and my Xwindows worked with the NV driver so I'm kinda at a loss right now.

I'm including my dmesg and XFree config file.

Please help!!

J-P 04-01-04 06:50 PM

Re: No usable screens found - Mandrake 10.0
Yea, I got the same error with Mandrake 9.0,

"No usable screens found" :screwy:

Tried to edit resolutions but didn't work.

japicken 04-01-04 07:28 PM

Re: No usable screens found - Mandrake 10.0
Joe Petsche, huh? Send me an email or something at japicken@adelphia.net, haven't talked to you in a while ;p And to answer your question you should reformat, and install Slackware ;)

favrefelixf 04-02-04 02:00 AM

Re: No usable screens found - Mandrake 10.0
What happens if you add the following in every "Display" subsection of the "Screen" section :

Modes "1024x768" "800x600" "640x480"


rednuht 04-02-04 03:21 AM

Re: No usable screens found - Mandrake 10.0
also is the nvidia module actually loaded ?
try lsmod as root to check

jpetsche 04-05-04 10:52 PM

Re: No usable screens found - Mandrake 10.0
I though I saw the module right when I installed it. However now I don't see anything related to nvidia from 'lsmod'. I found /lib/modules/2.6.3-4mdk/kernel/drivers/video/nvidia.ko and insmod'd it. it looks something like this:

Module Size Used by
nvidia 2068232 0

I run startx and it still says no usable screens found.

I also modified my lines to include Modes "1024x768" "800x600" "640x480"
I even removed the Virtual lines to see what happens. Currently I'm running with my nv driver without Virtual and with the Modes lines and that's working.

Any other ideas???

rednuht 04-06-04 02:21 PM

Re: No usable screens found - Mandrake 10.0
if lsmod does not list nvidia then try
modprobe nvidia
before startx

lonevvolf 04-07-04 02:33 AM

Re: No usable screens found - Mandrake 10.0
I have exactly the same problem...also from a clean install of Mandrake 10.0. I had it working for a short time, though I can't for the life of me remember what I changed. It was definitely NOT in the XF86Config-4 file. Though now something I installed must have reverted my changes, cause it no longer works again. This is really frustrating.

lonevvolf 04-07-04 07:32 AM

Re: No usable screens found - Mandrake 10.0
This may have been what did it for me...it's from another post in these forums, for Mandrake 9.2 (Should still apply, though). I will test when I get home today.


Originally Posted by mes
BLESSINGS ON THIS LIST! I'm running X and looking at KDE!

After taking notes on all previous posts on Mandrake 9 & NVIDIA, I tried a couple of simple things first. I edited /etc/X11/XF86Config-4 to include the Screen option "NVAgp" "0", rebooted and did startx. Same horrible msgs: failed to initialize kernel module, and 'Screen(s) found, but none have a usable configuration'.

I then doublechecked /etc/modules and sure enough, it still said 'NVdriver'. Edited this to 'nvidia', rebooted, start x and hey presto! the NVIDIA splash screen, followed by the Mandrake configuration wizard. No hassles at all with my KDE desktop, my LCD monitor is recognised as a generic LCD.

Couldn't be easier, love this Linux.

lonevvolf 04-07-04 03:51 PM

Re: No usable screens found - Mandrake 10.0
Ok...so I found the solution, as it seems. (at least in my case)

I noticed that performing a "modprobe nvidia" before loading "startx" made it work! So now the question was how to get it to load automatically. I tried adding all kinds of things to /etc/modules and so on, to no avail. Then I searched Google for "mandrake modprobe nvidia", and sure enough, found this link:


Note that the solution mentions kernel 2.5 and higher do not use the /etc/modules files! As Mandrake 10.0 is one of the first distros with the new 2.6 kernel, it seems to make sense that we couldn't just follow the README to get this working. So, as the solution says:


Putting an entry for the module in `/etc/modprobe.preload` is required for kernels 2.5 and above.
I was making the entry in /etc/modules, but kernel 2.6.x does not read that...

This is what the file looks like on mdk 10.0 on my system now...

# /etc/modprobe.preload: kernel modules to load at boot time.
# This file should contain the names of kernel modules that are
# to be loaded at boot time, one per line. Comments begin with
# a `#', and everything on the line after them are ignored.
# this file is for module-init-tools (kernel 2.5 and above) ONLY
# for old kernel use /etc/modules


Hope this works for other people as well!

jpetsche 04-07-04 09:32 PM

Re: No usable screens found - Mandrake 10.0
So I've tried all this stuff... the modules.preload, this Option "NVApg" "0" under the screens section. Still the same result. no screens found.

I've verified nvidia module is loaded (it's loaded at boot now). I can't figure out the problem. Anyone with it working wanna post up your XF86Config-4 or something? I'm out of ideas


lonevvolf 04-08-04 01:27 AM

Re: No usable screens found - Mandrake 10.0
Here's mine, though I seriously think it might not have anything to do with the XF86 file. Seems that most times, the problem lies elsewhere. Don't forget to check the troubleshooting of the NVidia README one more time. I found there was alot of stuff in there, that wasn't mentioned in the install instructions, but could be completely required! Specifically, when trying to run glxgears, for instance, I got:
Error: Could not open /dev/nvidiactl because the permissions
are too restrictive. Please see the FREQUENTLY ASKED QUESTIONS
section of /usr/share/doc/NVIDIA_GLX-1.0/README for steps
to correct.

This is in the README as well. Should be fixed by:
It is likely that a security module for the PAM system may be
changing the permissions on the NVIDIA device files. In most cases
this security system works, but it can get confused. To correct this
problem it is recommended that you disable this security feature.
Different Linux distributions have different files to control this;
please consult with your distributor for the correct method of
disabling this security feature. As an example, if your system has
the file
then you should edit the file and remove the line that starts with
"<dri>" (we have also received reports that additional references to
<dri> in console.perms must be removed, but this has not been verified
by NVIDIA). If instead your system has the file
then you should edit the file and remove the line that lists
/dev/nvidiactl. The above steps will prevent the PAM security system
from modifying the permissions on the NVIDIA device files. Next,
you will need to reset the permissions on the device files back
to their original permissions and owner. You can do that with the
following commands:
chmod 0666 /dev/nvidia* chown root /dev/nvidia*

NOTE: There are _two_ references in the console.perms file to <dri>...remove them _both_, or you will get nasty-looking boot problems. Hope all that helps!

All times are GMT -5. The time now is 02:49 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.