nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nvidia + 2.4.19 gentoo = messed up (http://www.nvnews.net/vbulletin/showthread.php?t=2698)

ulukay 10-09-02 06:29 PM

nvidia + 2.4.19 gentoo = messed up
 
lastest nvidia driver
2.4.19-gentoo
gcc3.2
xfree 4.0.2

in /etc/make.conf is the USE="mitshm" set !!
tmpfs on /dev/shm type tmpfs (rw) this is mouted correctly


when i want to start the xserver with the driver "nvidia" + LOAD GLX

i get a messed up nvidia logo, and the server crashes

here is the log (a little bit shortend):
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.3
(II) Loading font Type1
(II) Loading font CID
(II) LoadModule: "freetype"
(II) Loading /usr/X11R6/lib/modules/fonts/libfreetype.a
(II) Module freetype: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.1.10
Module class: XFree86 Font Renderer
ABI class: XFree86 Font Renderer, version 0.3
(II) Loading font FreeType
(II) LoadModule: "glx"
(II) Loading /usr/X11R6/lib/modules/extensions/libglx.so
(II) Module glx: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.3123
Module class: XFree86 Server Extension
ABI class: XFree86 Server Extension, version 0.1
(II) Loading extension GLX
(II) LoadModule: "nvidia"
(II) Loading /usr/X11R6/lib/modules/drivers/nvidia_drv.o
(II) Module nvidia: vendor="NVIDIA Corporation"
compiled for 4.0.2, module version = 1.0.3123
Module class: XFree86 Video Driver
(II) LoadModule: "mouse"
(II) Loading /usr/X11R6/lib/modules/input/mouse_drv.o
(II) Module mouse: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
Module class: XFree86 XInput Driver
ABI class: XFree86 XInput driver, version 0.3
(II) NVIDIA XFree86 Driver 1.0-3123 Tue Aug 27 16:00:08 PDT 2002
(II) NVIDIA: NVIDIA driver for: RIVA TNT, RIVA TNT2, Vanta,
RIVA TNT2 Ultra, RIVA TNT2 Model 64, Aladdin TNT2, GeForce 256,
GeForce DDR, Quadro, GeForce2 MX/MX 400, GeForce2 MX 100/200,
Quadro2 MXR/EX/Go, GeForce2 Integrated GPU, GeForce2 GTS,
GeForce2 Ti, GeForce2 Ultra, Quadro2 Pro, GeForce4 MX 460,
GeForce4 MX 440, GeForce4 MX 420, Quadro4 500/550 XGL,
Quadro4 200/400 NVS, NV18, NV18 , NV18 , NV18, NV18GL, NV18GL ,
NV18GL , 0x01F0, GeForce3, GeForce3 Ti 200, GeForce3 Ti 500,
Quadro DCC, GeForce4 Ti 4600, GeForce4 Ti 4400, GeForce4 Ti 4200,
Quadro4 900 XGL, Quadro4 750 XGL, Quadro4 700 XGL, NV28, NV28 ,
NV28GL, NV28GL , GeForce2 Go, GeForce4 440 Go, GeForce4 420 Go,
GeForce4 420 Go 32M, GeForce4 460 Go, GeForce4 440 Go 64M,
GeForce4 410 Go 16M, Quadro4 500 GoGL
(II) Primary Device is: PCI 01:00:0
(--) Assigning device section with no busID to primary device
(--) Chipset GeForce4 Ti 4600 found
(II) resource ranges after xf86ClaimFixedResources() call:

(II) resource ranges after probing:
(II) Setting vga for screen 0.
(II) Loading sub module "vgahw"
(II) LoadModule: "vgahw"
(II) Loading /usr/X11R6/lib/modules/libvgahw.a
(II) Module vgahw: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.5
(**) NVIDIA(0): Depth 24, (--) framebuffer bpp 32
(==) NVIDIA(0): RGB weight 888
(==) NVIDIA(0): Default visual is TrueColor
(==) NVIDIA(0): Using gamma correction (1.0, 1.0, 1.0)
(--) NVIDIA(0): Linear framebuffer at 0xD8000000
(--) NVIDIA(0): MMIO registers at 0xE8000000
(WW) System lacks support for changing MTRRs
(--) NVIDIA(0): VideoRAM: 131072 kBytes
(--) NVIDIA(0): Detected TV Encoder: Philips 7108
(--) NVIDIA(0): Display 0: maximum pixel clock at 8 bpp: 350 MHz
(--) NVIDIA(0): Display 0: maximum pixel clock at 16 bpp: 350 MHz
(--) NVIDIA(0): Display 0: maximum pixel clock at 32 bpp: 350 MHz
(II) Loading sub module "ddc"
(II) LoadModule: "ddc"
(II) Loading /usr/X11R6/lib/modules/libddc.a
(II) Module ddc: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.5
(II) NVIDIA(0): Sunnydale: Using hsync range of 31.50-95.00 kHz
(II) NVIDIA(0): Sunnydale: Using vrefresh range of 50.00-85.00 Hz
(II) NVIDIA(0): Clock range: 12.00 to 350.00 MHz
(II) NVIDIA(0): Not using default mode "1024x768" (bad mode clock/interlace/doublescan)
(II) NVIDIA(0): Not using default mode "512x384" (bad mode clock/interlace/doublescan)
(II) NVIDIA(0): Not using default mode "1600x1200" (hsync out of range)
(II) NVIDIA(0): Not using default mode "800x600" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1792x1344" (hsync out of range)
(II) NVIDIA(0): Not using default mode "896x672" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1856x1392" (hsync out of range)
(II) NVIDIA(0): Not using default mode "928x696" (hsync out of range)
(II) NVIDIA(0): Not using default mode "1920x1440" (hsync out of range)
(II) NVIDIA(0): Not using default mode "960x720" (hsync out of range)
(**) NVIDIA(0): Validated modes for Display Device 0:
(**) NVIDIA(0): Default mode "1280x1024": 157.5 MHz, 91.1 kHz, 85.0 Hz
(II) NVIDIA(0): Virtual screen size determined to be 1280 x 1024
(--) NVIDIA(0): Display dimensions: (360, 270) mm
(--) NVIDIA(0): DPI set to (90, 96)
(II) Loading sub module "fb"
(II) LoadModule: "fb"
(II) Loading /usr/X11R6/lib/modules/libfb.a
(II) Module fb: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
ABI class: XFree86 ANSI C Emulation, version 0.1
(II) Loading sub module "xaa"
(II) LoadModule: "xaa"
(II) Loading /usr/X11R6/lib/modules/libxaa.a
(II) Module xaa: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 1.0.0
ABI class: XFree86 Video Driver, version 0.5
(II) Loading sub module "ramdac"
(II) LoadModule: "ramdac"
(II) Loading /usr/X11R6/lib/modules/libramdac.a
(II) Module ramdac: vendor="The XFree86 Project"
compiled for 4.2.0, module version = 0.1.0
ABI class: XFree86 Video Driver, version 0.5
(--) Depth 24 pixmap format is 32 bpp
(II) do I need RAC? No, I don't.
(II) resource ranges after preInit:
(II) NVIDIA(0): AGP 2X successfully initialized
(II) NVIDIA(0): Setting mode "1280x1024"
(II) NVIDIA(0): Using XFree86 Acceleration Architecture (XAA)
Screen to screen bit blits
Solid filled rectangles
Solid filled trapezoids
8x8 mono pattern filled rectangles
8x8 mono pattern filled trapezoids
Indirect CPU to Screen color expansion
Solid Lines
Scanline Image Writes
Offscreen Pixmaps
Driver provided FillSolidRects replacement
Driver provided FillSolidSpans replacement
Driver provided FillMono8x8PatternRects replacement
Driver provided WritePixmap replacement
Driver provided ReadPixmap replacement
Setting up tile and stipple cache:
20 128x128 slots
5 256x256 slots
(==) NVIDIA(0): Backing store disabled
(==) NVIDIA(0): Silken mouse enabled
(EE) NVIDIA(0): Failed to obtain a shared memory identifier.
(II) Loading extension NV-GLX
(II) Loading extension NV-CONTROL
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) [GLX]: Calling GlxExtensionInit

Fatal server error:
Caught signal 11. Server aborting

anyone got an idea
:confused:

bwkaz 10-09-02 08:20 PM

What is this /etc/make.conf file? What does it control?

Would it be possible to upgrade X to 4.2.0 or 4.2.1? I know the documentation says that 4.0.2 works, but I haven't tried anything that old since driver version 0.9-769 or so, I think -- a long time ago, in other words. Gentoo's portage should have a way to upgrade X for you, which might work.

Can you also post /etc/X11/XF86Config-4 (if it exists, if not, the /etc/X11/XF86Config)?

mtrr 10-09-02 09:07 PM

without tmpfs (shm fs) mounted, to mount is not needed,
think bwkaz is right, update X and try again....

---snip---

(==) NVIDIA(0): Silken mouse enabled
(II) Loading extension NV-GLX
(II) Loading extension NV-CONTROL
(II) Initializing built-in extension MIT-SHM
(II) Initializing built-in extension XInputExtension
(II) Initializing built-in extension XTEST
(II) Initializing built-in extension XKEYBOARD
(II) Initializing built-in extension LBX
(II) Initializing built-in extension XC-APPGROUP
(II) Initializing built-in extension SECURITY
(II) Initializing built-in extension XINERAMA
(II) Initializing built-in extension XFree86-Bigfont
(II) Initializing built-in extension RENDER
(II) [GLX]: Calling GlxExtensionInit
(II) Keyboard "Keyboard[0]" handled by legacy driver
(**) Option "Protocol" "imps/2"

---snap---

kappax 10-09-02 11:57 PM

hey i am new here, First post :) just sold my atiR8500 for $50 and getting my ti4200 , using gefroce DDR atm, but yo, I would say get the r10 kernel, much better, much faster, it is masked but has been tested for a while now (portage freez) just unmask it and have fun, i have the nvidia drivers working and they seem to work great. Hope that dont change when i get my ti4200 in the computer.

heh this is my frist nvidia card never had one befor (friend let me use his geforce till my card got to me )

ulukay 10-10-02 02:10 AM

Quote:

Originally posted by kappax
hey i am new here, First post :) just sold my atiR8500 for $50 and getting my ti4200 , using gefroce DDR atm, but yo, I would say get the r10 kernel, much better, much faster, it is masked but has been tested for a while now (portage freez) just unmask it and have fun, i have the nvidia drivers working and they seem to work great. Hope that dont change when i get my ti4200 in the computer.

heh this is my frist nvidia card never had one befor (friend let me use his geforce till my card got to me )

hoi

do you mean 2.4.19-gentoo-r10

where do i get it?

oo - and where do i geht the XFree 4.2.1 sources?

bwkaz 10-10-02 08:24 AM

I would think that sources for 4.2.1 would be in portage, Gentoo's package management system. Is there any way to check the packages available to download?

Otherwise, there's always www.xfree86.org, but compiling that takes quite a bit of effort (X uses some strange build system that makes you edit C files to configure it).

ulukay 10-10-02 08:58 AM

hmm

it MUST work with gcc 3.2, 2.4.19-gentoo-r3 and xfree 4.2.0, because many people are using this config, and even in the docs, this config is working

i think the whole issue is here:
(EE) NVIDIA(0): Failed to obtain a shared memory identifier.

but i found no help for this specific error

ulukay 10-10-02 12:21 PM

hm
when i start mozilla i get this error message

Gdk-WARNING **: shmget failed: error 38 (Function not implemented)

i think something with shm is wrong?

maybee i should recompile my kernel to a standard 2.4.19 ???
(then i have to recompile xfree and the nvidia drivers?)

bwkaz 10-10-02 01:02 PM

You'll have to recompile the nVidia drivers (well, the kernel-mode half, not the GLX half).

But you shouldn't have to recompile X. The kernel is still binary compatible with everything (that's why it's not kernel version 3 ;) ), so your current X binaries should work.

If you do compile 2.4.19, enable MTRR support in the kernel config. That should help framerates a bit, since the driver can enable write combining with that. It's under "Processor type and features", and it's named "Memory Type Range Register (MTRR) support" (assuming you are using make menuconfig or xconfig to configure the kernel).

I assume /proc/mounts lists /dev/shm as mounted, right? Is it listed before or after /dev? (should be after.)

ulukay 10-10-02 01:38 PM

waaaaaaaaaAAAAAAAAAAAAAAAAAAAAAAAAAAaaa

i recompiled the kernel to the original 2.4.19
recompiled XFREE
and recompiled both NVIDIA Driver components

and i get the EXACT SAME ERROR :mad: :mad: :mad: :mad: :mad:

i HATE nvidia

mtrr 10-10-02 01:57 PM

it's not even needed to compile tmpfs (shmfs) in. read the documentation in the kernel source tree.

I believe there is something different wrong with your setup.

post your kernel .config, maybe we can find something (please post that file as attachment)


cheers

ulukay 10-10-02 02:06 PM

i'm currently compiling a 2.4.19-gentoo-r9

kernel config? you mean i should save the kernel config in a file and post it here .... (ok after i tried the last kernel for today ;D )


All times are GMT -5. The time now is 03:55 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.