nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Strange video playback problems (2.6 kernels) (http://www.nvnews.net/vbulletin/showthread.php?t=26985)

ragdim 04-06-04 07:30 AM

Strange video playback problems (2.6 kernels)
 
1 Attachment(s)
Hi,

I'm having performance problems with video playback when using the nvidia driver and 2.6 kernels. There are no problems when using nv driver (except for the lack of OpenGL support of course). I've tested this with the current 53.36 version and with earlier modified drivers from minion.de. The problem appeared when I switched to kernel 2.6.0 and is present in 2.6.5 also. It works fine with 2.4 kernels.

My system:
-Pentium 3 @ 800MHz
-MSI 6198 with VIA Apollo PRO 133 chipset
-512 MB SDRAM
-GeForce2 MX 32MB
-Arch Linux 0.6 (same problem with Slackware 9.1)

The actual problem is that when I play any video (with any player), the process X starts eating CPU and audio gets out of sync. Here are some test results while playing a DivX5 file sized 640x480:

mplayer -vo xv

CPU usage
mplayer: 18%
X: 50-60%

-Unwatchable, audio is out of sync after ~10 secs of playback.
Total CPU usage is near 100%. Mplayer complains my CPU is too slow.

mplayer -vo x11

CPU usage
mplayer: 24%
X: 14%

-Video plays fine, but I can't go fullscreen. If I add -zoom and put
fullscreen mode on, mplayer uses 100% CPU and video skips at times.

mplayer -vo xv (using nv driver)

CPU usage
mplayer: 18%
X: 22%

-Video plays fine, no problems.

Other -vo modes, such as gl and gl2 are unusable as well. Changing -ao mode to oss or sdl doesn't help either. I have tested mplayer 0.92, 1.0pre3 and current CVS plus Xine 1rc3b. OpenGL performance seems to be reasonable for my card. In glxgears I get ~1500 FPS. I've tried with with different values of NvAGP, tried to not load the agpgart module (via_agp) with no luck so far.

Here are some infos from /proc

/proc/driver/nvidia/agp/card:
Fast Writes: Supported
SBA: Not Supported
AGP Rates: 4x 2x 1x
Registers: 0x1f000017:0x1f000102

/proc/driver/nvidia/agp/host-bridge
Host Bridge: VIA Technologies, Inc. VT82C693A/694x [Apollo PRO133x]
Fast Writes: Not Supported
SBA: Supported
AGP Rates: 2x 1x
Registers: 0x1f000203:0x00000102

/proc/driver/nvidia/agp/status
Status: Enabled
Driver: AGPGART
AGP Rate: 2x
Fast Writes: Disabled
SBA: Disabled

/proc/driver/nvidia/cards/0
Model: GeForce2 MX/MX 400
IRQ: 5
Video BIOS: 03.11.00.07.00
Card Type: AGP

There seems to be a similiar problem in this thread.

It might be the Apollo PRO 133 + GeForce 2MX combination which is causing the problems.

If anyone knows a solution to this I would be more than happy to hear. Switching drivers when playing games or watching movies is kinda frustrating.

ibliss 07-19-04 11:20 AM

Re: Strange video playback problems (2.6 kernels)
 
i have actually the exact same symptoms

kernel 2.4: everything works fine, meaning:
* xmms scope framerates that are smooth
* scrolling in a kshell smooth, scrolling of mozilla acceptably smooth
* moving around of a window on desktop: smooth, no redraw that is visual

kernel: gs-sources 2.4.25-pre7-r5
agp: disabled (if i enable it either agpgart or nvagp, KDE locks up after 5-10 mins, seems that my graphics card is not very compatible with my mobo)

kernel 2.6: choppy performance :(
* xmms scope framerate of 0.5 or so. Well, i only see a new scope-function displayed every 2 secs
* scrolling in a kshell -> choppy
* scrolling of mozilla is horrible slow
* moving around of any window creates a huge cpu-load, and u see it being redrawn :(
kernel: gentoo-dev-sources-2.6.7
agp: disabled (as it was in 2.4)

graphics card: geforce 2 gts 32MB (actually an asus v7700 i think)
mobo: abit kr7a-r
mem: 512MB, 2x256
cpu: athlon xp1700+ (palomino core)

drivers installed: (in both cases)

qpkg -I -v nvidia
media-video/nvidia-glx-1.0.5336-r2
media-video/nvidia-kernel-1.0.5336-r4

i haven't had the time to try other driver versions yet... also, it's a user-system in the sense that all my family members are using it, and i dont really have much opportunities to try to solve this problem...

Spudman 07-20-04 01:03 PM

Re: Strange video playback problems (2.6 kernels)
 
Similar problem here. I use two cards... MX460(AGP) + MX420(PCI).

Run a 2.4 kernel & everything is fine. Boot into a 2.6 kernel & the performance of the PCI card dies.

With 2.6, running Xine (or mplayer, or MythTV) on the AGP card is fine, but try to run it on the PCI card & X uses 80% of the CPU time with Xine dropping frames like crazy. Shrinking the window size does nothing. Drop back to a 2.4 kernel and everything runs fine.

Kamel 07-20-04 03:57 PM

Re: Strange video playback problems (2.6 kernels)
 
i could be wrong, but this sounds to me like a kernel configuration that the nvidia doesn't like. i'd reccomend all of you posting your .config just incase.

ibliss 07-22-04 03:40 AM

Re: Strange video playback problems (2.6 kernels)
 
2 Attachment(s)
here is my .config and the nvidia-bug-report.log file

(generated when i switched to the 6106 driver version, but i had the same problem with the 5336 drivers)

the thing is also, i can watch my anime with mplayer (thank god... i wouldnt survive without anime ;) ), but cpu usage is a lot higher than with the 2.4 kernels.

TedJ 09-09-04 06:24 AM

Re: Strange video playback problems (2.6 kernels)
 
Hi all,

I have also been experiencing this problem since upgrading to Mandrake 10.0 Official, and have been beating my head against the wall for nearly 3 months over it.

The poor DVD playback is especially annoying as the PIII 866 box I'm using is for a home theatre PC.

I can confirm the problem appears to be some sort of conflict between the nvidia driver and the 2.6 series kernel.

Ted

Pinky's brain 09-14-04 05:29 PM

Re: Strange video playback problems (2.6 kernels)
 
P3-450 bx mobo and tnt video card, same problem. The system seems to be behaving as if writecombining is disabled, the MTRRs seem to be setup okay though. (It is Xfree86 taking up the CPU time BTW, this does the xvideo copy to video memory of the decoded frames.)

I dont know if this is relevant, but lspci says the following with 2.4 while omitting it with 2.6
Expansion ROM at <unassigned> [disabled] [size=64K]

Hell with 2.6.9 pre releases I cant even load the nvidia kernel module at the moment, there is something ****ed up ... but it is unfortunately machine dependent, and the people who matter arent suffering the problems it seems. Cause this problem has been around for ages.


All times are GMT -5. The time now is 12:04 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.