nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   debian nvidia driver installation freezes after reboot after reporting 'success' (http://www.nvnews.net/vbulletin/showthread.php?t=27127)

michael a. 04-09-04 02:56 PM

debian nvidia driver installation freezes after reboot after reporting 'success'
greetings everyone,

it is very late for me, so i will try to be brief and cross my fingers something arises before morning. essentially i've been driving myself crazy for the last month it seems, trying to install drivers for a quadrofx card on a debian system. registering with a bbs is a pretty extreme move for me though i actually tried to register some time ago as suggested by the nvidia linux driver installation docs, but could never recieve permission via email, i tried again to night out of desperation and was apparently successful. below is a letter i sent to 'linux-bugs@nvidia.com' some time ago to which i never recieved a response. i'm not entirely sure how valid the letter still is, likely somewhat i imagine. it basically explains the situation i think.



--originally sent to: linux-bugs@nvidia.com --------------------------------------------


it is my wish on this occasion to recieve help with a particular nasty bug that reared its head why attempting to bring nvidia graphics hardware support online running under debian linux 2.4.18. i believe that is the correct revision. the installer is version 5663 i believe. their is significant discussion of this particular process under these particular constraints on the nvnews bbs, and i've read through every line of the accompaning support documents downloadable from the same local on your network as the installer. but still at somepoint my situation becomes unique. i attempted to register with the nvnews bbs but have yet to be allowed access, in any case i thought that maybe my situation might warrant ammendment of your trouble shooting FAQ. i am new to linux and attempting to bring all of my necesarry hardware online. in the process of getting the installer to succeed i had to recompile the kernel and trade in lilo for grub, but everything went fairly smoothly aside from the boot loader. in the process i actually managed to bring all of my hardware but the nvidia drivers online in an ironic twist, which was the initial goal.

finally the problem arises after modifying the x86config file. the installer terminates with success, insmod/modprobe appear successful, warning about tainting the GPL with proprietary software in the process. the modconfig file contains the entry for nvidia, which i assume is responsible for loading the module during initialization automatically though i can find no evidence of this during initial boot.

now i believe those are all of the constraints aside from the x86config file.

now if i do not alter the x86config file there is no appearance of any faults in the system. but after making the suggested changes and rebooting, upon initialization once the bit which automaticly starts the X server is reached the system blacks out for a few seconds and then displays a wall of asci 'garbage' similar if not entirely so to the console display. at this point the system becomes apparently frozen responding to no input, and at the same time this fault appears to do dame to the hard disk which makes it an expensive process to work with as i'm particularly adverse to the idea of starting over from square one at this point.

also if you will, i would prefer that the X server not automatically run itself during powerup, but i'm unable to find the file which requests this action. if you could help me in that way i would apreciate it. your docs suggest that inittab is responsible for this, but i was unable to draw any real correlation with investigation between the contents of the file and the automated starting of the X server.
in any case in retrospect, with the installation process, all seems well until changing the x86config file, after which starting the X server causes the system to freeze displaying asci garbage (unintelligible characters often outside standard input ranges), most certaintly this is the console and not the X server. also this process almost certaintly causes disk damage making it difficult to work with. it is also difficult to check the X log because to do so requires escaping the inititialzation process which i am sometimes successful at doing though not necesarrily reproducibly, through the mostly random key thrashing of the keyboard.

as well the file that is responsible for automatically starting the X server would prove helpful information. i would seek help via the internet, but i can formulate no means of conveying this situation to a contempory automated search mechanism.

upon gaining access to the nvnews bbs i will post this letter there as well.

hopefully i will find more support than i'm accustomed to.

best wishes.



PS: this server almost never recognizes my requests

michael a. 04-09-04 06:59 PM

Re: debian nvidia driver installation freezes after reboot after reporting 'success'
i found this address: http://www.minion.de/ which i found on this bbs to seem some what helpful. it seems to describe my experience well, the black frozen screen wiwth ascii garbage that is. i followed its instructions to add the NvAGP option and removed AGPGART from the the kernel but experienced no success.

i've really been breaking my back over this one for a month now more or less. if someone can offer some ensight it would be greatly apreciated.



michael a. 04-10-04 12:38 PM

Re: debian nvidia driver installation freezes after reboot after reporting 'success'
please anyone? iv'e really run out of ideas. i disabbled the agp, is there nothing else that causes these symptoms? black frozen screen of ascii garbage that is. the card works wonders on a win2000 system on the same machine with 3 monitors, dual agp with one pci. i need to get this setup up and running with linux before i can really port my work to it. i would prefer to be a linux developer, but i can't get my card to work. i've tried on many occasions to port my work to linux, but the situation has never been a viable one. this time i am determined, but after another month of this i'm afraid i might be slightly wavered. -michael

michael a. 04-10-04 02:08 PM

Re: debian nvidia driver installation freezes after reboot after reporting 'success'

i can't get an x log because the file is not written before the system freezes. is it possible to force x to write each line to disk rather than buffering the log? now that i mention it, i would prefer to start x manually after boot, but gdm wont permit this and i can't find a means to configure this. also i can not terminate the x server unless i continually bash on ctrl+shift+alt+bksp until the server crashes. if someone can help me in these respects i would apreciate the gesture greatly.



PS: can someone please let me know if you are scratching your head on this one, or if everyone is just put off by my demeanor. i would apreciate some sort of response, just so to know whether or not i've garnered any sympathy. -michael

michael a. 04-10-04 06:20 PM

Re: debian nvidia driver installation freezes after reboot after reporting 'success'
another person with a similar dilemma:


says flashing the bios fixed teh problem after 4 flashes miraculously.

what is the significance of flashing the bios? sounds like a hardware operation, but i imagine there is some mechanism to perform the task via software hopefully that is. i guess i will have to look into it for lack of a better idea. onward to the next adventure of my linux nvidia odyssey then. i must just really enjoy talking to my self.



michael a. 04-10-04 06:59 PM

Re: debian nvidia driver installation freezes after reboot after reporting 'success'
-post copied from another related thread i create


Re: where can i learn how to use the "nv" drivers as opposed to the "nvidia" ones?

"I am using the 'nv' drivers right now, and they are not accelerated (3D wise)."

yeah i read that... too bad.

"AFAIK debian comes with the nv driver so all you have to do is change the Driver line in your XF86Config-4 file to say 'nv' instead of 'nvidia'."

this never works for me. x trys to start about 3 times and gives up. i examined the log but i can't remember what it said, in any case it was very short. i just assumed something was missing. but i can't find anything nv related in dselect, nor can i find any real useful information on the internet related to nv. but if it is not 3d accelerated then i'ven't much use for it. i was using vesa successfully, but after upgrading x to 4.4 i can't get vesa to work either. it results in a display that looks like the refresh rate is wrong, but changing the resolution refresh colour depht and what have you has no effect. the config file worked fine for vesa before the upgrade, and never worked for nv. i'm just hoping that problem will fix itself after i get the nvidia drivers to work, assuming i ever will. people don't seem to be too helpful, and the software seems shotty at best. right now i'm looking into flashing the bios with little leads on how to. that is obtaining the new image and flashing it. i hope i don't need a floppy drive because i don't have one, i've gone through 5 or 6, they never work for me.

" Your problem _really_ sounds similar to mine as my machine hard locks when loading the Nvidia kernel side module (see the 32 bit drivers on Asus K8V thread)."

i think i've read tehm all for the last 4 or 5 pages.

"Just a suggestion, boot up with an extra kernel option 'single'. Then do a modprobe nvidia and see if your machine crashes. If it does you may suffer from the same problem I'm trying to get fixed."

i don't understand teh boot option part. i use grub, lilo never would recognize my kernel after i installed tehm. modprobe want crash my system. it simply reports that the proprietary drivers will taint the kernel open source wise.

in any case i apreciate teh response. i was beginning to feel like this place was a ghost town.. i think i will let this thread die and focus on my other running one.

best of luck.



michael a. 04-10-04 07:02 PM

Re: debian nvidia driver installation freezes after reboot after reporting 'success'
i'm looking for a means to flash teh nvidia bios at this time. if you can help me find the images and utilities necesarry i would greately apreciate it.

michael a. 04-11-04 08:07 PM

Re: debian nvidia driver installation freezes after reboot after reporting 'success'
here are some issues which might apply to my situation


From www.minion.de:

"Words of caution

If you find that 1.0-5328 hangs on X startup on a newer Via chipset, please download the current 2.6 patch for this release. This bug is not specific to Linux 2.6.

Linux 2.6 AGPGART seems to be broken on some chipsets. If you find that your system hangs upon starting X, potentially with ASCII garbage all over the screen, try the built-in NVIDIA AGP GART driver (Option "NvAgp" "1", AGPGART not loaded) instead.

Many ACPI and UP I/O APIC configurations seem to be unreliable; if you're experiencing startup or stability problems, it may help to disable them with acpi=off and noapic. In some cases, a combination of pci=noacpi and pci=biosirq has also been reported to help.

The (partial) mem=nopentium workaround for the AMD Athlon/AGP stability problem on Linux will not work as expected on Linux 2.6. It has been made obsolete with the introduction of Andi Kleen's page attribute interface in Linux 2.4.20 (also present in Linux 2.6).


can anyone try to help me with these. i'm a little fuzzy on everything but the NvAGP option, which i just left in there because it describes my symptoms, ascii garbage and lock up that is.

what of the patch and the "<?>=<?>" bits, where should these be specified?


michael a. 04-18-04 01:46 AM

Re: debian nvidia driver installation freezes after reboot after reporting 'success'
update: upgraded to kernel 2.6 every thing was up and running in minutes.

at least i learned a lot about the linux infrastructure i suppose.

my heart goes out to everyone struggling with their graphics cards.



All times are GMT -5. The time now is 11:55 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.