nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Blank virtual terminals (http://www.nvnews.net/vbulletin/showthread.php?t=27146)

lotheac 04-10-04 02:46 AM

Blank virtual terminals
 
2 Attachment(s)
I tried searching the forums for this problem, but just couldn't find anything. So anyway, after X starts and I switch to another virtual terminal with Ctrl+Alt+F(n), I can't see anything but a black screen. I can still login and use commands blindly though. I can't see shutdown messages either. What could be the problem and how to fix it?
Specifications:
ASUS GeForce4Ti4600, driver 5336, Debian GNU/Linux, Athlon XP 2400+ ~2.1GHz and MSI KT3 Ultra2 as my motherboard.
/proc/driver/nvidia/cards/0:
Code:

Model:          GeForce4 Ti 4600
IRQ:            16
Video BIOS:      04.25.00.19.00
Card Type:      AGP

I tried (with too little effort) to get a verbose log, but I had some random problems and thought I wouldn't post a verbose log until I knew it was necessary... So...

Thunderbird 04-10-04 03:50 AM

Re: Blank virtual terminals
 
First make sure you are not using any framebuffer console (including vesafb), this might cause the problem.

lotheac 04-10-04 06:07 AM

Re: Blank virtual terminals
 
Ok, uh, I'm a nublet as they say, so how would I check that? :)

prplxd 04-11-04 04:13 PM

Re: Blank virtual terminals
 
This is apparently a bug in the 5336 driver.
Many of us have posted about this same issue a month or two ago.

There a lot of us experiencing the same thing.
Apparently, Nvidia things everyone boots to a GUI, like Fedora or Mandrake 10.

Nvidia is "supposedly" working on a fix so us folks that boot to text can toggle back and forth and still see the output when we are back in the text-mode.

It's just something you have to contend with for now.
My work-around is to just shutdown from X, or do a re-boot in X.

The 2nd option is that since you know you are at a prompt when you toggle back to console, just execute your command to re-boot or shutdown from there.

If you find a fix, pleae let the rest of us know.

maxresch 04-27-04 07:54 AM

Re: Blank virtual terminals
 
yes it looks like you've the same problem.
http://www.nvnews.net/vbulletin/showthread.php?p=310646

i hope nvidia will fix this soon.

lotheac 04-27-04 08:41 AM

Re: Blank virtual terminals
 
Not that I have the option to whine, but it seems to me you linked to the wrong thread here :)

mickep76 04-28-04 12:14 AM

Re: Blank virtual terminals
 
It seem's to me that perhaps your CRT or DFP isn't choosen as the primary display and the console only appears on the primary display. If you have a secondary display like TV or similar check if the console appears on this one or try removing the cable and se if it work's.

Regards
Michael P

lotheac 04-29-04 12:03 PM

Re: Blank virtual terminals
 
Well, I don't have any secondary display devices...

lotheac 04-29-04 11:41 PM

Re: Blank virtual terminals
 
Well, I downloaded 46.20 (with 2.6 kernel support, http://www.minion.de had links) and it works like a charm. And I like nvidia-settings.

odinbaal 04-30-04 11:56 PM

Re: Blank virtual terminals
 
prplxd,

Since this is a problem we're all having, and I see it's been there for a few months already (recent for me), shouldn't we do something about it? Are the Nvidia people taking this seriously? Have they come up with another driver (other than 5336) or with a "fix"?
I think it's a major problem and it HAS to be looked into seriously!

SuLinUX 05-01-04 01:46 AM

Re: Blank virtual terminals
 
Dont have that probelm and never have, swear I must have Linux certified harware or something :rolleyes: because theses so called bugs I just dont see.

odinbaal 05-01-04 09:17 AM

Re: Blank virtual terminals
 
Fixed it!

Not by entering vga=normal from the grub load/boot screen but, for some mysterious reason (I'm a newbie, I know), from the KDE Control Center like this:

Control Center -> Yast2 Modules -> System -> Boot Loader Config -> option "gfxmenu"

->edit Linux###section and add/change the vga=xxx to vga=normal

Reboot, and that's it! 3D worked fine, the nvidia splash screen was on, and all console screens (virtual and otherwise) were crystal clear.

One thing, though: the nice progress bar at load time with the gecko has disappeared. I'm back now to the old black and white scrolling stuff, which is fine as long as I have everything set!

Thanks SuLinUX for first suggesting the vga=normal fix!


All times are GMT -5. The time now is 06:40 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.