nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   POSSIBLE AGP TROUBLE (mandrake 9.0) (http://www.nvnews.net/vbulletin/showthread.php?t=2742)

chrono86 10-10-02 07:13 PM

Hi, i'm ultra new to linux. I installed the mandrake 9.0 distribution with no problems at all, and the x server running perfectly. I needed to upgrade so that i could use my TV-OUT port, so i followed the instructions on the NVIDIA website to the tee (using the rpm method), everything "compiled" okay. i edited the XF86Config-4 file (since XFree86 is using that config file and even if it wasn't i tried running it like "XFree86 -xf86config /etc/X11/XF86Config-4"). When I tried to start the server (I'm running the at the shell, with the x server disabled at startup) my monitor blinks 3 times with fast blue screens then it stops doing anything and my computer hangs and i have to press the system reset button. after investigating the log file there is no sign of error except for a warning at the end saying "Failed to load AGP" or something similar. I edited the config file to say Option "NvAgp" "0", but still same response when i start my X server. I have the log files + the config file. If anyone is willing to help me out i'd really appreciate it! my system specs are:

Geforce 2 MX400 64MB SDRAM AGP
VIA VT82C598MVP AGP system controller

here is the config file i am using:

# File generated by XFdrake.

# ************************************************** ********************
# Refer to the XF86Config man page for details about the format of
# this file.
# ************************************************** ********************

Section "Files"
# Multiple FontPath entries are allowed (they are concatenated together)
# By default, Mandrake 6.0 and later now use a font server independent of
# the X server to render fonts.
FontPath "unix/:-1"

Section "ServerFlags"
#DontZap # disable <Crtl><Alt><BS> (server abort)
AllowMouseOpenFail # allows the server to start up even if the mouse doesn't work
#DontZoom # disable <Crtl><Alt><KP_+>/<KP_-> (resolution switching)

Section "Module"
Load "dbe" # Double-Buffering Extension
Load "v4l" # Video for Linux
Load "extmod"
Load "type1"
Load "freetype"
Load "glx" # 3D layer

Section "InputDevice"
Identifier "Keyboard1"
Driver "Keyboard"
Option "XkbModel" "HP
Option "XkbLayout" "us"
Option "XkbOptions" ""

Section "InputDevice"
Identifier "Mouse1"
Driver "mouse"
Option "Protocol" "PS/2"
Option "Device" "/dev/psaux"
Option "Emulate3Buttons"
Option "Emulate3Timeout" "50"

Section "Monitor"
Identifier "monitor1"
VendorName "Generic"
ModelName "1024x768 @ 60 Hz"
HorizSync 31.5-48.5
VertRefresh 60 # 50-70

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
Driver "nvidia"
Option "NvAgp" "0"
Option "DPMS"

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 24

Subsection "Display"
Depth 8
Modes "800x600" "640x480"

Subsection "Display"
Depth 15
Modes "800x600" "640x480"

Subsection "Display"
Depth 16
Modes "800x600" "640x480"

Subsection "Display"
Depth 24
Modes "800x600" "640x480"

Section "ServerLayout"
Identifier "layout1"
InputDevice "Keyboard1" "CoreKeyboard"
InputDevice "Mouse1" "CorePointer"
Screen "screen1"


i attached the log output i get.

again thanks in advance to whoever can help me solve this problem.

chrono86 10-11-02 10:57 PM

okay so i STILL have the same problem. I have have narrowed it down from the agp (or maybe i just think i have) and the extra options in the config file. What happened? same exact thing. I tried using the XFree86 NVidia driver (nv) and that works perfectly (When i don't load the glx, which was modified when i installed the nvidia version). i was thinking for a moment that it could be my monitor settings and that its just hte monito acting up but when the nv driver works under the same monitor configuration i eliminated that. I'm all out of ideas, could it just be that the driver isn't compatible with my card? Thanks to anyone who can guess what it going wrong witht his.

bwkaz 10-12-02 08:14 AM

Hmm... it's probably not that the drivers aren't compatible with your card -- they work with all nVidia cards.

If you comment the Load "v4l" line, does that help? You won't have Video 4 Linux support, but if it works, it might be worth it.

Are you passing mem=nopentium to the kernel at boot time? (I see you have a K6, so I don't know if that's even a problem with that processor, but it's worth a shot anyway)

Also try commenting out the Option "DPMS" line, see if that helps.

chrono86 10-12-02 09:45 AM

Yeah i'm thinking the same thing, but it SHOULD be compatible with my card. My card is very generic its basically just a board with the NVidia chip. I tried commenting out all the extra options and still i get nothing. Maybe it is the mem=nopentium thing, but you're right that shouldn't even be a problem since i have a K6 family processor. It's worth a try though i guess. So how do i add this option to my boot process? Does it work though lilo or the kernel? thanks

bwkaz 10-12-02 12:09 PM

If you use lilo, you can do it one of two ways. To only do it temporarily, wait until lilo is running. Then if you change the selection to something else, then back to whatever you called your linux boot, so that you get that thing's name in the prompt (mine is called LFS, yours could be linux or mandrake or whatever), you can just type " mem=nopentium" (w/o the quotes) and hit return. Then, once Linux is up, check /proc/cmdline to make sure the option got passed.

Otherwise, you can edit /etc/lilo.conf, and add mem=nopentium to the append= line in the proper section. After you've saved the config file, run /sbin/lilo -v to make the changes active.

All times are GMT -5. The time now is 02:02 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.