nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   ERROR: Unable to load the kernel module ‘nvidia.o’ (http://www.nvnews.net/vbulletin/showthread.php?t=27510)

jaavedm 04-17-04 02:27 PM

ERROR: Unable to load the kernel module ‘nvidia.o’
 
New Linux User here. I am trying to install the NVIDia Display driver. However during installation, that is after I have read the disclaimer, I get an error saying

"ERROR: Unable to load the kernel module ‘nvidia.o’. This is the most likely because the kernel module was built using the wrong kernel source files. Please make sure you have installed the kernel source files for your kernel…

…If you know the correct kernel source files are installed, you may specify the kernel source path with the ‘—kernel-source-path’ commandline option."

I used the command "rpm -qa | grep kernel" which tells me Kernel-2.4.22.10mdk-1-1mdk. Where do I go from here? How do I get the installer to recognize this kernel, if it is the right kernel at all.


I just found out that in /usr/src, i only have one file which is RPM. While reading the post, some say to type
sh NVIDIA-Linux-x86-10-5336-pkg1.run --Kernel-source-path /usr/src/(whatever)

But in my case, i don't have a (whatever) be it linux-2.4.22.10mdk

Talornin 04-17-04 11:47 PM

Re: ERROR: Unable to load the kernel module ‘nvidia.o’
 
I dont use Mandrake, never have, so Im not quite sure, but I would assume that you need to either unpack the rpm file or find a mdk-kernel-source rpm, maching your kernel, somewhere on the web and install it.

pzgren 04-18-04 02:27 AM

Re: ERROR: Unable to load the kernel module ‘nvidia.o’
 
hello,

you need kernel-source-2.4.22-28mdk.i586.rpm The other one is only the ready kernel to run your system, not the sources.

And you should before, install an up2date secure kernel for your CPU There many more updates for MDK 9.2. Install them! They are not there for nothing. ;-)

Here: http://ftp-stud.fht-esslingen.de/pub...ates/9.2/RPMS/

kernel-i686-up-4GB-2.4.22.28mdk-1-1mdk.i586.rpm (Athlon CPU,...)
kernel-p3-smp-64GB-2.4.22.28mdk-1-1mdk.i586.rpm (Intel P3 SMP system)

and the source for all: kernel-source-2.4.22-28mdk.i586.rpm

maybe you need some others like glibc-devel or the GCC and look what rpm says.


Regards,

Marcus

jaavedm 04-18-04 01:17 PM

Re: ERROR: Unable to load the kernel module ‘nvidia.o’
 
So in downloaded and installed kernel-source-2.4.22-28mdk.i586.rpm. This added to my /usr/src/ folder the two files:

linux
linux-2.4.22-28mdk
RPM (--which was here previously)

Now when I type in
sh NVIDIA-Linux-x86-1.0-5336-pkg1.run the same message occurs

I then type in
sh NVIDIA-Linux-x86-1.0-5336-pkg1.run --kernel-source-path /usr/src/linux-2.4.22-28mdk and the same message occurs.

I don't know what I am doing wrong. I've been reading about rebuilding the kernel but I don't know how to do this or if it will help. I also read in other posts to install the module-init-tools-3.0-pre10.tar.gz. I already downloaded this folder but have no idea about how to install a tar.gz folder. Could someone please help me.

jaavedm 04-18-04 01:38 PM

New Error
 
I just downloaded NVIDIA-Linux-x86-1.0.4363.run file

I tried to install it by typing in
sh NVIDIA-Linux-x86-1.0.4363.run
Same ERROR as before

Then I tried
sh NVIDIA-Linux-x86-1.0.4363.run --kernel-include-path /usr/include

Then it says
"No precompiled kernel interface was found to match your kernel; would you like the installer to attempt to download a kernel interface for your kernel from the NVIDIA ftp site (ftp://download.nvidia.com)" I hit yes.

"ERROR: Unable to connect to download.nvidia.com (temporary DNS error (try again later)) " I hit ok

"No matching precompile kernel interface was found on the NVIDIA ftp site; this means that the installer will need to compile a kernel interface for your kernel." Hit ok.

(attempts to build the module)

"ERROR: Unable to build the NVIDIA kernel module."

Where do I go from here?

pzgren 04-18-04 11:54 PM

Re: ERROR: Unable to load the kernel module ‘nvidia.o’
 
Ok farmer method now, do not know what MDK has done there or you... ;)
Jump to /usr/src/linux-2.4.22-28mdk and type

make menuconfig

the config menu appears. Exit it. Then type

make depend

Then try the installer again. If no go --->

Go to the location where the nVidia driver is and type

sh ./NVIDIA-Linux-x86-1.0-5336-pkg1.run --extract-only

It will be extracted to the subdir.

Edit the Makefile at the "install line" like this wo kernel_module_install after it:
...
install:
@echo "Removing all old and conflicting files!"
...
...

Now change to NVIDIA-Linux-x86-1.0-5336-pkg1/usr/src/nv and type

make install

only the kernel module will now installed.

Then back to the top of the NVIDIA-Linux-x86-1.0-5336-pkg1 and again for the GXL driver.

make install

If allright, edit /etc/X11/XF86Config
...
Section "Module"
Load "dbe"
Load "extmod"
Load "glx"
Load "freetype"
Load "type1"
Load "v4l"
EndSection
...
Section "Device"
...
Driver "nvidia"
...

et voila?

Marcus

SOCiOPATh 04-20-04 10:50 AM

Re: ERROR: Unable to load the kernel module ‘nvidia.o’
 
I exactly had the same problem and solved it recently.
For me I stupidly forgot disabling Direct Rendering Manager in my 2.6.5 kernel ... :bash: .
Then the ERROR magicly diseapered.


All times are GMT -5. The time now is 09:53 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.