nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Module will not load at boot (http://www.nvnews.net/vbulletin/showthread.php?t=27603)

psiegel 04-20-04 08:30 AM

Module will not load at boot
 
I'm running Mandrake 10.0, and have installed the 5336 drivers. While it basically works, the nvidia module simply will not load at boot. I must log in and type "modprobe nvidia" first, then start X manually. I see that others on this forum have had similar problems, but many of the fixes they list don't help. Here's what I've tried:

/etc/modules.devfs
The last line used to read: alias /dev/nvidia* NVDriver
I changed this to: alias /dev/nvidia* nvidia

/etc/modules.conf
I added the following: alias /dev/nvidia* nvidia

/etc/modules
I added the following: nvidia

I tried the following sequence of commands:
> depmod 2.6.3-7mdk
> modeprobe nvidia

This makes it work for the current login, but on reboot the module still doesn't load.

Does anyone have any other thoughts? The drivers work, it's just a pain to have to manually load them on every boot.

Paul

whig 04-20-04 07:24 PM

Re: Module will not load at boot
 
In Mandrake 9.2 I put nvidia in/etc/modprobe.preload (2.6 kernel).

psiegel 04-21-04 07:51 AM

Re: Module will not load at boot
 
Excellent, that did it. Thanks!

The odd thing is, when I was running Mandrake 9.2 it just worked. All I had to do was run the installer and modify my XF86Config-4 file. I wonder though if 9.2 had an older kernel by default?


All times are GMT -5. The time now is 04:31 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.