nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   nForce locups (http://www.nvnews.net/vbulletin/showthread.php?t=27848)

reve_etrange 04-25-04 10:40 PM

nForce lockups
 
The nForce lockup problem has been around for a while now. I have spent the better part of a month trying to fix it. It is making my system virtually unusable-and making me wonder if nVidia deserves its reputation as a Linux-friendly company.
These are the "fixes" I have used: setting idle=pass, not compiling ACPI into the kernel, setting mem=nopentium, setting acpi=off. Then only unimplemented fix I have heard about is using hdparm to change a UDMA setting, but I'm not sure how to do this.

Has anybody solved this problem? How?

Thanks,
Daniel

NF7-S 2.0, GeForce FX 5600 ULTRA, Debian with kernel 2.6.5, Athlon XP 1700+ at 2 GHz

kgroombr 04-27-04 12:02 PM

Re: nForce locups
 
I fixed mine by disabling the CPU Disconnect function in the BIOS. This is on ABit NF7-S and AN7 boards.

Another fix that worked before I did the above was:

Compile the kernel with absolutely no APIC or ACPI support.
Specify the kernel line options acpi=off noapic noioapic

Good luck,
Ken

reve_etrange 04-29-04 08:26 PM

Re: nForce locups
 
I am using an Abit NF7-S. I disabled CPU disconnect, and set my UDMA settings to UDMA3 (with hdparm -X udma3 /dev/hda). Things are working OK right now, no lockup so far. I am going to test it (with grep, which usually caused the lockups), then turn off workarounds one by one until the problem returns; I want to know what is causing this exactly. Thank the Linux gods for a journaling filesystem (each lockup requires a hard reboot).
-Daniel


All times are GMT -5. The time now is 05:17 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.