nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Frozen screen with GeForce2 GTS and SuSE 7.3, 8.0, 8.1 (http://www.nvnews.net/vbulletin/showthread.php?t=2797)

ltgnome 10-12-02 06:53 PM

Frozen screen with GeForce2 GTS and SuSE 7.3, 8.0, 8.1
 
Help!!!
I need some antifreeze for my PC-screen – and haven't found it yet!

Ok. – here is my problem:
I use a nVIDIA GeForce2-GTS. No problems with windows, but a lot with Linux and the nVIDIA drivers: after some minutes the screen „freezes“, the mouse-cursor is still moving but clicking has no effect (and no changes in the cursors shape), the keyboard is „dead“, no key incl. Num-Lock, Caps-Lock gives any response. The system is running, you can see some activity of the harddisk, when connecting an USB-device (e.g. mouse), the system obviously reacts – but I still have no device to do anything with that system: keyboard and mouse have no function at all. I tried to wait some time, hoping the „frozen-running“ system would change the status in any way, but after two hours nothing had happened. The only possibility, to continue work is to use the reset-button!

I found a lot of hints in this forum, but nothing worked. Here are the details:

The problem occured with SuSE 7.3, SuSE 8.0 and SuSE 8.1 (all with reiser-fs). The problems occured with all (at least those I got in the past 18 months) versions of NVIDIA_GLX- and NVIDIA_kernel-packages. The problem occured with Gnome1.4 with sawfish, with Gnome2 and metacity, with KDE3.

In my case it's obviously not a problem of the kernel-version, the driver-version and it's not a problem of Gnome or Gnome2!

In all cases the installation was no problem (good README from NVIDIA!), no errors in XFree86.0.log after starting the X-System. The correct drivers were used, everything looked fine, testing shows that the drivers were doing there (good) work.

And after some minutes – frozen screen, dead keyboard. After the reset there are no errors in any message- or log-file – at least I found nothing at all.

I tried to use the source-rpms – no problems, everything worked as described. Startx – ok. XFree86.0.log – ok. And some minutes later – after freezing - the only difference: the mouse-cursor was „dead“, too.

I tried the <Option „NoRenderAccel“ „true“>. Good idea – I could work about ten minutes longer before the screen frozes...

I'm really a little bit „unhappy“! And I have no idea, what the cause for these problems should be! Perhaps someone knows an excellent antifreeze for me! Thank you!

bwkaz 10-12-02 07:30 PM

What processor is in this computer? If it's an Athlon XP or MP, then upgrading to kernel 2.4.19 might help. If it's a plain Athlon T-bird, or I think Duron, then passing "mem=nopentium" to your kernel at boot time might help.

Have you tried both AGP implementations (Option "NvAgp" "x", where x is either 1 or 2, in your X config file)?

ltgnome 10-13-02 05:58 PM

Sorry, it's my mistake, not to give the system data:

No, it's an Intel Pentium III (coppermine ?!) with 1000 MHz, 133 MHz FrontSiteBus (ASUS-Board), 1024 MB SDRAM.

Yes, with SuSE 7.3 I tried NvAgp = 1 and = 2, with less success, as far as I remember. In the actual system not yet, I'll try it again. Report of result will follow.

wastrel 10-14-02 02:26 AM

Confirmation on memory problem with Nvidia on Suse 8.0 and Red Hat 8.0
 
I can confirm this problem with both the previous version of the drivers and the latest version.

I have the following hardware:

Athlon 850 MHz
512 MB RAM
40 GB HD
Leadtek graphics card based on NVidia GeForce2 GTS chipset

I had installed SuSE 8.0 on the system and had consistent system freezes after 2+ hours. The main characteristic of the system freezes was graphics corruption. In addition, running KSysMonitor in the KDE panel showed that the memory required by the system slowly increased over time. I'm not sure how to track down what process has the memory leak: Whether its the nvidia driver or another component that affects the nvidia driver.

I also turned of agpgart driver and used the nvidia one, but to no avail. I installed Red Hat 8.0 hoping that the new system would contain the fix, but no dice. My machines still freezes after a two to three hours and the memory consumed slowly increases over time.

-R

bwkaz 10-14-02 07:53 AM

Re: Confirmation on memory problem with Nvidia on Suse 8.0 and Red Hat 8.0
 
Quote:

Originally posted by wastrel
...the memory consumed slowly increases over time.
Up to what? Does the amount of memory used stay below the amount of physical memory you have?

Linux does not handle memory the same way as Windows does -- it will allocate free physical memory to things like caching filesystem data (to make FS searches faster the second time around), up to the point where only a small amount of physical memory is free. Then when a program needs some allocated, the kernel moves it from the FS cache to that program. Instead of maximizing the total amount of free memory, you should be trying to figure out if you're ever hitting your swap partition. If so, then you might have a problem (or just not enough memory).

You can run ps aux to get a one-shot listing of all the processes that are running. One of the columns is labeled %MEM; this is the column keeping track of the percentage of (virtual) memory that that specific process is taking up. Also, VSZ is the virtual-memory footprint of the program. Look for the largest %MEM and VSZ programs, and consider killing them off.

KDE is one usual culprit of memory hogging. X itself is another (but if X has a large VSZ, that's OK, because the stuff that's swapped out generally never swaps back in). I believe Gnome is fairly huge as well.

Since you have a non-XP/MP processor, have you tried passing mem=nopentium to your kernel at boot time? Upgrading to 2.4.19 doesn't fix the problem with plain Athlons, I believe. You could also try disabling AGP altogether (Option "NvAgp" "0"), as that would be another way to fix that problem. If you still get lockups, then the Athlon vs. AGP bug isn't what's causing them.

ltgnome 10-14-02 07:15 PM

It works!
 
:) :) :)
Oh yeah! 7 hours running system without freezing!

And here is the How to Do, at least in this (that means: my) case:

First some remarks:

When scanning the threads for the "freezing screen"-error I notized that in most cases the graphic-card was a GeForce2. Perhaps there is a general problem with this one, because the problem appears with different processors and different boards.

OK. Now let's take a look at the system:
GeForce2 GTS, Pentium III with 1000 MHz (ASUS), 1024 MB SDRAM (that means: at least enough of memory).
SuSE 8.1

Standard installation of SuSE8.1 Linux will install the "dummy"-nVIDIA-drivers. After install or update, test the functions of the X-windows-system with 'startx', 'startx gnome' or whatever you prefer. If it works well, you may install the (original) nVIDIA drivers. If you have installed the standard SuSE-kernel and all the other stuff you need from the distribution CDs/DVD without (too much) modifications, you may download the rpm-packages from the nvidia-donwload-page.
For SuSE8.1 there are the two rpm's:
- NVIDIA_kernel-1.0-3123.suse81.i586.rpm
and
- NVIDIA_GLX-1.0-3123.suse81.i586.rpm
and the README as text or pdf-file. Please read the instructions in this README if you have problems (it's really helpfull!).
After downloading the rpm's and reading the instructions, leave the X-window-system. Log in as root if you didn't yet.

Then uninstall the dummy-drivers with

rpm -e NVIDIA_kernel
rpm -e NVIDIA_GLX

(I don't know, if it's really necessary, but I think it's a good idea).

Edit (e.g. with vi) the XFree86-configuration-file. You will find it in the case of SuSE8.1 in the directory '/etc/X11' and it's named 'XF86Config' (resp. 'XF86Config-4'). Look for the line 'Section "Device"' It should look similar to the following lines:

Section "Device"
BoardName "GeForce2 GTS"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
VendorName "NVidia"
EndSection

The actual data may vary a little bit, depending on your specific system. Add the following line in that section (that means between the 'Section' and the 'EndSection':

Option "NvAgp" "0"

Now it should look like this:

Section "Device"
BoardName "GeForce2 GTS"
BusID "1:0:0"
Driver "nvidia"
Identifier "Device[0]"
Screen 0
VendorName "NVidia"
Option "NvAgp" "0"
EndSection

Install the drivers with the following commands (assuming you have changed to the directory where you stored the packages):

rpm -ivh NVIDIA_kernel-1.0-3123.suse81.i586.rpm
rpm -ivh NVIDIA_GLX-1.0-3123.suse81.i586.rpm
ldconfig

That's it. If you have a 'normal' running, not too much modified SuSE8.1-system, there should be no warnings or errors. In all other cases you have a problem with the system itself (see also README!).

After installing the packages I stopped the system (init 0) in order to be shure, to start a clean system.

And it worked for seven hours without any problem. "Normally" the freezing-problem occured after ten minutes or so. Best method was to use OpenOffice.org, changing the font of some text, calling the help-function - frozen...

I hope it will work in the other cases, too.
But I don't think, that this is the best way - it's not really a good idea to disable the AGP-features in order to have a running system... Perhaps someone has an idea what the reason for this behaviour is and perhaps there exists a workaround with less radical methods...

Good luck!


All times are GMT -5. The time now is 09:21 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright ©1998 - 2014, nV News.