nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   NVidia / XMMS OpenGL plug-ins bug (http://www.nvnews.net/vbulletin/showthread.php?t=28050)

Neoslak 04-29-04 02:39 PM

NVidia / XMMS OpenGL plug-ins bug
 
There has been an extant bug that has been bugging me for months. I first filed a bug report (Bugzilla Bug 1596) on January 29, 2001, only to have this bug marked as a duplicate of bug 1564 that was opened January 17th which was marked as a duplicate of bug 1386 that was opened September 10, 2003. Another 'duplicate' of this bug is bug #1568 filed January 18th.

I've searched the NVidia news group, Google, and about half a dozen forums and message boards, tried the #XMMS channel on IRC numerous times and still can't seem to find a solution.

It seems that the XMMS folks must think it is an NVidia bug and the NVidia folks think it is an XMMS bug...
And round and round we go! Some have declared it possibly a kernel bug, some guess an XFree86 bug... nobody seems to know for sure.

Well, I'm up to XMMS 1.2.10 and NVidia-Linux-1.0-5336, kernel 2.6.5, gcc-3.3.3, etc. and still XMMS crashes on trying to close any OpenGL plugin.

Here's what I first filed as a bug report on this problem back in January:

-----clip-----
Closing any OpenGL visual plugin crashes XMMS 1.2.9 with a segmentation fault,
either by trying to close the plugin window or unchecking the Visual Plugins
'Enable Plugin' check box.

On my system so far I tried both the NVidia 5328 drivers and the new 5336
drivers and this problem occurs on both.

I'm running Slackware 9.1, AMD Athlon 650, NVidia GeForce4 MX 440, Linux kernel
2.4.24, gcc-3.3.2, glib2-2.2.3, glibc-2.3.2, gtk+2-2.2.4.

If this helps, here are the dependencies listed for XMMS 1.2.9 on my system.

ldd /usr/bin/xmms
libSM.so.6 => /usr/X11R6/lib/libSM.so.6 (0x40030000)
libICE.so.6 => /usr/X11R6/lib/libICE.so.6 (0x40039000)
libxmms.so.1 => /usr/lib/libxmms.so.1 (0x40050000)
libgtk-1.2.so.0 => /usr/lib/libgtk-1.2.so.0 (0x4005d000)
libgdk-1.2.so.0 => /usr/lib/libgdk-1.2.so.0 (0x4017c000)
libgmodule-1.2.so.0 => /usr/lib/libgmodule-1.2.so.0 (0x401ad000)
libgthread-1.2.so.0 => /usr/lib/libgthread-1.2.so.0 (0x401b0000)
libglib-1.2.so.0 => /usr/lib/libglib-1.2.so.0 (0x401b3000)
libXext.so.6 => /usr/X11R6/lib/libXext.so.6 (0x401d4000)
libX11.so.6 => /usr/X11R6/lib/libX11.so.6 (0x401e2000)
libasound.so.2 => /usr/lib/libasound.so.2 (0x402aa000)
libm.so.6 => /lib/libm.so.6 (0x40353000)
libdl.so.2 => /lib/libdl.so.2 (0x40375000)
libpthread.so.0 => /lib/libpthread.so.0 (0x40378000)
libc.so.6 => /lib/libc.so.6 (0x403c9000)
/lib/ld-linux.so.2 => /lib/ld-linux.so.2 (0x40000000)

Appreciate any help or feedback -

Chuck Bell

Neoslak 04-29-04 02:42 PM

Re: NVidia / XMMS OpenGL plug-ins bug
 
Oops... typo "There has been an extant bug that has been bugging me for months. I first filed a bug report (Bugzilla Bug 1596) on January 29, 2001"

Thats was January 29th 2004, not 2001. Sorry 'bout that

Neoslak

yodaofborg 04-29-04 02:50 PM

Re: NVidia / XMMS OpenGL plug-ins bug
 
I have also had a simaler problem with xmms and the visualsation plugins. it got so bad on my old mdk9.2 box i had to delete all .xmms settings after a bad exit, or xmms would sigfault everytime i tried to reopen it - because the plugin would try to start again as soon as i opened xmms. not sure who's fault it is, but it did seem better in mdk 10, with the 5000+ drivers. i say did, because it was stable for around a week, even using the goom plugin, it now exits if i try activate a plugin. Totem also uses a simaler goom plugin, and that works fine.


This peed me off for ages, i bugged xmms, they blaime nvidia, so how come it has started to happen on my ati rage mobilty too ??...lol

dunno who's fault it is, been experiencing it since redhat 8 and my tnt2...lol just wish also it would be sorted soon :)

SuLinUX 04-29-04 05:26 PM

Re: NVidia / XMMS OpenGL plug-ins bug
 
Dont crash with the 4620 driver, I'll have to try it with the 5336 as I switch for tesing.

Neoslak 04-29-04 10:33 PM

Re: NVidia / XMMS OpenGL plug-ins bug
 
The 4620 driver doesn't support the 2.6 kernels does it? If not, then that isn't a very workable solution for me. Let me know how your testing goes.

Chuck

MNKyDeth 04-30-04 01:52 AM

Re: NVidia / XMMS OpenGL plug-ins bug
 
Pretty much most all drivers can be made to be used in the 2.6 kernels. Here check this. www.minion.de and http://www.sh.nu/download/nvidia

Hope those can help out. I really like the 4620 drivers cause of the nvidia-settings front end. All nvidia drivers should include this. It's pathetic we don't have this in official drivers.

energyman76b 04-30-04 09:11 PM

Re: NVidia / XMMS OpenGL plug-ins bug
 
hi,

well, xmms crashes because of this bug since ages... I am remembering well, how it segfaulted with my ati rage 128pro based card... so it is not nvidias fault...

And if you do want to get rid of the plugin (deactive it) just remove it from ~/.xmms/config
For iris get rid of this line:
enabled_vplugins=libiris.so
the others are looking similar

Neoslak 05-10-04 12:02 PM

Re: NVidia / XMMS OpenGL plug-ins bug
 
If you are also experiencing this problem, go to http://bugs.xmms.org/show_bug.cgi?id=1386
and add your vote for this bug.

Neoslak 05-11-04 06:36 AM

Re: NVidia / XMMS OpenGL plug-ins bug
 
Well, I verified that this problem with XMMS crashing on OpenGL plugins does *not* occur with the 4620 driver as pointed out by SuLinUX above. Thanks! It even works fine on my system with a new 2.6.6 kernel.

But, that would lead me to think it probably *is* a bug in the newer NVidia drivers, not in XMMS, which has wasted so much of my time! So I guess I should retract the bug report I filed and leave some info there about which driver to use to avoid that problem.

Chuck

----------------
Slackware Linux - The Professionals Choice!


All times are GMT -5. The time now is 01:11 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.