nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Red Hat 8.0 and nForce drivers (http://www.nvnews.net/vbulletin/showthread.php?t=2808)

alphajoe 10-12-02 11:38 PM

Red Hat 8.0 and nForce drivers
Has anyone had any success compiling the source tarball for the nforce chipset?

I am getting the following errors when I try and compile the tarball:

warning: user buildmeister does not exist - using root
warning: user buildmeister does not exist - using root
warning: user buildmeister does not exist - using root
warning: user buildmeister does not exist - using root

I get this error a couple of times during the compile, then it fails at the end with:

Bad exit status from /var/tmp/rpm-tmp.5818

Looking farther up in the output, I find the following lines:

Executing(%build): /bin/sh -e /var/tmp/rpm-tmp.5818
+ umask 022
+ cd /usr/src/redhat/BUILD
+ cd nforce
+ export LANG
+ -n nforce
/var/tmp/rpm-tmp.5818: line 23: -n: command not found

Has anyone else had trouble installing the sources for the nForce chipset under RedHat 8.0?


tanksimpson 10-13-02 08:40 AM

I think the question would be "has anyone managed to install the nforce drivers on RH 8.0 AT ALL?! :)

Seriously, I got errors similar to yours. I just have no clue. Could be Red Hat's newest kernel is screwy, could be that the nforce drivers don't like GCC 3.2. I think we will need to wait until NVIDIA releases new drivers for RH 8.0.

doom 10-13-02 11:14 AM

Yes i too got the same error.
Try going to the "still waiting nvidia..." thread. bwkaz has a bit of a solution.

BossMD 10-14-02 12:53 AM

The problem with nforce-1.0-0241 and RH 8.0 is simple. The RH 8 kernel is now compiled with gcc 3.2. Both "nvnet.o" and "nvaudio.o" that are included in the src downloads are compiled with gcc 2.95. You can compile and install without warning, however when you reboot the two new devices will still not be available. The kernels released with 8.0 have issue loading kernel modules compiled with gcc 2 (if you have tried to install already and run 'modprove nvnet' it will tell you this). The best answer right now unfortunatly is to wait till nVidia gets on the ball and releases 8.0 binray or source with updates .o's.

captain_obvious 10-17-02 11:44 AM

I had the exact same problem when trying to use the source rpm's, so instead, I used the tarballs. They worked the way they are supposed to. I have X up and running now, with only one minor problem with my mouse (it doesn't work). Get the tarball for the display driver from this link:


Then just install according to the instructions NVIDIA supplies.

Hope this helps!

captain_obvious 10-17-02 05:43 PM

Complete success
I am now having no problems with audio, usb, ethernet, or display drivers. At the very least the tarballs for the drivers work.

At first my audio didn't work, but when I opened the volume settings, it suddenly had audio. Perhaps that is the trick.

All times are GMT -5. The time now is 10:11 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.