nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   line 716 : ./nvidia-installer: permission denied (http://www.nvnews.net/vbulletin/showthread.php?t=28138)

DavidSulc 05-02-04 01:56 PM

line 716 : ./nvidia-installer: permission denied
 
Here's my problem :

I compiled a 2.6.4 kernel nder Debian (testing). I then ran the installer and everything went fine. I then imediately recompiled, adding the "device mapper" or something of the sort (to be able to use lvm). Previously, this was compiled as a module.

I now get the error "line 716 : ./nvidia-installer: permission denied". I am using the 5336 driver, although the error also appeared with the 5328 driver (patched for 2.6).

The card is a GeForce FX 5650 (laptop).

Yes. I'm trying to install the driver as root, and the gcc version is the same as the one used to compile the kernel...

Thank you for any help !

MUYA 05-02-04 01:57 PM

Re: line 716 : ./nvidia-installer: permission denied
 
There is a linux section ..so I will move this there.

Pls read the warnings when u post folks.

Linux section is exactly what it says it is...a forum for Linux users!!!!

DavidSulc 05-03-04 12:38 PM

Re: line 716 : ./nvidia-installer: permission denied
 
Sorry about that...

I tried re-installing the driver on the 2.6.3 kernel, and I get the same error (if that helps anyone).

hppnq 05-03-04 07:14 PM

Re: line 716 : ./nvidia-installer: permission denied
 
Can you post the output of the 'mount' command, please?

Also, could you do the following: could you open your installer script (the one that ends in .run) in your favourite text editor, and insert the line "set -x" immediately after the first one that reads "#! /bin/sh", so that you get

#! /bin/sh
set -x
[...]

and then run it again like this:

# ./NVIDIA[..].run 2> /tmp/output

(Use the proper installer script name, of course.)

Attach the resulting /tmp/output file.

DavidSulc 05-05-04 02:12 PM

Re: line 716 : ./nvidia-installer: permission denied
 
Mount result :

/dev/hda6 on / type reiserfs (rw)
proc on /proc type proc (rw)
sysfs on /sys type sysfs (rw)
devpts on /dev/pts type devpts (rw,gid=5,mode=620)
tmpfs on /dev/shm type tmpfs (rw)
/dev/hda5 on /boot type ext2 (rw)
/dev/hda7 on /home type reiserfs (rw)
/dev/mapper/VG0-LV0 on /tmp type reiserfs (rw,noexec)
/dev/hda1 on /win type ntfs (rw,noexec,nosuid,nodev)
usbfs on /proc/bus/usb type usbfs (rw)
/dev/sdb1 on /usb type vfat (rw,noexec,nosuid,nodev)

after adding set -x, I get :
+ skip=753
+ CRCsum=230898608
+ MD5=235ef8f11ffa32071c80ec9e0f272694
+ label=NVIDIA Accelerated Graphics Driver for Linux-x86 1.0-5336
+ major_version=1
+ minor_version=0
+ patch_version=5336
+ pkg_version=1
+ script=./nvidia-installer
+ targetdir=NVIDIA-Linux-x86-1.0-5336-pkg1
+ scriptargs=
+ keep=n
+ add_this_kernel=
+ TMPROOT=/tmp
+ TARGET_OS=Linux
+ TARGET_ARCH=x86
+ '[' '' = -help -o '' = --help -o '' = -h ']'
+ '[' '' = -A -o '' = --advanced-options ']'
+ '[' '' = -lsm -o '' = --lsm ']'
+ '[' '' = --pkg-history ']'
+ '[' '' = --label ']'
+ '[' '' = --major-version ']'
+ '[' '' = --minor-version ']'
+ '[' '' = --patch-version ']'
+ '[' '' = --pkg-version ']'
+ '[' '' = --target-os ']'
+ '[' '' = --target-arch ']'
+ '[' '' = --target-directory ']'
+ '[' '' = --script ']'
+ '[' '' = --info ']'
+ '[' '' = --list ']'
+ '[' '' = --check ']'
+ run_script=y
+ '[' '' ']'
++ uname
+ LOCAL_OS=Linux
++ uname -m
+ LOCAL_ARCH=i686
+ '[' i686 = i386 ']'
+ '[' i686 = i486 ']'
+ '[' i686 = i586 ']'
+ '[' i686 = i686 ']'
+ LOCAL_ARCH=x86
+ '[' -z Linux -o -z x86 ']'
+ '[' x86 '!=' x86 -o Linux '!=' Linux ']'
+ '[' n = y ']'
+ workingdir=/tmp/selfgz3162
+ tmpdir=/tmp/selfgz3162/NVIDIA-Linux-x86-1.0-5336-pkg1
+ rm -rf /tmp/selfgz3162/NVIDIA-Linux-x86-1.0-5336-pkg1
+ '[' -d /tmp/selfgz3162/NVIDIA-Linux-x86-1.0-5336-pkg1 -o -f /tmp/selfgz3162/NVIDIA-Linux-x86-1.0-5336-pkg1 ']'
+ mkdir -p /tmp/selfgz3162/NVIDIA-Linux-x86-1.0-5336-pkg1
++ pwd
+ location=/root
+ echo=echo
+ '[' -x /usr/ucb/echo ']'
+ '[' x '!=' x1 ']'
+ echo -n 'Verifying archive integrity... '
++ tail -n +6 ./NVIDIA-Linux-x86-1.0-5336-pkg1.run
++ cksum
++ sed -e 's/ /Z/' -e 's/ /Z/'
++ cut -dZ -f1
+ sum1=568407370
+ '[' 568407370 '!=' 230898608 ']'
+ echo 'Error in check sums 568407370 230898608'
+ exit 2

and the fact that the installer refuses to run, because the checksums don't match...

I hope we can get this sorted out soon, because Windows and I don't get along really well...

hppnq 05-06-04 02:59 AM

Re: line 716 : ./nvidia-installer: permission denied
 
Damn, forgot about the checksum. ;-(

Remove that set -x from the installer script.

My bets are on your /tmp filesystem being the culprit. In any case, if you're trying to install from one of the filesystems mounted with the noexec option, you won't be able to run the installer. Does that get you any further?

DavidSulc 05-06-04 12:33 PM

Re: line 716 : ./nvidia-installer: permission denied
 
Possibly...

Well, my /tmp directory is mounted noexec, but that shouldn't bother the installer, should it ?

Also, my /tmp directory is part of a LVM logical Volume. Do you think that could be causing the trouble ?

(I'm not home right now, so I can't check this yet...)

Oh, and I re-downloaded the installer from nVidia's site, since even after removing the set-x option the checksum didn't match...

hppnq 05-07-04 02:54 AM

Re: line 716 : ./nvidia-installer: permission denied
 
In principle there's nothing wrong with /tmp on a logical volume; it's the first time that I see it mounted with a noexec option though. ;-) The error that you get makes sense if you are trying to install somewhere from /tmp, so I'd check that first.

Sorry about the checksum.

lotheac 05-07-04 11:44 AM

Re: line 716 : ./nvidia-installer: permission denied
 
Well... Did you do chmod +x? :)

edit: urgh. Might as well disregard that. How'd I miss "line 716"?

DavidSulc 05-12-04 07:20 PM

Re: line 716 : ./nvidia-installer: permission denied
 
Well, I ended up re-installing, as I wanted to change my system layout and try the new Debian installer.

But I bet the problem was : my /tmp directory was mounted with type "reiserfs" instead of "tmpfs" (it's still formated as reiserfs)... DUH !!!


All times are GMT -5. The time now is 09:00 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.