nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   two problems with current driver (http://www.nvnews.net/vbulletin/showthread.php?t=2815)

mat185 10-13-02 09:37 AM

two problems with current driver
 
Hi,

recently I managed to get the current drivers working with my GeForce4 MX440. However, I have still got two problems that disturb me:

1. The first problem is a little strange: I installed the GLX-modules with "make install" from the .tar.gz-package. After a reboot, the GLX-modules are loaded and it works fine, but after a few days, the modules aren't loaded correctly anymore. I do "make install" again and it works...
This is somewhat strange, as I haven't modified anything related to the X-server or the driver.

2. This is even more annoying: Every time the X server is started, the screen turns black for about 20-30 sec (!), and then the nvidia logo is displayed and I can log me in. In another forum, several users had the same problem and could not find a solution.

My system:
SuSE 7.3, Celeron 433 on Intel AL440LX motherboard, 256 MB RAM

Thank you for your help

mat

fabian 10-13-02 12:30 PM

Lame "same here"
 
Just want to add a lame "same here" to the second problem. When starting X, the screen goes blank for about 30 anoying seconds and then everything works, ut2003, q3, but sometimes (at this time, 6 times in two weeks), the system or either Oopses or reboots.

I have tried to append a "mem=nopentium" at boot time, but when then I've tried to start X, the system reboots.

I had to come back and use the xfree's nv driver.

Hardware:
ASUS A7V333 (VIA KT333)
256MB RAM
GeForce4 440MX
Athlon XP 2000+

Software:
Debian Sid
kernel 2.4.19 (and some others 2.4.20-pre, same problem)
Xfree 4.2.1 (Branden's 4.2.1-2)
NVIDIA_GLX-3123
NVIDIA_kernel-3123

Andy Mecham 10-13-02 01:07 PM

Re: 20-30 second start

What vbios revision are you using? You can check by looking in /proc/driver/nvidia/cards/0 while X is running. What specific card are you using? Who's the manufacturer?

--andy

mat185 10-13-02 01:54 PM

Hi,

user@linux:~> cat /proc/driver/nvidia/cards/0
Model: GeForce4 MX 440
IRQ: 11
Video BIOS: 04.17.00.28.00
Card Type: AGP

My card is a "Pixelview GeForce4 MX 440", here you can see a desription, it's the shop where I bought it: http://www.diekamera.de/pd1480835511.htm .

The manufacturer of the card is PROLINK, the homepage can be found here: http://www.prolink.com.tw/ .

Hope this supplies you with some helpful information.

mat

bwkaz 10-13-02 04:50 PM

mat185: How do you know the modules aren't getting loaded correctly? What's the error message that makes you think this?

And just as a chime-in, I do *not* have the 20-30 second delay, and I get this in /proc/driver/nvidia/cards/0:

Code:

[bilbo@beta slideshow]$ cat /proc/driver/nvidia/cards/0 
Model:          GeForce4 Ti 4200
IRQ:            11
Video BIOS:      04.25.00.29.00
Card Type:      AGP

So my BIOS is a later version number than yours... although I don't know if there's a difference between the MX BIOS numbers and the Ti BIOS numbers. There might be.

mat185 10-14-02 08:22 AM

Hi,

I know that there are only some users who have this problem with that delay, but it's a really annoying problem. So even if you have a later BIOS, the nvidka driver should normally support all BIOS versions.
So my question remains: Does anyone have an idea how to sove this problem?

mat

fabian 10-15-02 12:30 AM

Have the exact same problem with the 30 sec delay. For that period of time, the system is plain dead. Even if I'm downloading something, for that 30 secs, the external cablemodem shows no activity nor the ethernet's leds. The keyboard is also dead.

Code:

fabian@aiwha:~$ cat /proc/driver/nvidia/cards/0
Model:                  GeForce4 MX 440
IRQ:                    11
Video BIOS:          04.17.00.24.00
Card Type:          AGP

01:00.0 VGA compatible controller: nVidia Corporation NV17 [GeForce4 MX440] (rev a3) (prog-if 00 [VGA])
        Subsystem: Micro-star International Co Ltd: Unknown device 8661
        Flags: bus master, 66Mhz, medium devsel, latency 248, IRQ 11
        Memory at d6000000 (32-bit, non-prefetchable) [size=16M]
        Memory at d8000000 (32-bit, prefetchable) [size=128M]
        Memory at d7800000 (32-bit, prefetchable) [size=512K]
        Expansion ROM at d77e0000 [disabled] [size=128K]
        Capabilities: [60] Power Management version 2
        Capabilities: [44] AGP version 2.0

MSI G4MX440-T (MS-8866)
http://www.msi.com.tw/program/produc...&MODEL=MS-8866

bwkaz 10-15-02 08:08 AM

Would one of you guys be willing to try to get a rev. 29 BIOS?

I believe that in the BIOS version, the 4 is pretty much in all cards, the .17 is for NV17 chips (GF4 MXs) and the .25 is for NV25 chipst (GF4 Tis), I'm not sure what the next .00 field is, and I'm not sure what the last .00 field is. But the second to last field, where mine says .29 and yours are .28 and .24, might be the revision...

If you wouldn't mind trying, see if you can find a .29 video BIOS for your card. That would at least narrow it down -- if .28 doesn't work and .29 does, then that's the fix, I guess... Kind of annoying, but if there are BIOS bugs, then there are BIOS bugs.

mat185 10-15-02 09:34 AM

Hi,

a BIOS update might be solution, but neither do I know where to get the BIOS nor how to install it. I doubt if this worth trying, as I even don't know if the BIOS will cooperate with my card. Maybe it is really a driver problem that will be fixed in one of the next versions, because with Windows this problem does not occur. But indeed there is a growing number of users having this problem (see also thread Big DELAY), so let's see what comes...

mat

bwkaz 10-15-02 12:11 PM

Updates to the BIOS should be on the manufacturer's site. Getting the BIOS from there will also help with compatibility with your board.

Maybe it is a driver issue. Or maybe it's both -- maybe the Windows drivers have a workaround for BIOS bugs. I really don't know, I'm just trying to narrow things down.

If you don't want to try to flash your card, that's fine. I wouldn't want to either, if mine didn't have the backup BIOS on it for just in case something goes wrong in the flashing process (it's an MSI card). So I really don't blame you.

Waiting works too...

kappax 10-16-02 01:17 AM

kappax@thebox kappax $ cat /proc/driver/nvidia/cards/0
Model: GeForce4 Ti 4200
IRQ: 11
Video BIOS: 04.25.00.29.00
Card Type: AGP
kappax@thebox kappax $


I dont seem to have this problem you ppl speak of.

oh, i have a abit ti4200

mat185 10-16-02 02:39 PM

Hi,

I just tried to solve the problem with that delay by adjusting my X86Config, but did not have success with my options. So I'm quite certain now that this is a BIOS issue, and that nvidia should try to solve this in one of the next versions, as this behaviour is just INACCEPTABLE!

mat


All times are GMT -5. The time now is 12:08 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.