nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   RIVA TNT2/MDK 10/Screen resolution (http://www.nvnews.net/vbulletin/showthread.php?t=28349)

daves_not_here 05-05-04 09:32 PM

RIVA TNT2/MDK 10/Screen resolution
 
2 Attachment(s)
I am really having fun learning Linux, and have chosen Mandrake 10 as my first distro. So far, I really like it. I am an old DOS/PC person, and prefer to get my hardware working to my satisfaction before diving into loading all kinds of software, and I have reached a stumbling block with my screen resolution. I am currently running:

Distribution: Mdk 10 Community
Kernel: 2.6.3-4mdk
Kernel source installed: 2.6.3-4mdk
XFree86 version: 4.3.0.1

I have spent a fair amount of time searching, reading, and trying most of the suggestions posted here and elsewhere, and while able to work through things like getting the kernel source installed and the nVidia driver installed, I have been unable to solve the following problem:

No matter what I try, I cannot get the 1280x1024 resolution to work.

Every time I go into Mandrake Control Center->Hardware->Screen resolution,
the only setting that will 'stick' is 1280x960. It shows the correct video card, however.
Under the Graphical X Server settings, the Resolution is shown as 1280x1024.
My desktop is usable, but a bit hard on the eyes due to the fuzzy edges of fonts, etc.

I am 99.99% sure the resolution is NOT 1280x1024, because when I switch the monitor over to the Win2000 box, everything is sharp and crisp. There is a marked visual difference on the screen between the two boxes.

I see the nVidia splash screen when starting X, so it is loading the right (I guess) drivers for the vid. card.

Things I have done (all as root, of course):
-reinstalled Mdk
-made appropriate (I think) changes to XF86Config-4 (see snippets below and attached log files)
-added nvidia to modprobe.preload
-ran xf86config
-ran XFdrake
-added Mode "1280x1024" to each Display subsection of SF86Config-4 (then later removed as it didn't do anything)

Hardware: Compaq Deskpro, PIII 1 GHz, 128MB
Monitor: Sony SDM-M81, w/native resolution of 1280x1024
Horiz Scan Range: 28-92 kHz, Vert Scan Range: 48-85 Hz

This box is run through a KVM switch which shares this monitor and a keyboard with a Win2000 machine.

From /proc/driver/nvidia/cards/0:

Model: RIVA TNT2 Model 64/Model 64 Pro
IRQ: 18
Video BIOS: 02.05.19.03.11
Card Type: AGP

nVidia driver version: 5336

XF86Config-4 and XFree86.0.log (as .txt files, forum would not upload otherwise) are attached.



Most relevant portions of XF86Config-4:

Section "Module"
# This loads the DBE extension module.

Load "dbe" # Double buffer extension

# This loads the Type1 and FreeType font modules
Load "type1"
Load "speedo"
Load "/usr/X11R6/lib/modules/extensions/libglx.so"

# This loads the DRI module
# Load "dri"

# This loads the miscellaneous extensions module, and disables
# initialisation of the XFree86-DGA extension within that module.

Subsection "extmod"
Option "omit xfree86-dga" # don't initialise the DGA extension
EndSubsection
EndSection


Section "Monitor"
Identifier "monitor1"
HorizSync 28-92
VertRefresh 48-85

# Sony Vaio C1(X,XS,VE,VN)?
# 1024x480 @ 85.6 Hz, 48 kHz hsync
ModeLine "1024x480" 65.00 1024 1032 1176 1344 480 488 494 563 -hsync -vsync

# TV fullscreen mode or DVD fullscreen output.
# 768x576 @ 79 Hz, 50 kHz hsync
ModeLine "768x576" 50.00 768 832 846 1000 576 590 595 630

# 768x576 @ 100 Hz, 61.6 kHz hsync
ModeLine "768x576" 63.07 768 800 960 1024 576 578 590 616
EndSection

Section "Device"
Identifier "device1"
VendorName "nVidia Corporation"
BoardName "RIVA TNT2"
Driver "nvidia"
Option "DPMS"
Option "IgnoreEDID" "1"
EndSection

Section "Screen"
Identifier "screen1"
Device "device1"
Monitor "monitor1"
DefaultColorDepth 16

Subsection "Display"
Depth 8
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 15
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 16
Virtual 1280 1024
EndSubsection

Subsection "Display"
Depth 24
Virtual 1280 1024
EndSubsection
EndSection


Any recommendations on the following?
-Manually calculating all the H and V sync timings and adding these manually to XF86Config-4
-Adding MetaModes to the config file
-Could the problem be the KVM switch? (I don't believe this since everything looks crisp on the Windoze box)

I would really like to work to get this problem resolved, since this is all a precursor to building a new box this summer and making it a dual boot system, but staying in Linux as much as possible. I am just so sick of Borgware.

Thanks in advance for any pointers/suggestions/etc...

whig 05-06-04 12:51 AM

Re: RIVA TNT2/MDK 10/Screen resolution
 
Your 1024 mode has a v refresh of 85.6, but your range only goes up to 85 (and your X log doesn't drop it for some reason). Put in a mode for 1280 and extend the refresh range to the capability of your monitor. Get your display info this way: xdpyifno | less

whig 05-06-04 01:02 AM

Re: RIVA TNT2/MDK 10/Screen resolution
 
Another thought: TNT2 cards are very old, may not support high resolutions.

Thunderbird 05-06-04 04:32 AM

Re: RIVA TNT2/MDK 10/Screen resolution
 
Although TNT2 cards can be called old, they are new enough to support resolutions upto 2048x1536 perhaps not at such high refresh rates supported on modern hardware.

To calculate modelines for example use this:
http://www.sh.nu/nvidia/gtf.php


All times are GMT -5. The time now is 04:18 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.