nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   Microsoft Windows XP And Vista (http://www.nvnews.net/vbulletin/forumdisplay.php?f=11)
-   -   Win XP problem with regards to CD ROM (http://www.nvnews.net/vbulletin/showthread.php?t=285)

MUYA 08-01-02 11:56 AM

Win XP problem with regards to CD ROM
 
Dear nvnews regulars, good to be back on the forums after the purile attempts for attention dirupted and destroyed the old fourm. I hope that further attacks as those seen a few days back will not happen as this board happens to be the only board I visit regularly.

Now folks, I have particular problem in WInXP pro. This problem is that I have a CD-ROM, Samsung one which is connecetd to the secondary IDE channel and to slave connecter (device 1). Now on my previous installation of WinXP, I had set the secondary IDE channel settings of device 1 in the advanced settings' setting to DMA if available. I used to get "multi-word dma 2" or something..

Now in this fresh install, the settings are the same "DMA is available" but the setting is reported to be "PIO mode only" for this device 1. I have tried everything from moving the cd rom to the master (device 0) etc and deleted from teh device manager to have it detected bby WINXP again etc and nothing works. Anybody have any clues?
Also in win2k pro and server install, both OS report that particular CD_ROM to be working in dma mode.
I hate PIO mode, hogs the CPU 100%, so slow in copying files for cds and insatlling games!!

any help appreciated.
MUYA

volt 08-01-02 12:17 PM

Here is what you might try:

Did you have VIA 4 in 1 installed on your previous installation ? If not you would definetly want to install those because it will change your IDE settings to appropriate ones. As the last resort I would try installing IDE miniport driver from VIA. You can download them here:

http://downloads.viaarena.com/driver...DE_MPD3014.zip

Once you install it, run it and change your settings to DMA and reboot.

|JuiceZ| 08-01-02 06:05 PM

yea assuming that yer on a via chipset, I would definitely recommend d/ling the 4in1 drv's. After that if you manually change the option in device mgr it should retain the setting if yer cdrom supports that mode, which you said it does. Other than that, I would double check yer bios settings.

MUYA 08-02-02 10:50 AM

Thanks for the reply, but I managed to sort it out. I re-installed the default winxp ide driver again. It (cdrom) works in dma mode. I tried all via 4 in 1 but it didn't seem to work. Anyway thanks guys!

MUYA

eL_PuSHeR 08-03-02 09:51 AM

Yes, I'm having this issue, too. I have found out that DMA (or UDMA) mode just gets disabled from time to time. The only way I have discorevered to prevent this is to AUTODETECT all drives at startup. Just set them to AUTO in your bios. Startup process should last a little more but your DMA settings will remain.

Forgot to mention that you may need to delete primary or secondary IDE channel (or both) and reboot to let windows recognize them again. After that, manually adjust access mode if neccesary.


All times are GMT -5. The time now is 06:01 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.