nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Getting GLX to work ... (http://www.nvnews.net/vbulletin/showthread.php?t=28532)

ibm2080 05-09-04 08:44 AM

Getting GLX to work ...
2 Attachment(s)
Hi all,

I have read a few posts and searched the web to try and fix my problem, but no luck till now.

I am writing this post from debian with nvidia drivers v.1.0.5336. So the drivers work. I even see the nvidia logo at the startup of my X server. However, I should point out that I did not use the nvidia installer, but I used the debian packages to build and install the drivers along side my kernel. I followed this site's advice to the letter Debian-nVidia HOWTO (A great reference by the way). All works except that in XFree's log, I get the error message "Failed to load GLX". I tried to run an OpenGL app, but my X server crashes just like if I hit ctrl-alt-backspace.

I tried to set the verbosity level to the highest using "XFree86 -logverbose 10" but it did not print anything more than the message I quoted earlier. I'll attach my config file and the log file I got at verbosity 10. (All renamed to .txt)

I hope someone can help me figure out how to solve this. Or at least where the problem might be ;-).


hppnq 05-09-04 09:59 AM

Re: Getting GLX to work ...
You are apparently using the XFree provided GLX. The Nvidia driver is shipped with its own GLX extension, and you should be using that (you can tell because it will say that the vendor is Nvidia in the X log). I think there's a package called nvidia-glx, you will probably have to install that.

ibm2080 05-09-04 01:01 PM

Re: Getting GLX to work ...
Thx hppnq for your prompt reply.

However, I did install nvidia-glx.

The four main steps to install the nvidia drivers the debian way mentioned in the link I provided are:
1. Install the kernel module source.
2. Build and install the kernel and kernel module.
3. Install the user-space libraries.
4. Update your configuration.

Step #3 is installing the nvidia-glx package.
I tried uninstalling it and see what would happen, but my x server would not even start until I installed nvidia-glx again. So I guess part of nvidia-glx works, but what I would like is some better debugging tools other than my XFree log file that does not help at all.

Is there a way to manually load nvidia-glx and see what it prints out as errors? I can work outside of my X session if needed.

Thanks in advance,

coroner 05-09-04 03:21 PM

Re: Getting GLX to work ...
well, first thing i could see is, that you load the GLCore module in X. Comment it out in XFree86Config-4 file and try again, I don't know, if that's related to your problem, but as can also be seen in the README of the nvidia-driver, one shouldn't load the GLCore module together with the nvidia driver.
ohh, I see youre not explicitly loading GLcore in your config-file, anyways it gets loaded by the Xfree-supplied glx module. Seems that your nvidia-glx package didn't install right.

hppnq 05-09-04 03:37 PM

Re: Getting GLX to work ...
In /usr/X11R6/lib/modules/extensions, check whether the Nvidia GLX extension is there;
it most probably has the version 1.0.5336 appended to it, and there should be a symbolic link pointing to it. So, you should have something like

lrwxrwxrwx 1 root root 18 Apr 16 01:08 libglx.so -> libglx.so.1.0.5336
-rwxr-xr-x 1 root root 647268 Apr 16 01:08 libglx.so.1.0.5336

The extension you are loading is called libglx.a, that's the one provided by Xfree86. You can remove it or move it to another directory.

If you only have this libglx.a, something must have gone wrong while installing nvidia-glx. Try installing the Nvidia driver the Nvidia way instead of the Debian way then. ;-)

Otherwise, removing the file libglx.a will most probably solve your problem.

(There is no need really to turn on more debugging, the problem is definitely loading the wrong extension.)

ibm2080 05-11-04 07:17 AM

Re: Getting GLX to work ...
Thx a lot both of you for the help. The problem is fixed using hppnq suggestions. You were right, I had both libglx.so and libglx.a in the extensions directory. I removed the latter, rebooted, and tata. I can't thank you enough.

coroner, I think you were right too as my extensions directory also includes the following (after I removed libglx.a):

-r--r--r-- 1 root root 2100472 Feb 28 04:23 libGLcore.a
-r--r--r-- 1 root root 15556 Feb 28 04:23 libdbe.a
-r--r--r-- 1 root root 29432 Feb 28 04:23 libdri.a
-r--r--r-- 1 root root 155910 Feb 28 04:23 libextmod.a
lrwxrwxrwx 1 root root 18 May 4 23:51 libglx.so -> libglx.so.1.0.5336
lrwxrwxrwx 1 root root 34 May 4 23:51 libglx.so.1.0.5336 -> /usr/lib/nvidia/libglx.so.1.0.5336
-r--r--r-- 1 root root 23520 Feb 28 04:23 librecord.a
-r--r--r-- 1 root root 38330 Feb 28 04:23 libxtrap.a

As you can see the libGLcore.a is there, and I guess libglx.a used to load it.

My question now is why didn't the installation of nvidia-glx remove it by itself? But hey, I don't really need to know, do I? hehe.


hppnq 05-11-04 07:30 AM

Re: Getting GLX to work ...
Great! Now, have fun! (This was already a lot of fun, huh? ;-)

All times are GMT -5. The time now is 07:33 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.