nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Abit Silura GF4 TI 4200, problems with twin view... (http://www.nvnews.net/vbulletin/showthread.php?t=2861)

nekstrom 10-14-02 04:48 PM

Abit Silura GF4 TI 4200, problems with twin view...
 
Ok, here is the problem. I am trying to use twin view with the mentioned card. I can use two monitors just fine in Windows XP, however in X I can't get the second screen to show up. I don't get any errors, it just acts like the other screen doesn't exist. Here is my XFConfig stuff...
Section "Device"
Identifier "ABitGF4"
Driver "nvidia"
BusID "PCI:1:5:0"
Option "TwinView"
Option "SecondMonitorHorizSync" "30-107"
Option "SecondMonitorVertRefresh" "65-160"
Option "TwinViewOrientation" "RightOf"
Option "MetaModes" "1600x1200,1600x1200;1600X1200,1280X1024;1280x1024 ,1280x1024; 1024x768,1024x768"
Option "ConnectedMonitor" "CRT,CRT"
EndSection
Section "Screen"
Identifier "TwinView Screen"
Device "ABitGF4"
Monitor "Phillips201B"
Option "ConnectedMonitor" "CRT"
DefaultDepth 24

Subsection "Display"
Depth 8
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 16
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
Subsection "Display"
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
ViewPort 0 0
EndSubsection
EndSection
Section "ServerLayout"

# The Identifier line must be present
Identifier "Simple Layout"

# Each Screen line specifies a Screen section name, and optionally
# the relative position of other screens. The four names after
# primary screen name are the screens to the top, bottom, left and right
# of the primary screen. In this example, screen 2 is located to the
# right of screen 1.

Screen "Screen 1"

# Each InputDevice line specifies an InputDevice section name and
# optionally some options to specify the way the device is to be
# used. Those options include "CorePointer", "CoreKeyboard" and
# "SendCoreEvents".

InputDevice "Mouse1" "CorePointer"
InputDevice "Keyboard1" "CoreKeyboard"

EndSection


Can any one tell me if I am doing something wrong here?

Andy Mecham 10-14-02 04:54 PM

Please post a copy of your /var/log/XFree86.0.log file.

--andy

nekstrom 10-14-02 05:13 PM

1 Attachment(s)
Ok, here it is

Andy Mecham 10-14-02 06:30 PM

*snip*
(**) NVIDIA(0): Option "ConnectedMonitor" "CRT"
...
(WW) NVIDIA(0): Only one display device connected; disabling TwinView

This is the problem. Can you change the top line to

"ConnectedMonitor" "CRT,CRT" in your Screen section as well (or just commenting it out)?

--andy

bwkaz 10-14-02 06:31 PM

You might want to comment the Option "ConnectedMonitor" "CRT" line in your Screen section, and see if that helps.

Not the one in the Device section, just the one in the Screen section.

Edit: beaten by Andy... ;) Of course, I didn't "cheat" and look at your log file, this suggestion was just a guess... :p

nekstrom 10-14-02 06:50 PM

That was the problem...
 
Ok, so It was the Option "ConnectedMonitor" "CRT". I should have noticed that sooner. Now does any one have any ideas on how to make it so that each head is a different screen? So that instead of having one giant desktop I have two desktops?


All times are GMT -5. The time now is 01:09 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.