nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   MDK9 : Failed to initialise the NVdriver kernel module (http://www.nvnews.net/vbulletin/showthread.php?t=2865)

morden 10-14-02 05:36 PM

MDK9 : Failed to initialise the NVdriver kernel module
 
Hey all, i know, i know, another mandrake problem ;)

First things, heres what i've done

tried installing 2880 from rpm's
then i tried the latest version
after that i decided to read here
installed kernel source
deleted any old copies of NVdriver
compiled kernel fine from .tar file
installed GLX from the rpm
edited my X Config, dri and glcore werent present, so changed my driver from "fbdev" to "nvidia".

tried a startx and got

Error: Failed to initialise the NVdriver kernel module

I have a Winfast Geforce 4 ti 4200

any ideas?

bwkaz 10-14-02 06:18 PM

Try an /sbin/modprobe NVdriver as root first (this loads the nVidia kernel module). Then see if you can run X. The problem with this fix is that it doesn't fix anything after a reboot, only until you shut down.

If you can run X, then make the change persistent by editing /etc/modules.conf, and adding a line looking like this:

alias /dev/nvidia* NVdriver

Save and exit, and run /sbin/depmod -a to update the module dependencies (this has to be run every time you edit /etc/modules.conf, otherwise you'll get warnings when you try to load modules -- not a huge deal, but it's easy enough to fix). Once you do this, you should be able to reboot, and X should load fine after that.


All times are GMT -5. The time now is 04:15 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.