nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   nForce and Red Hat 8.0 (http://www.nvnews.net/vbulletin/showthread.php?t=2873)

florin 10-15-02 12:28 AM

nForce and Red Hat 8.0
 
I cannot make the nForce drivers work with Red Hat 8.0
I got the src.rpm, i rebuilt it on my system, but when i try to insert the module, i get an error message saying that the kernel was built with gcc3 while the module was built with gcc2 and that does not work.
But i'm sure the module was built with gcc3!

mtrr 10-15-02 06:43 AM

redhat patched modutils, get a clean version to get rid of that message.

btw: the driver has a binary only component, and that has been compiled
with a 2.xx compiler, therefore the message



cheers

florin 10-16-02 01:29 AM

it works now
 
Someone from nVidia told me to run insmod -f :-) Silly me, i should have tried that from the beginning.
They also told me they'll release a new version soon.

mtrr 10-16-02 01:39 AM

glad to hear that

cheers

florin 10-16-02 01:44 AM

the video drivers are fine
 
BTW, the GeForce drivers themselves are running without any problems. It's only the nForce motherboard driver that has the insmod issues.

Andy Mecham 10-16-02 01:46 AM

Quote:

They also told me they'll release a new version soon.
AHA! Leaking information! ;)

Glad to hear it's working for you now.

--andy

florin 10-17-02 12:34 AM

a neat solution
 
Basically, if you run insmod -f nvnet, the driver is loaded. But the startup scripts don't want to run "insmod -f", so you may be tempted to put it in rc.local.
However, there's a neat solution to it. Don't modify rc.local. You can still trick your startup scripts to force the module insert.
Just add this line to /etc/modules.conf:

install eth0 /sbin/insmod -f nvnet

This way, when the startup scripts try to install the nforce module, they are told to actually attempt a forced insert.

Also, make sure you have this line in modules.conf:

alias eth0 nvnet

(but that should be added already by the nforce driver RPM)

Tr@sH#e@D 10-17-02 11:26 AM

1 Attachment(s)
guys..
somebody please gimme the redhat 8.0 nforce drivers..or gimme a link ..
and btw any hot tips on how to avoid the usual bugs which come with installing linux on the nforce platforms.. i still get nightmares when i remember the trouble and manipulations i had to do to install rehhat 7.3
:p


All times are GMT -5. The time now is 02:32 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.