nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Pb with FX5900XT + 2.6.6 : nvidia drivers swpet out ... (http://www.nvnews.net/vbulletin/showthread.php?t=28742)

nemesis_rebirth 05-14-04 10:40 AM

Pb with FX5900XT + 2.6.6 : nvidia drivers swpet out ...
 
3 Attachment(s)
Hi all
I recompiled a new kernel 2.6.6 for my debian. (i was on 2.6.5)
After that, i reinstalled nvidia drivers for my new kernel ...
...no problem...
then i switched my computer off, and the next day, when i reboot ...
Unable to load X
I reinstalled the drivers, then restarted X ... no problem
and the next day when i turned the computer on ..
unable to load X again lol
well i reinstaled the drivers, and it is now working ...
anyway, i'm quite sure that tomorrow, when i will turn the computer on ...
I will again have to reinstall nvidia drivers ^^

Eh if anyone knows what it is due to, please tell me

Here are my logs and config file

Please help me, having to reinstall drivers each time i boot is quite borring :bash:

hppnq 05-14-04 11:06 AM

Re: Pb with FX5900XT + 2.6.6 : nvidia drivers swpet out ...
 
Have you got a line like "alias char-major-195 nvidia" in /etc/modprobe.conf?

I don't see why you should have to re-install the driver. If X won't start it's probably because you haven't got the nvidia kernel module loaded. Try 'modprobe nvidia' and then 'startx'. Does that work for you?

nemesis_rebirth 05-14-04 11:16 AM

Re: Pb with FX5900XT + 2.6.6 : nvidia drivers swpet out ...
 
Well the content of my modprobe.conf is nearly nothin :

# Place your local directives here.


# This line loads the part of the modprobe configuration managed with
# update-modules(8) and built from the contents of /etc/modprobe.d/.
include /lib/modules/modprobe.conf

but the line is in my modules.conf (even if i don't know what that means ^^)
Code:

3zechiel:/home/hugo# cat /etc/modules.conf | grep nvidia
alias char-major-195 nvidia
### update-modules: start processing /etc/modutils/nvidia-kernel-nkc
alias char-major-195 nvidia
### update-modules: end processing /etc/modutils/nvidia-kernel-nkc

I will test modprobe nvidia tomorrow if it bugs again :D
But if anyone has an answer ...
:clap:

nemesis_rebirth 05-14-04 12:18 PM

Re: Pb with FX5900XT + 2.6.6 : nvidia drivers swpet out ...
 
Ok i rebooted and got one more time this problem
I tried doing
modprobe nvidia
and it printed nothing, and when i tried startx i had the same error
I also tried adding the line your mentionning
alias char-major-195 nvidia
in modprobe.conf, but again there was no change ...

so i reinstalled the drivers lol
anyway, the installer says something about "tainted"
i dont know what it means, but maybe ther can be a relation?
:retard:

help required :D

Serial_Killer 05-14-04 09:30 PM

Re: Pb with FX5900XT + 2.6.6 : nvidia drivers swpet out ...
 
whoooooooooooooooooooooooooooooooooooooooooooooooo oooooooooooahhh
I'd hate to be in your shoes right now lol

nemesis_rebirth 05-15-04 04:31 AM

Re: Pb with FX5900XT + 2.6.6 : nvidia drivers swpet out ...
 
One more reinstall today :D
Hey , don't be shy, come and help me :D
(kngt)
and really, i don't like being in my shoes lol :D


All times are GMT -5. The time now is 09:52 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.