nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   GeForce 5650 GO - Linux (gentoo) problems (http://www.nvnews.net/vbulletin/showthread.php?t=28947)

the_eternal 05-19-04 12:52 PM

GeForce 5650 GO - Linux (gentoo) problems
 
I'm running on a inspiron 8600 laptop with a geforce 5650 with a 1680x1050 screen.

I've tried getting the nvidia-kernel and nvidia-glx drivers working with my the system in gentoo linux. After compiling / loading and cofiguring everything as it should work x11 just crashes (ctrl-alt-backspace etc.. doesn't work, it's just completely crashed). The 'nv' drivers do work tough, but that's without opengl support offcourse.

After i do a hard reboot most of the times the nvidia-kernel drivers have 'corrupted' some way and sometimes even the xorg.conf is corrupted (contents are @^@^@ etc... - the same happened with xfree).
And after the reboot the x11 config files don't show any errors/bugs/problems either... I've only tried the latest 5336 nvidia drivers tough, i'm not sure if it's usefull to try older drivers?

I'm currently running on the 2.6.6-mm kernel but i also tried the 2.6.5-mm kernel (exactly the same problem).

I really hope someone has a solution or knows what could possibly be wrong.

Thanks.

the_eternal 05-20-04 04:45 AM

Re: GeForce 5650 GO - Linux (gentoo) problems
 
bumpy :p

Sajre 05-21-04 12:16 PM

Re: GeForce 5650 GO - Linux (gentoo) problems
 
I've had the same problem with my gentoo install. I am using the newest love-sources and it was a fresh 2004.1 install just a week ago. I used to have the nvidia driver working really well on my gentoo system but any time I startx with the nvidia driver I get the error no screens found. works perfectly fine with the nv driver. My logs can be found at this thread. Trying to get away from Windows, if I could get this working I would have everything I need.

the_eternal 05-21-04 01:13 PM

Re: GeForce 5650 GO - Linux (gentoo) problems
 
I found the solution to run the nvidia drivers. Altough i tought i tried them before it's the solution you can find on more places:
* use 2.6.5 or a 2.6.6 kernel source where you can select the stack size (in kernel hacking) (re-make/install offcourse)
* do NOT select 4k instead of 8k stack size in the kernel hacking section of your menuconfig
* make sure you point /usr/src/linux to your current kernel folder
* re-emerge nvidia-kernel and nvidia-glx
After you reboot they 'should' work (worked here, altough it didn't work earlier when i tried, might be a mistake on my fault tough ;-)
(opengl-update offcourse and modify your xfree/xorg config)

Another solution is to wait for an nvidia driver which supports 4k stack size and use nv drivers for the time beeing.


All times are GMT -5. The time now is 01:13 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.