nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Fedora Core 2 - lockup problems (http://www.nvnews.net/vbulletin/showthread.php?t=28954)

Omnifarious 05-19-04 03:07 PM

Fedora Core 2 - lockup problems
 
I originally posted this in the general Linux forum, rather than this, the graphics card forum. I'll try to delete it from the other forum because it doesn't belong there.

I've had problems with the nVidia drivers for both Fedora Core 1, and Fedora Core 2. They freeze the system at the very beginning of the X startup process. I think this has something to do with AGP support, but I can't be sure.

I was able to get the nVidia drivers to work with one Fedora development kernel, but no others. That kernel was 2.6.1-1.43. Even then, my display went strange when I switched back to a text console.

Now, with FC-2, I can't go back to that old kernel because FC-2 requires things that are in newer 2.6 kernels. But, I also can't get the nVidia drivers to work. I suspect there is something about my specific motherboard that causes the problem. I've played with the NvAGP settings, and that hasn't changed anything.

Here's what I know:

lspci output for the AGP bridge:

00:00.0 Host bridge: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Host Bridge Subsystem: VIA Technologies, Inc. VT8377 [KT400/KT600 AGP] Host Bridge
Flags: bus master, 66Mhz, medium devsel, latency 8
Memory at d0000000 (32-bit, prefetchable)
Capabilities: [a0] AGP version 2.0
Capabilities: [c0] Power Management version 2

lspci output for the nVidia card, without their driver loaded:

01:00.0 VGA compatible controller: nVidia Corporation NV25 [GeForce4 Ti 4600] (rev a3) (prog-if 00 [VGA])
Flags: bus master, 66Mhz, medium devsel, latency 32, IRQ 11
Memory at e8000000 (32-bit, non-prefetchable)
Memory at d8000000 (32-bit, prefetchable) [size=128M]
Memory at e0000000 (32-bit, prefetchable) [size=512K]
Capabilities: [60] Power Management version 2
Capabilities: [44] AGP version 2.0

Package I compiled from:
NVIDIA-Linux-x86-1.0-5336-pkg1.run

/etc/modprobe.conf
alias char-major-195* nvidia

Relevant sections of xorg.conf, as they are when I try to use the nVidia drivers:
Section "Module"
Load "dbe"
Load "extmod"
# Load "fbdevhw"
Load "glx"
Load "record"
Load "freetype"
Load "type1"
# Load "dri"
EndSection

Section "Device"
Identifier "Videocard0"
Driver "nvidia"
VendorName "NVIDIA"
BoardName "NVIDIA GeForce 4 Ti 4600"
Option "NoLogo" "false"
Option "CursorShadow" "true"
Option "RenderAccel" "true"
Option "NvAGP" "1" # I've tried 2 and 3 here as well.
EndSection

Section "Screen"
Identifier "Screen0"
Device "Videocard0"
Monitor "Monitor0"
DefaultDepth 24
SubSection "Display"
Viewport 0 0
Depth 24
Modes "1600x1200" "1280x1024" "1024x768" "800x600" "640x480"
EndSubSection
EndSection

If it matters, I have a Samsung SyncMaster 213T LCD monitor.

I'm using the stock FC-2 kernel package: 2.6.5-1.358

-----------

I do not like that nVidia close sources their drivers. By close sourcing their drivers, nVidia loses the ability to effectively track kernel changes. And this causes me no end of headaches and frustration. Each and every time I upgrade my kernel, installing the nVidia drivers is an adventure that I do not relish. I want to develop software, and/or play games. I do not want to spend 3 days fiddling with stupid little technical details that would baffle the average computer user.

I can almost swallow their arguments for the video card drivers, but I can't even begin to comprehend what insane rationale they have for close-sourcing their chipset drivers. I will never use an nForce chipset until I can use it effectively without loading any proprietary nVidia drivers.

I'm sorry that I'm not obsequiously thankful that nVidia would deign to support lowly little Linux. They derive plenty of benefit from the Open Source nature of Linux in their own development labs where they make extensive use of it for hardware simulations and other such tasks. They need to rethink their attitudes. Someday someone will top them using a strategy that embraces Open Source instead of fighting it. Personally, I can't wait. And if I'm in a position to help make it happen, I will.

dschueths 05-19-04 03:51 PM

Re: Fedora Core 2 - lockup problems
 
I also loaded the 5336 driver for Fedora Core 2 Final on a test machine. X starts up but as soon as I run any OpenGL application, the screen goes black and the system hangs. No errors in any log files. I guess we will have to wait until the next driver release. I also like things to work out of box and not have to tweak anything just to get it to work.

Omnifarious 05-19-04 04:05 PM

Re: Fedora Core 2 - lockup problems
 
I managed to get it to work after hand-compiling a 2.6.6 kernel. I don't like doing that because I like having a system like up2date helping to keep me from being hacked. But, I did get it to work. I had to turn off the 4kb stack option of course.

Even now it still doesn't work quite right. When I switch back to a text console, it shows up very strangely.

I think it was the 4kb stack option in the Fedora kernel that was causing it to behave badly.

And, for the average person, what I had to do to make all of this work would be incomprehensible gibberish. I help several friends maintain their own Linux installations, and the only one I ever really have to pay regular attention to is the one that has an nVidia card.

slriv 05-19-04 07:57 PM

Re: Fedora Core 2 - lockup problems
 
I'm baffled that Fedora Core 2 was even released with this big a hole in it. Distributions need to think about their customer base before they start dumping 'geeky' kernel options that break most people's machines.

Kamel 05-19-04 08:16 PM

Re: Fedora Core 2 - lockup problems
 
heh, i don't like fedora... red hat is good and serves the linux community right -- but only in the corperate world. for a desktop computer, i don't think redhat or fedora are good ideas.

Omnifarious 05-19-04 09:37 PM

Re: Fedora Core 2 - lockup problems
 
Quote:

Originally Posted by slriv
I'm baffled that Fedora Core 2 was even released with this big a hole in it. Distributions need to think about their customer base before they start dumping 'geeky' kernel options that break most people's machines.

Well, yes, but that's another story. But, one interesting thing is that this wouldn't happen if nVidia would Open Source their drivers. Either the Fedora people wouldn't set the geeky kernel option because it breaks one of the drivers, or someone would fix the driver so it worked again. As it is, nobody feels any obligation to accomodate the other in any way.

You see this all the time in the proprietary world when you don't have an evil, controlling force like Microsoft calling the shots. It's glaring and unpleasant when it rears its ugly head in the Open Source world.

LordMorgul 05-19-04 10:32 PM

Re: Fedora Core 2 - lockup problems
 
Personal opinions about the distro aside.. the kernel option was left in for release specifically to aid the community (at large.. meaning linux in general) begin to accept and work through the problems with this kernel change. It is a good thing.. and is here to stay.. all distros will have to either undo the change or embrace it themselves soon enough.

This is a known problem.. has been known from just before from FC2 test 2. Search this forum for more detailed discussions. There is a way to fix the issue, and yes it requires recompiling your kernel. Fedora is not targeted as a production or enterprise distribution, but an up2date (pun) hobbyists distro. Compiling the kernel is not the end of the world, and it does not indicate that Fedora is a bad distro.

This is ultimately an nVIDIA problem, and presumably will be fixed soon.
This issue should not be surprising people.. the driver does not specifically mention support for Fedora and there is plenty of evidence here of the problem for those that look early.

ogetbilo 05-19-04 11:07 PM

Re: Fedora Core 2 - lockup problems
 
Can anybody who got this working in FC2 please at least post his .config file here?
I tried a dozen things. No hope, its not working:(

Omnifarious 05-19-04 11:34 PM

Re: Fedora Core 2 - lockup problems
 
1 Attachment(s)
Ask, and you shall recieve. Here is the .config file I used for my 2.6.6. Keep in mind that I disabled a few things I knew I would never use. I'm guessing hardly anybody with a desktop system will use them, but they include things like PCMCIA.

ogetbilo 05-19-04 11:56 PM

Re: Fedora Core 2 - lockup problems
 
thank you omnifarious!:)
I am now trying a 2.6.2 kernel. as soon as I am done I will try yours on 2.6.6. Did you use stock kernel?

Omnifarious 05-19-04 11:58 PM

Re: Fedora Core 2 - lockup problems
 
Yes, I used a stock 2.6.6 kernel.

ogetbilo 05-20-04 03:22 AM

Re: Fedora Core 2 - lockup problems
 
THANK YOU so much!

I now got it working with a 2.6.6 kernel!:)

However, still no success with a 2.6.5 kernel but who cares?:)


BUT one small problem arose along the way. I couldn´t get past the nvidia login screen. The X crashed and gave the error:

Fatal server error:
Could not open default font ´fixed´:

looks like the is an incompatibility with the font server xfs.(no, my harddrive is not full:)) So I opened the xorg.conf and commented out the line

FontPath ¨unix/:7100¨


and now it works.


Is it OK to comment out that line?


All times are GMT -5. The time now is 04:14 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.