nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Unable to play ET because of sound -- kernel 2.6 (http://www.nvnews.net/vbulletin/showthread.php?t=29074)

4xel 05-22-04 03:01 PM

Unable to play ET because of sound -- kernel 2.6
 
Hi,

i just installed the nvidia drivers and etc in debian unstable for the stock kernel 2.6 and everything seems fine, except the game hangs at startup trying to init the audio ... i'm pretty sure i't's some ALSA thing cause i've had problems with other stuff, anyone know the quick fix or, at least, the commandline switch to disable sound in ET?

Thansks

Kamel 05-22-04 04:26 PM

Re: Unable to play ET because of sound -- kernel 2.6
 
most likely something is posessing your sound card -- and most likely it's arts sound daemon (if you use KDE).

the easiest fix for this is to go into control center, click the + next to sound and multimedia, click sound system, and the bottom where it says "auto-suspect sound system if idle for:" set this to 0 seconds.

start up ET (do this by typing et into a terminal window, not by clicking an icon), and see if it works. if it doesn't, paste the error msg here pls.

4xel 05-22-04 06:08 PM

Re: Unable to play ET because of sound -- kernel 2.6
 
Heh, that was it. I'm not using KDE but gnome, so it was esd using the soundcard. As a workaround, i simply changed the 'et' script to do:

#!/bin/sh
killall esd
...run et here
esd &
exit 0

... and it works perfectly now. Now, if you excuse me, i have an allied invastion to stop. Cheers!


All times are GMT -5. The time now is 03:57 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.