nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   Problem: glxgears hangs (debian, nvidia 5336) (http://www.nvnews.net/vbulletin/showthread.php?t=29106)

Nuanda 05-23-04 04:11 PM

Problem with glx on debian: glxgears hangs (knoppix3, nvidia 5336)
 
4 Attachment(s)
Hi,

I run Knoppix 3.3 (similar to Debian Sid) and I have GeForce 2 MX on board. Already downloaded NVIDIA 5336 driver and installed it (with Nvidia installer). All the changes in X xonfiguration file are done according to the Nvidia README manual (driver=nvidia, glx+, dri-, GLcore-).

Problem: glxgears shows chaotic colorful screen (in full-screen mode) and hangs whole system completely - I need hard reboot! However, glxinfo seems to output proper values (to me, at least).

There is no old libglx.a library version in extensions subdirectory.

I've tried with NvAGP = 1 and 3 (default, I suppose) - both with the same effect: X-Windows run smoothly, glxgears hangs the whole system.

No meaningful error/warning messages in X server start log apart from strange "Failed to verify AGP usage" line. However, when running xdpyinfo I can not see NVIDIA-GLX extension (maybe it is no longer needed with 5336 drivers, is it?).

I attach X log file, my X config file, glxinfo and xdpyinfo outputs below. I hope somebody know the right solution.

Nuanda 05-24-04 02:29 PM

Re: Problem: glxgears hangs (debian, nvidia 5336)
 
An update :). About AGP error.

I've learnt that in order to try with nvidia-provided AGP support I need to remove agpgart from being loaded on strtup. I did that and set NvAGP=1.

Now, I don't have Failed to verify AGP usage warning in XFlog file and AGP support seems to be working ok:

~$ cat /proc/driver/nvidia/agp/status
Status: Enabled
Driver: NVIDIA
AGP Rate: 2x
Fast Writes: Disabled
SBA: Disabled

Previously it was disabled.

Unfortunately, that didn't solve the problem: both glxgears and tuxracer hangs the whole system completely. I'm getting tired with this... (crazy)

Nuanda 05-25-04 03:13 AM

Update: Kano's scripts do not help either
 
Yet another update.

I've recently found and tried Kano scripts from http://kanotix.com/files/ (I've got knoppix3.3):

- install-nvidia-4496-debian.sh
- install-nvidia-5336-debian.sh

Both of them do not help :(. Everything seems to bo ok as previously: Nvidia libraries installed, AGP supported, neither error nor significant warning messages in XFree startup log BUT no 3D application work.

I've tried three of them: tuxracer, glxgears and a demo of 3D Ogre engine - all of them hangs the system, this time with a black screen (display goes off) instead of fuzzy colorful screen. The same occurs while trying both agpgart and nvidia nvagp modules.

More info: my kernel is 2.4.19, my card is detected as "GeForce 2 Ti", I've got VIA motherboard with AGPx2 port (the speed is detected correctly, see the previous post). Is it maybe a problem with my kernel version. Although I fear 2.6.5/6 a bit because I see many post from people having problem with this version and NVIDIA drivers...

Anybody experianced the same? Anyone has a slightest hint what to try next? I would appreciate the answer much.

davidics 05-25-04 03:46 AM

Re: Problem: glxgears hangs (debian, nvidia 5336)
 
I am experiencing exactly the same thing under debian testing. I just wander if it is some kind of dependency issue, are we both missing some kind of libs - dont know really. I have never seen so many crashes under a debian system than over the last couple of days trying the nvidia drivers. Its really starting to p*** me off.

If you find a solution please post here and i will do the same Good Luck.

Nuanda 05-25-04 07:46 AM

Re: Problem: glxgears hangs (debian, nvidia 5336)
 
At last some company on this thread ;).

davidicd, I've learnt from your another post that your equipment setup is quite different than mine (I have GeForce 2 + VIA board). This is a kind of relief to me, as I was starting to think this problem has something to do with my hardware configuration - but apparently it does not.

Still, it doesn't mean it's not a hardware problem, but I don't even want to think that my adapter or AGP slot may be malfunctioning... I hope this is not the case.

I also experiance occasional blank-screen lockups even not running any kind of 3D or video software (just usual desktop apps).

davidics 05-25-04 01:43 PM

Re: Problem: glxgears hangs (debian, nvidia 5336)
 
i have just tried the latest nvidia-installer and the same happens i have even tried the 1.0.4349 and still segfaults. the output from glxgears -info
glxgears -info
GL_RENDERER = RIVA TNT2/AGP/3DNOW!
GL_VERSION = 1.4.0 NVIDIA 43.49
GL_VENDOR = NVIDIA Corporation
GL_EXTENSIONS = GL_ARB_imaging GL_ARB_multitexture GL_ARB_point_parameters GL_ARB_texture_env_add GL_ARB_texture_mirrored_repeat GL_ARB_transpose_matrix GL_ARB_vertex_buffer_object GL_ARB_window_pos GL_EXT_abgr GL_EXT_bgra GL_EXT_compiled_vertex_array GL_EXT_draw_range_elements GL_EXT_fog_coord GL_EXT_multi_draw_arrays GL_EXT_packed_pixels GL_EXT_point_parameters GL_EXT_rescale_normal GL_EXT_secondary_color GL_EXT_separate_specular_color GL_EXT_stencil_wrap GL_EXT_texture_edge_clamp GL_EXT_texture_env_add GL_EXT_texture_env_combine GL_EXT_texture_lod_bias GL_EXT_texture_object GL_EXT_vertex_array GL_IBM_texture_mirrored_repeat GL_KTX_buffer_region GL_NV_blend_square GL_NV_fog_distance GL_NV_packed_depth_stencil GL_NV_texgen_reflection GL_NV_texture_env_combine4 GL_SGIS_multitexture
Aborted

again any help appreciated

Nuanda 06-03-04 09:32 AM

Re: Problem: glxgears hangs (debian, nvidia 5336)
 
Well, the problem is somewhat solved, though not the way I've expected that... :(

This was a hardware issue. I had no idea that the cooler fan was not working properly and when I tried to run something 3D, the chip heated too much and locked. To the moment that (running Windows) it was burnt completely and have never recovered...

Now, I borrowed another NVIDIA-based card, Asus GeForce 5600, and everything is all right: all the 3D applications work.

davidics, Sorry for thet news as this does not explain your problem at all.


All times are GMT -5. The time now is 09:46 PM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.