nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   NVIDIA Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=14)
-   -   SuSE81 with Nvidia Driver 3123 (http://www.nvnews.net/vbulletin/showthread.php?t=2915)

Leon G. 10-16-02 11:52 AM

SuSE81 with Nvidia Driver 3123
 
I installed SuSE8.1 and updated the Nvida driver to 3123, but still the 3d acceleration does not work. Whenever I try sax I get the message (EE) NVIDIA (0) aborting; (EE) Screen(s) found, but not a usable configuration.
I work on a i386-basis, therefore I installed the drivers for SuSE80-i386, because drivers for 8.1 i386 werent on offer. Does anybody have any idea how to activiate the 3D accelaeration???

Thanks in advance

Leon G.

bwkaz 10-16-02 01:07 PM

Well, if you're running SuSE 8.1, but installed the NVIDIA_kernel for SuSE 8.0, it will not work. You can't mix versions like that.

I didn't quite understand what you're saying about i386 -- are you not going to be using this driver on an i686 computer? (i686 is compatible with the Pentium Pro, 2, 3, 4, and Athlon (T-Bird, Duron, XP, MP at least, possibly K6-2 but I don't know for sure) processors)

If your processor is at least a Pentium Pro (in other words, Pentium, Pentium MMX, and below processors don't count), then use the i686 kernel.

What does sax do, by the way?

Leon G. 10-16-02 02:17 PM

SuSE81 with Nvidia Driver 3123
 
Well, I already told you what Sax said:
(EE) NVIDIA (0): Aborting
(EE) Screen(s) found, but not a usable configuration.

I got a Duron 1,2 GHz, but still Yast 2 tells me: Architecture: i386, so I am a bit confused about that. I already tried the SuSE81. drivers for i586, but they didn't work either. As you can imagine, I am a bit at a loss, especially as I am not an expert...

Is there anything else I can do???:confused:

Greatings
Leon G.

bwkaz 10-16-02 03:06 PM

No, sorry, I meant to ask what the purpose of sax was. Like, is it a configurator tool? Or SuSE's version of the startx script? Or something else?

i386 is the least common denominator among all the Intel-compatible (this includes AMD and Via/Cyrix) processors that can run Linux. It was also the first. So I think that's why yast says you have i386.

Have you tried the NVchooser.sh script?

sh NVchooser.sh from inside the directory you download it to.

Leon G. 10-17-02 04:04 AM

The NVchooser tells me to download GLX and kernel 1.0-2960.suse81.i386, but I can't find them on the download sites. What can I do alternativley???

bwkaz 10-17-02 09:40 AM

Hmm... you can grab either the .src.rpm files or the .tar.gz files, and build from source. Make sure you have SuSE's kernel-source RPM (from your installation CDs) installed, and that you've done something similar to make -C /usr/src/linux mrproper oldconfig dep before you try to build either of those.

Build them according to the instructions in the nVidia README file.

But what's the purpose of sax? I've never used SuSE, so I really have no idea...

Klaus-P 10-17-02 12:01 PM

Sorry for butting in the discussion!

Sax resp. sax2 is a Xf86Config writing
and video mode online-test utility more confortable than the classical
xf86config. It belongs to the SusE distro. For Xfree version 4.x sax2 and not sax
should be used.

The error message regarding to

" Well, I already told you what Sax said:
(EE) NVIDIA (0): Aborting
(EE) Screen(s) found, but not a usable configuration. "

is strange indeed for it is a typical error message of xinit one gets
if the NVdriver cannot be found or has the wrong time-stamp. modules.dep
and NVdriver must have the same last accessed stamp, etc.
A "depmode -a" should fix it.A Duron 1.2 MHz should work with 586-code
Even on my very old AMD 133 MHz it worked. That's probably not the issue here.

So my question to Leon G. is:
What does a
" find -name "NVdriver" "
reports?

Klaus-P 10-17-02 12:13 PM

Sorry, i meant " depmod -a ".

Leon G. 10-17-02 12:44 PM

Hallo Klaus P.

I may not be very experienced with Linux, but of course I use sax2 - I only quit the "2" because with SuSE 8.1 there is no sax Version...

The command "find-name" is not found, but 3Ddiag tells me that both packages for Nvidia (GLX and kernel) are properly installed, only the 3d acceleration is not use. Well, whenever I try that, I get the posted message.

I will try to download both, the tar files and again the i586 files, and then try it again.

Thanks for all your help.

Leon

bwkaz 10-17-02 04:53 PM

find-name isn't found because there's supposed to be a space between "find" and "-name" ;)

Try find /lib/modules -name NVdriver instead, because I don't know where the find command's default path is, but I always give it somewhere to start looking. Just to make sure it doesn't do anything stupid.

OK, sax (and/or sax2) is a config-file-writing tool. Don't use it!!! The same type of thing might go for this 3ddiag program.

The problem with sax at least, is that it doesn't recognize the proper way to install the nVidia drivers. So once they are installed correctly, and working, if you run sax/sax2, your config file can get overwritten, which will destroy the changes that made the nVidia drivers work in the first place (Mandrake's GUI configuration tools are notorious for this kind of behavior). Obviously this isn't good.

Just try to startx (after manually making sure the proper lines are set up in XF86Config-4), and then post your /var/log/XFree86.0.log file, I think that will help.


All times are GMT -5. The time now is 12:47 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.