nV News Forums


nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   SATA question (http://www.nvnews.net/vbulletin/showthread.php?t=30187)

darkshadow 06-17-04 11:51 AM

SATA question
I have a Asus A7N8X-Deluxe motherboard and just upgraded to kernel 2.6.7 and it changed the behavior of my sata drive. In order to even get it to boot I had to add "silicon image chipset" to the kernel or else the computer would not boot with a dma error even though 2.6.6 worked fine without it.

The drive was under /dev/sda in 2.6.6 and a hdparm would only report 2 lines "readonly, geometry"

Under 2.6.7 it is /dev/hde and gets a full output from hdparm.

My question is should I set the seagate sata drive with the same settings as my western digital ide drive or leave them as the auto-set settings by the kernel. This sata drive is used for realtime uncompressed video capture from a tv card so I need the best performance

multcount = 16 (on)
IO_support = 1 (32-bit)
unmaskirq = 1 (on)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 256 (on)
geometry = 65535/16/63, sectors = 78165360, start = 0

multcount = 16 (on)
IO_support = 0 (default 16-bit)
unmaskirq = 0 (off)
using_dma = 1 (on)
keepsettings = 0 (off)
readonly = 0 (off)
readahead = 256 (on)
geometry = 19457/255/63, sectors = 312581808, start = 0

Slartibardfast 06-18-04 06:12 AM

Re: SATA question
did you make oldconfig with the .config file from your 2.6.6 kernel?

if you had of libata would have been selected with support for silicon image.

To make your 2.6.7 behave like your old kernel quickly, make menuconfig and select the following.


Device Drivers --->
  ATA/ATAPI/MFM/RLL support  --->
      < > Silicon Image chipset support

Device Drivers --->
    SCSI device support  --->
      <*> SCSI device support 
      <*> SCSI disk support 

Device Drivers --->
  SCSI device support  --->
      SCSI low-level drivers  -->
[*] Serial ATA (SATA) support
        <*>  Silicon Image SATA support

If you want to stay with the ATA driver (I don't like it myself), I would definatly set the drive with hdparm!
Particulary the udma mode, and irq unmasking etc.

darkshadow 06-18-04 11:17 AM

Re: SATA question
I did a make oldconfig when setting up 2.6.7 but when I tried booting it gave this error "ide1 DMA timeout: stat 0x4" which may not be exact since I am just remembering off my head. then would just hang and not continue to boot. I just pulled the power from my sata drive and it booted fine. Then the only way I got it to work was add the chipset support.

Slartibardfast 06-18-04 11:33 AM

Re: SATA question
strange, that message doesn't even refer to libata, it looks more like the nforce2 ide driver. e.g. ide1 on my system is the second channel of it.

libata refers to channels as ata0, ata1 etc. Maybe try a kernel with out nforce2 ide support, just to rule it out. Then on a kernel with nf2 ide support it would be helpful to pass at boot time, hdc=none hdd=none, which would disable the second channel.


NFORCE2: IDE controller at PCI slot 0000:00:09.0
NFORCE2: chipset revision 162
NFORCE2: not 100% native mode: will probe irqs later
NFORCE2: 0000:00:09.0 (rev a2) UDMA133 controller
    ide0: BM-DMA at 0xf000-0xf007, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0xf008-0xf00f, BIOS settings: hdc:DMA, hdd:DMA

darkshadow 06-18-04 11:38 AM

Re: SATA question
Ok I just got it fixed since I remembered the problem happened when I had ehci usb enabled which the only way I think they affected each other is that they are on the same irq. So in the end I can use the old behavior as long as I have my ehci usb ports disabled. luckily my only usb devices are keyboard and mouse and I also have ohci ports.

Like I said I think the problem was explained with this dmesg output where at the end it says irq #11 was disabled. (my SATA stuff is also on irq #11)


irq 11: nobody cared!
[<c01053e3>] __report_bad_irq+0x33/0x90
[<c01054c0>] note_interrupt+0x50/0x80
[<c0105699>] do_IRQ+0xa9/0x130
[<c0103e3c>] common_interrupt+0x18/0x20
[<c011728f>] __do_softirq+0x2f/0x80
[<c0117302>] do_softirq+0x22/0x30
[<c0105701>] do_IRQ+0x111/0x130
[<c0103e3c>] common_interrupt+0x18/0x20
[<c01b4cfa>] pci_bus_read_config_byte+0x4a/0x70
[<c0264d69>] ehci_start+0xe9/0x320
[<c0114420>] printk+0x100/0x130
[<c0257ebb>] usb_register_bus+0x14b/0x160
[<c025c656>] usb_hcd_pci_probe+0x446/0x490
[<c01b7c2c>] pci_device_probe_static+0x2c/0x40
[<c01b7c5f>] __pci_device_probe+0x1f/0x40
[<c01b7c9c>] pci_device_probe+0x1c/0x40
[<c01f1c31>] bus_match+0x31/0x60
[<c01f1d20>] driver_attach+0x40/0x80
[<c01f1f7f>] bus_add_driver+0x6f/0x90
[<c01f2384>] driver_register+0x34/0x40
[<c01b7ea4>] pci_register_driver+0x54/0x80
[<c0454906>] init+0x16/0x30
[<c0442679>] do_initcalls+0x69/0xc0
[<c01003d0>] init+0x0/0x130
[<c04426e9>] do_basic_setup+0x19/0x20
[<c0100408>] init+0x38/0x130
[<c01003d0>] init+0x0/0x130
[<c0102275>] kernel_thread_helper+0x5/0x10

[<c0227db0>] (ide_intr+0x0/0x180)
[<c0258c20>] (usb_hcd_irq+0x0/0x60)
Disabling IRQ #11

Slartibardfast 06-18-04 12:09 PM

Re: SATA question
ah, do you run with IOAPIC enabled in the bios & kernel config?

on my system the sil3112 ends up with irq 18, on its own

I guess SATA is more important than USB2 any day

Best of luck,

darkshadow 06-18-04 12:18 PM

Re: SATA question
I checked and I did not have ioapic in kernel just local apic. If it will get sata alone I am going to enable it

Slartibardfast 06-18-04 12:31 PM

Re: SATA question
yeah it gives you full 24 irq support!
and if it give you any trouble you can disable it with the boot option:

All times are GMT -5. The time now is 11:06 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2015, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.