nV News Forums

 
 

nV News Forums (http://www.nvnews.net/vbulletin/index.php)
-   General Linux (http://www.nvnews.net/vbulletin/forumdisplay.php?f=27)
-   -   20% CPU load and huge number of interrupts after insertion of nvaudio kernel module (http://www.nvnews.net/vbulletin/showthread.php?t=30264)

theodor 06-18-04 12:59 PM

20% CPU load (as reported by 'top') and huge number of interrupts with nvaudio module
 
Hi all,

I've EpOX RDA3I ver 3.x motherboard with nVidia nforce2 chipset on board. The problem is that after insertion of nvaudio (the same with versions 269 and 274) kernel module the procesor (AthlonXP 2000+) have 20% load (as reported by 'top' and 'procinfo') in system state. The same with i810_audio module wich nvaudio is clone. I've observed too (with 'procinfo') very large number of interrupts generated by nforce audio subsystem after load of any module (nvaudio or i810_audio). I think 20% CPU load is effect of handling by kernel huge number of interrupts.

Does anybody have like this? What can i do?

After longtime of testing many configuration I've no more ideas.

Kernel version: 2.4.26, 2.4.24

Thanks,
Theodor

theodor 08-19-04 02:34 AM

"pci=noacpi" kernel boot option solve the problem
 
[...]
20% CPU load (as reported by 'top' and 'procinfo')
[...]

Finaly, the kernel boot option: "pci=noacpi" solved the problem. So, it looks like bug in nvaudio (nvsound from nForce new driver set too) cooperation with kernel ACPI subsystem.

Theodor


All times are GMT -5. The time now is 05:41 AM.

Powered by vBulletin® Version 3.7.1
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Copyright 1998 - 2014, nV News.